Important Update on a few Potential SketchUp 2017 issues on Windows


#1

QUICK UPDATE! In case you hadn’t heard, we just released SketchUp Pro 2018 which has some fixes that should help with some of these crashes. If you’d like to give it a try, please download the 30-day trial here.

Howdy everybody! As you may have noticed, SketchUp Pro 2017 M2 (maintenance release 2) is here! Like the earlier SketchUp 2017 releases, this release requires your system meets our minimum requirements for installing SketchUp 2017 as defined here. Make sure your system meets these requirements before installing it! To get the M2 release, launch SketchUp and select the Help > Check for Update menu item or go to this Knowledge Center article. This release contains the bug fixes documented here.

I also wanted to give an update on some issues that have been reported on the Windows operation system and potential workarounds for them.

1. We have had a good deal of reports of SketchUp crashing on launch for users with Intel graphics cards on Windows. We are seeing that this crash is usually related to an out of date Intel graphics card driver that does not play well with SketchUp 2017. If you are crashing on launch and have an Intel video card, try updating your graphics driver to see if that solves the issue. To update your driver, please try the steps found here.

Some notes:

  • We are seeing that this crash most often affects the following graphics cards:
    Intel® HD Graphics 4000
    Intel® HD Graphics 4400
    Intel® HD Graphics 4600
    Intel® HD Graphics

  • Here are some links on where to get drivers for each of the above graphics cards:
    Intel® HD Graphics 4000
    Intel® HD Graphics 4400
    Intel® HD Graphics 4600
    Intel® HD Graphics

  • If these steps don’t solve the crashing or you are having trouble getting an updated driver for your Intel video card, please try the steps found in this forum post from Yogesh. Note that it is possible that using the first set of steps your card will report that it is up to date when it is not up to date!

  • If you have a built in video card (like an Intel 4600), you may need to contact your computer manufacturer to get the latest driver (i.e., Dell, HP, etc).

  • If none of the above steps work, check that your graphics card meets our minimum requirements for running SU 2017. We have seen an Intel driver related startup crash related to using SketchUp with graphic cards using very old versions of OpenGL - e.g., OpenGL 1.4.

2. We have had some reports of SketchUp crashing when launching SketchUp or working in SketchUp for users with older AMD graphics cards on Windows. If you have an AMD graphics card and are crashing, please upgrade to SketchUp 2017 M2 as we made some fixes that could solve your crashes.

  • If you are still crashing with SU 2017 M2 and have an AMD graphics card, see this Help Center article.

3. If you have multiple video cards, you may need to set which one SketchUp uses.

  • For example, it is possible that your system has a discrete AMD graphics card and an on-board Intel graphics card and SketchUp is crashing because it is using the Intel graphics card. Please follow the steps found here to fix this issue.

4. If you are still crashing on launch or when using SketchUp and none of the above steps helped you, please try the following:

  • Please make sure that you submit a BugSplat to us - i.e., when you crash, please click the Send Error Report button when you see a dialog like the following one:

  • When you submit a BugSplat to us, if we have information about your crash that can help you, we will display it in your web browser. For example, If after submitting the crash to us you see this response pop up in your web browser, SketchUp is crashing because of an issue with the installation of the Microsoft Visual Studio C++ 2015 Redistributable that SketchUp 2017 requires to run on Windows. Please try the following:

A. Go to Control Panel > Add/Remove Programs and uninstall the Microsoft Visual Studio C++ 2015 Redistributable (There may be a 32-bit and 64-bit version. If so, uninstall both).
B. Uninstall SketchUp 2017
C. Reinstall SketchUp 2017 (you can download it here if you need it).
D. Start SketchUp

  • Please read/perform the “Crash troubleshooting steps” section of this article.

5. If you are having trouble installing SketchUp 2017, please try the following:

  • Run Windows Update prior to installing SketchUp 2017.
  • Install .NET and the C++ Runtime libraries manually. Both of these updates are prerequisites for installing SketchUp 2017. These prerequisites should be installed automatically when you run the SketchUp installer. We have though gotten a few reports where the installer was not able to successfully install .NET or the C++ Runtime libraries. Manually installing them provided a workaround.

SketchUp 2017 install error
Crashing during startup
Select Tool Delay
Black screen when start up sketch up make 2017
Layout stops when hide tray?
SketchUp 2017 won't start
Cant install Sketchup 2017 pro
Loading, opening new file very slow since upgrading to 2017
Select Tool suddenly very slow
Hangs upon opening SketchUp Pro 2017
SU Make 2017- Can not manually enter dimensions for resizing
Bug Splat SketchUp Make 2017
Graphics card and ram not recognized by Sketchup
SketchUp Pro 2017 wont launch
Reinstall SketchUp 2016 after installing 2017
SketchUp 2017 Installation Fails Under Win10
Issue for SketchUp installation
SketchUp does not work
2017 not launching
Uncoordinated Mouse
Make 2017 problems loading
New SketchUp 2017 Viewer won't launch on Windows 8.1 laptop
Tray Thumbs, Second Monitor, SU2014 (FREE)
Problem: Select tool not working (Win10 Intel HD4000)
Is it actually possible to install SketchUp on Win 7? About to give up
Sketchup 2017 Installs and wont start. NEW HARDWARE
Sketchup v 2017 and Win 7
Layout and Style will open, Sketchup does nothing on start :(
Herramienta seleccion tiene mucho lag (Lag on selection tool)
Sketchup keeps crashing on startup
Selection window box not displaying
No Tray Thumbs on Second Monitor
Sketchup Crash with GTX 1080 - Cant find read card memory - HELP
SketchUp freezes upon selection
Cannot Launch SU2017
LayOut image export problems (black areas)
SketchUp Desktop Viewer won't open
Still getting startup crash after opening 2016 Pro
SketchUp Checkup 2017 Freezes Computer before complete install
Sketchup 2018 Install error
Selection Tool process is slow, unbearably slow
Selecting takes ~5 seconds
Sketchup Pro 2018 Crashing after clicking Start Using Sketchup
Install error: Component Universal CRT (Hotfix KB2999226) has failed to install
Selecting takes ~5 seconds
Problem when downloading Sketchup 2017 for Windows 8.1 64 bit
Slightly annoyed at version reducing model download ability
Is the Intel Iris Graphics 5100 card any good?
SketchUp 2017 won't start
#2

#3

I have installed the two previous version of Sketchup Pro 2017. What is *.dmg file. When I try to open it, it is not recognized and asks me to select an ap to open it. I have never had this experience in the 10 years of using Sketchup.


SU Checkup freezes, SU2017 won't start
SU make 2017 now slow. after selection it takes 4 sec. for reaction
#4

dmg is the installer for Macs. If you are on Windows, go to the download area and get the one for Windows


#5

I’m done trying all of these fixes.So far nothing is working with 17. I’ll try rolling back to 2016 to see if that’s stable. Really frustrating.


#6

Is this just for the Onboard/Discrete situation or also those with multi GPU setups of the same card?


SU2017 New Install with Load Errors on Plugins
Installation is exiting
#7

SU17 Out of Memory Issue & Move/Ctrl to copy Crash

This has happened numerous times in SU17 for me [never in SU16 with the same computer and less ram]

I have a ASUS ROG G751JY, i7-4710HQ @2.50GHz, 64bit, 32GB ram, GTX 980M graphics [updated] running Windows 10 OS Build 14393.477.

I’m not doing anything unusual, but it seams to happen when I dive in or out of a group or component to edit it and using the hide/un-hide model [keyboard s/c].

Also SU17 has been crashing when I use the Move/Ctrl or Rotate/Ctrl place sequence. I’m getting at least 7 crashes an hour with this. There is a tell that its about to crash; you get the blue spinning wheel and I noticed the AutoSave function actively creating/deleting the tmp file in another window [on another monitor] then the crash. So I don’t know if its the Move/Ctrl or the AutoSave that is causing the crash.

Anyone else have these issues or know what is causing them?

thx in advance
R Hutniak


#8

I have a Dell Latitude E6400, it works fine. It runs SolidWorks, for god’s sake.

It won’t run SketchUp, and never will - I cannot update my graphics drivers any further.

Why have you done this?


#9

I am having same issues with SU2017 pro too… have you found a solution? Have been trying to fix this over a week and getting very frustrated with SU. Still waiting for tech support!!!

I have an ASUS ROG G752VS, i7-6820HK, NVIDIA GTX 1070 graphic card, G-SYNC, 2.7GHz, Windows 10 OS, and an ASUS swift 27 inch monitor.

I get error code that I don’t have enough memory when I do the SU check. I have lots of memory in my new laptop!! SU thinks I have less that1 MB!!

Also have problem with displaying all of the content in the tray (soften edges) like some other users and I notice that when I click on items in my toolbar it doesn’t always react and have to redo to activate them.

Hopefully someone can help us!


#10

ignore the V-RAM check of the SU CheckUp tool, it relies on faulty information of MS diagnostics tool.


#11

Thanks but have other issues ever since I updated M2 that is why I ran the checkup. I updated the driver but no change and am using a new laptop with newer graphic cards and processor - that’s why I bought it so that I wouldn’t have rendering / lag problems. Its affecting my trays and sensitivity of activating my tools - SU technician is calling me this morning to try to fix the issue remotely. Will report back once resolved. Cheers, Barb


#12

ensure with the 3D settings of the nVidia control panel that SU is configured to run on the dedicated GeForce GTX and not on the integrated intel HD/intel Iris graphics processor… with the GPU being used might be dependend on the power saving mode active… connect to AC for getting the max. performance.

Already elebaroted many times here, search the forum for further info.


#13

I don’t know how to do this - running GTX 1070. Can you please give me step by step instructions. Will try to see if I can fix myself since tech support has still not called this morning.


#14

see step 3.) of initial post above.


#15

James from SU tech support is still trying to resolve my issue with the M2 update and has looked at everything remotely but to no avail yet. In the meanwhile, they have given me access to 2016 so that I can continue working on my project. Hopefully they can solve this puzzle, but if you have any ideas your help is very much appreciated. Thank you for your continued support. Cheers, Barb


#16

Barb are you using display scaling ? SketchUp only supports 125% and 150% (for increased scaling.)
This is usually set via: Control Panel > Display > Make it easier to read what on your screen
(Using custom text sizes for dialog text might not play well with SketchUp’s inspector tray panels.)


Start button off screen - can't click it!
#17

Thank you Dan for your suggestion but yes I am aware of the display setting possibility - am using 125% even tried 100% and doesn’t help. Will check the custom text size but I think was using the default settings so haven’t customized the size. Hopefully SU tech support will find a solution - it appears that several of us have similar issues - perhaps because we have newer hardware/software that is conflicting - probably a pre-set config setting someplace - will keep everyone posted as things evolve. Hopefully SU tech support will find a solution soon. Do like Pro2017 capabilities.

Take care. Have a wonderful day. Barb


#18

You might have downloaded a Mac Version. When you down load the widows version, it will have an “.exe” extension


#19

#20

Thanks for suggestion but am definitely installing the windows version (have done it several times) - have reloaded just now and still the same - ran administrator from download folder. Hopefully James will find a fix soon. B