Sketchup 2017 Pro Locking up


#1

I have been using Sketchup successfully for about 18 months to do mechanical drawings.

After the latest W10 update, it now locks up and is unusable after about 10 seconds. It will unlock , I then move the cursor to try to perform a task and it locks up again.

I have rolled back the W10 update, deleted and then re-installed Sketchup and I still have the problems.

Has anyone solved this issue?


#2

Solved? No.

A common, reoccurring theme that appears in the link below seems to be Win 10 (and its automatic updating) and integrated Intel graphics. There are quite a few variables encompassing computer configurations, computer manufacturers (and their custom tweaking of things like Intel graphic drivers to best work with the hardware), the vintage of the Intel graphics chip (is it still getting updated drivers from Intel and/or the computer manufacturer)…

Let’s first deal with your Intel graphics. You didn’t specify what you have in your profile. An easy way to check what SU sees is from inside SU. Go to the Windows menu > Preferences > OpenGL. Click on the Details button. What does it say? If you see a version number, besides other things, it gives you a phrase to search on this forum.

Check that the Intel graphics driver is the latest and greatest. Try the computer manufacturer and/or the Intel website. Which is best will depend on how your computer manufacturer set up your machine.


Now onto Win 10 updates, the above link goes through some of the specific updates that did not play nice with SU. But there are still a few things to check:

  1. Where all the updates successfully installed? Check the Windows Update log. If something failed to install successfully, try installing it directly from the Windows Update site.

  2. Go to the Windows Update site to see if there are any updates/patches that may be useful but did not get included in the automatic update cue (some things to look for include patches to .NET Framework and VC++ - and there may be some unrelated downloads you may like to have just for giggles.)


#3

My graphics driver version is Intel HD 10.18.10.4358

I am working through some of the stuff - hopefully I can solve it.


#4

Hello, here is my feedback on the Sketchup Crash/lockup problem - I am running W10 with an i3 3.3 GHz processor and Intel HD GPU

When I went into the Device Driver in Settings and checked for the latest updates, Windows said my drivers were up to date. I down loaded ‘Intel Driver Update Utility’, installed it and ran it. It came back and identified that both my CPU and the Graphics processor had newer drivers, and asked if I wanted to make the updates, which I did.

Sketchup 2017 Pro is now working correctly

The original Intel HD driver version was 10.18.10.4358
The new driver is 15.33.45.4653

Here is the link to the Intel Driver update Utility: https://downloadcenter.intel.com/product/79577/Intel-Driver-Update-Utility


#5

AR1,
Sorry to hear you had to wrestle through this debilitating ‘glitch’ but thankful to learn that others have experienced the same problem and worked through it. This same thing happened to me about a month ago and when I searched this forum for solutions most of them centered around an automatic update sometime back in April of 2017 (linked to in catamountain’s response above). Somehow that update didn’t affect SketchUp on my computer but something else did in this recent episode. It’s frustrating because Make 2017 was working wonderfully on a new (March 2017) Windows 10 machine with an i7 processor, SSD and smokin’ Nvidia card one day and then WHAM, it was busticated the next day.
Hope something gleaned from you journey to solve the problem is the clue to mine!
Best,
Matt


#6

I found some ways for Win 10 users to at least temporarily turn off automatic updates. Most of the suggestions are for Win 10 Pro users to better manage this Win update h***hole.


#7

I went through steps outlined above in this topic and got this message:

SketchUp found the following:

  • SketchUp has detected you are using a “Intel® HD Graphics 630” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.

I have a smokin’ graphics card but don’t know how to ‘change (my) system to use the… NVIDIA card.’ I’m sure it’s simple but need ‘baby steps’ to get it done… any help is greatly appreciated! I MISS my SketchUp which is unusable with current performance :frowning:


#8

It sounds like you have a laptop. Go to the Nvidia Control Panel > 3D Settings. You should have a tab to configure settings for individual programs. When you choose SU, either at the top or somewhere in the options there should be an option to pick which graphics to use for the program.


#9

catamountain,
Sounds simple enough… but I have no clue where to find Nvidia Control Panel > 3D Settings. It’s easy to imagine that there are tabs to configure settings… once I get there :frowning:

It’s clearly a NVIDIA Quadro K1200 (I was told that was a smokin’ card anyways) but when I open the highlighted text there’s no Control Panel>3D Settings to be found. BTW this is a Dell Precision desktop system running Windows 10 Pro.

I’m sure it doesn’t seem like it but I really try hard to figure this sort of thing out on my own but get stumped by the most inane things sometimes!

Really appreciate the hand-holding for a passionate SketchUpper!


#10

The ‘smoking’ part is a sales pitch. Look at the GTX gaming cards recommended by @sketch3d_de on the forum. He keeps well informed.

The Nvidia control panel is card controlling software. I usually r-click on a blank space on the desktop > NVIDIA Control Panel. You many also find it through NVIDIA Experience icon in the taskbar located in the lower right of the Windows status bar. R-click on that icon.


#11

The frustrating part about my experience with this is that SU was working wonderfully for 6 months with whatever graphics card settings were being used by default. Then one day it quit and I’m left with the 30 second lag for any mouse click action. I updated the video card driver and try to follow countless other help topic processes and nothing is helping. With your help I was able to find the NVIDIA Control Panel but, wouldn’t you know, the ‘manage 3D settings’ option does NOTHING when I click it!:


One thing I CAN get to work is showing a GPU Utiliization graph and it just sits there while SU is running and I select or move things:

Not even a blip… seems like my graphics card can’t be smokin’ because it isn’t even lit!

Someone, somewhere could probably sit at this computer and have this problem fixed in 45 seconds but that clearly isn’t me :frowning: Thanks for trying to point me in the right direction!


#12

I understand the frustration and empathize with you. Your SketchUp installation hasn’t changed in those six months but likely all the Windows updates that come automatically, things can get balled up.


#13

If you drudged through the following thread, you’d see an issue with Windows 10 updates and how at least one update can mess with graphic settings: reverting settings for some.

What gave you got the message about using the Intel graphics over the Quadro? Ub SU, you can check your graphics through Window > Preferences > OpenGL > Graphics Card Details. Is that your source?

That GPU utilization chart is for your Nvidia card - which you report is not being used with SU. That just shows the Quadro isn’t being used.

It sounds like time to contact Nvidia support on why you cannot access the 3D settings page. It maybe a permission thing - the way the driver was installed. Did you r-click > Run as administrator?


#14

catamountain and DaveR,
I empathize with you both in trudging through these obscure issues again and again in a noble effort to keep SketchUp functional for the community! Your dedication towards the Community on behalf of Trimble is most commendable!

I tried to look at Windows update stuff but the instances cited in the forum link above seemed to focus on one in April or May so I didn’t know what to look for since I started having problems in September/October.

I’ll check into the suggestions/directions provided in your most recent response and see if I can make sense of something. You both stress the Run as administrator thing often and it might be something as simple as that I didn’t do that foundational step…

Thanks some more!


#15

The first step would be probably to try and update the Nvidia driver, either from the Dell site or directly from Nvidia.


#16

Anssi,
Thanks for weighing in on this… I was really hoping that a driver update would fix the problem but even though it needed updating it didn’t change the behavior. Off I go in search of a fix…


#17

That is indeed my source for the Intel/Quadro message. Naturally I was hoping that there was a ‘switch’ somewhere to change my preference but have’t found it. Most puzzling is where this problem crept in from because it didn’t matter before which graphics card was being used. Something minor but potent snuck in unawares and I REALLY want/need to find it and fix/reverse it soon… a backlog of SketchUp work is piling up each day I’m not able to use my favorite software :frowning:
Going to take your suggestion and reach out to NVIDIA because I’m puzzled why their video card is just sitting there doing nothing…


#18

It’s a odd situation suddenly losing access to your graphic card on a desktop. It feels like a permission issue as you cannot open the 3D Settings dialog. Whether that’s from some automatic Win10 update changing things behind your back or something else, I don’t know.


#19

Catamountain,
I’m almost as confused as ever right now but am making progress, I think.
I just ended a chat session with NVIDIA (at your suggestion, thank you!) and learned that my monitor is plugged in with an HDMI cable (the one I got with it) that is connected to the motherboard. Everything with SketchUp had been working with that cable since I first plugged it in and I didn’t know anything was amiss. BUT for the last 6 months my ‘smokin’ graphics card is just riding along like a 250lb linebacker on the back of a two-seater bike with his feet up off the pedals while the scrawny video card riding in front did all the work! That’s embarrassing!
So tomorrow I get an HDMI to mini DP adapter or, better yet, a mini DP to miniDP cable to run the monitor THROUGH the graphics card… talk about a D’uoh! moment! I’m gonna make that linebacker do double time from here on out!
That will (should?) get me to the 3D graphics settings options to see what can be done but the situation remains that SketchUp Make 2017 was working fine one day and not the next. I have high hopes of better SU performance and also video editing software performance with the new cable but may be back to this topic if there’s something else causing the delayed cursor activity… I hope you’ll still be willing to help if there is… but wouldn’t blame you a bit if you’re not :frowning:


#20

Keep posting. You’re now the second person posting in this forum about a monitor issue. The other person found out his old, second VGA monitor wasn’t compatible with his Nvidia video card. As SU is getting more picky about hardware and drivers, the same forward progress is applying peripheral hardware components.

Maybe your latest graphics driver update got a little more pickier about the cable you were using?