Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#1

Up until yesterday SketchUp Pro 2017 was working wonderfully, now it still works great with the exception of one thing: It is impossible to triple-click or double-click select because it takes about 30 seconds for the selection tool to work and highlight the object. It freezes until then. Absolutely every other function works perfectly, it just takes half a minute to select/deselect anything. A group, a face, a line, anything.

It is driving me crazy… It is not model specific either, it happens in every model I’ve opened since this started last night. I’ve updated 2017, I’ve disabled extensions, I’ve done all I have read to do to no avail.


Newest Sketchup: Select tool freezes for 7 seconds
(Solved-ish)Going Incredibly Slow
Selection Function
Fast in integrated card, slow in dedicated graphics card
Windows 10 Creator Update
Selecting takes ~5 seconds
Suddenly Time Lag after clicking select tool?
Pointer slow to respond
SU Pro 2017 Painfully Slow
Select Tool lag issue on Windows 10
SU 2018 issues, probably windows updates again?!
Sketchup make 2017 5 sec delay to select anything
Problem: Select tool not working (Win10 Intel HD4000)
SketchUp Hangs for 30 seconds every few minutes
Graphics card problems
Sketch Up 2017 Pro Runs Slow
All of SketchUp Make Tools under View/Tool Palettes stray off the SketchUp Make screen!
Was on 2015 , updated to 2017 and now very laggy
SketchUp 2017 extremely slow in rebuilding the screen
Extremely slow response time any action
SketchUp Make 2017 is not working how to fix it?
Sketchup checks online something
Make the first component required huge time
Sketchup all of a sudden not Loading. Not responding
SketchUp Make 2017 will no longer open
Orbit is sluggish in Sketchup 2017 on Windows 7
Zoom slows in simple model
SketchUp Make 2017 has started working so slow as to be useless!
Cannot Launch SU2017
Why is there a selection tool delay in SketchUp (under Windows 10)?
Herramienta seleccion tiene mucho lag (Lag on selection tool)
Pointer very slow
Outils sélectionner qui ne marche plus!
Select tool pauses for 5-10 seconds since window update
Sketchup 2017 Pro Locking up
Slow response to click
Sketchup 2017 Sélection lente
Select tool not responding
Sketchup 2017 Pro Locking up
Very slow select tool
#2

This sounds like an issue related to graphics drivers. Was there an update pushed over night with a Windows update?


#3

I’m having the exact same problem with Windows 10 and SketchUp make 2017. And yes, there was an update last night. any advice?


#4

Your profiles both indicate Intel HD graphics cards. Potentially the common denominator. Try rolling the graphics drivers back to the previous version.


#5

Thanks. I’ll give it a shot.


#6

I hope it takes care of the problem. Please report the results. You two can’t be the only ones who were “lucky” enough to get an update last night.


#7

I went through all the update stuff in settings but the option to roll back to a previous version of the driver is grayed out… Everything else I looked at seem to indicate that the graphics drivers may not have been changed in this latest update


#8

Hmmmm… What does Intel show as the most recent driver for that card? How does it compare to the version you are running?


#9

For me, that did the trick. There was an update last night as mentioned… I wish I could remember the patch ID#, but the first one on the list from 3-15-2017 was the one screwing things up for me. There were two… The first one did it after an uninstall and restart.

Thanks!

Good luck, Don.


#10

I’m glad to hear that fixed it. Maybe not a graphics driver update but something else in the Windows update?


#11

It appears so, it didn’t explicitly list any updates to the Graphics card, probably just some Windows10 wonkiness.


#12

The dreaded Windows Wonkiness. Figures. :smiley:


#13

After going through all the checks it’s telling me that everything is
up-to-date.


#14

Did you try uninstalling last nights Windows patch like @berticus did?


#15

Okay I see five installations for 3/15

One is for "malicious software removal tool"
an update and a cumulative update for Windows 10 1607
and two security updates for Silverlight and Adobe flash player

Should I uninstall them?


#16

Accrding to @berticus, it was the first one on the list he removed which fixed the problem. I guess I’d remove the first one and see if that helps before moving on to uninstall any others.


#17

Yes, it was the first actual Windows system update on the list. Not the
malicious software updates or the Adobe updates.


#18

It’s doing it now but it’s taken over 20 minutes…


#19

Hot dang! I do believe that did it!

Yeah the number on it was something like KB4013249. It was a security update for windows.

Thanks to both of you.


#20

Will it try to redo that update at some future time?