SketchUp Make 2017 has started working so slow as to be useless!

win10
slow
windows10

#1

I’ve been a user for several years and update to the latest version every time one comes out. I installed Sketchup Make 2017 a couple months ago. It’s been operating fine, without issues, until yesterday. I was beginning to design a very simple frame, beginning with a simple rectangle. Seemed like the screen simply locked up. After fussing with it, restarting several times, etc. it seemed that it was simply taking a very long time to do even the simplest commands. (I haven’t been able to get past <Push/Pull>. As soon as I triple click the result to make it a component, or anything at all, it would freeze for so long I thought the computer was locking up.)

I was able to pull up a previous project, a fairly complicated model. It came up fine but, as soon as I tried to do anything, the same thing happened. Locked up in eternal think mode.

Tried pulling up an old model in a previous version (I don’t always delete the previous version.). Same thing: the model would come up but, as soon as I tried to do anything, it would freeze.

Other applications on the computer seem fine. (Operating on an older Dell Inspiron 15 laptop with Windows 10.)

I’m not a real savvy computer guy so all of the IT chatter I see in other strings leaves me feeling really, really ignorant. Any ideas???


#2

Numerous users have reported similar problems with Win 10 auto updating (or auto breaking as I like to call it). Search the forum and you’ll see what others have done about it.


#3

The following is the most comprehensive thread on some recent MS Win10 updates that adversely affected SU:


#4

Same problem here. about 3 seconds to make a selection… Tried uninstalling last windows update and it did not help…


#5

Same advice, go to the other thread (given above by catamountain) and read about the Windows Update issues.


#6

Windows 10 Home

Sketchup 2016 and 2017

In March 2017 the selection tool started taking about 7 seconds to complete a selection. Uninstalling Windows update KB4013429 fixed the problem.

On april 22, 2017 the problem returned, this time approximately a 3 second delay started on the selection tool pick time. Uninstalling the Windows updates KB3150513 and KB4015217 fixed the slowdown issue. It is possible that it might only require the uninstall of the windows update KB4015217 to fix the problem…

Good luck…


#7

Success! I first tried uninstalling KB4015217. No change. Next, instead of uninstalling KB3150513, I went straight to uninstalling KB4013429. From many of the previous comments, that appeared to be the original culprit. Took about an hour but that seems to have done the trick. Now I guess I’ll have to turn off auto-update and just plan on doing them manually.

Thank you everyone for your inputs. No way could I have figured this one out on my own!


#8

After watching all the issues , I wonder how much is related to the BIOS , chipset, Intel Management Engine updates. I do not know about the Apple and AMD platforms.
Just to toss something else in the mix.


#9

The problem has returned! My model comes up fine but, as soon as I make any sort of selection, it takes a very long time to respond. I revisited this thread and removed the only update that I hadn’t yet removed that was mentioned by theessentialcommongood. No luck.

There have been two additional recent security updates that I am reluctant to uninstall because they are security updates, after all.

Not sure this is significant but, when I first launch Sketchup, it keeps saying that it appears that I am offline, when I know in fact that I am online.

Any other suggestions anyone? I have a couple of major projects that I’m supposed to be making progress on and my wife is trying hard not to roll her eyes. :slight_smile:


#10

You don’t list your graphics card in your profile.

In SU, go to Window > Preferences > OpenGL. Click on the details button. What are you using? If it’s some Intel integrated graphics chipset, is that graphics option you have - no Nvidia or AMD card? Whatever you have, go to the Dell site and check for driver updates.


#11

Great input! I found the graphics details: It’s “Intel® HD Graphics 4000, GL Version: 4.0.0 - Build 10.18.10.4358”. I did some searches, both on Bing and the Dell website and was unable to find anything I felt was appropriately specific. I wonder if my laptop is too old. (It’s a Dell Inspiron 15, but beyond that, I don’t know how to find additional specifics.) I bought it with Windows 8-something and did the free update to Windows 10 some time ago. Couldn’t find any Graphics downloads that referenced Windows 10 or gave me that “Aha! This is it!” feeling. (Remember, I’m not the most tech savvy user.)

Before my first post this morning, I did a fresh install of the very latest SU, just in case this issue had been resolved in the most recent release. No joy.


#12

My son stopped by to trade vehicles for a camping trip with his young sons (Memorial Day weekend…what a dad!). He’s a bit of an IT whiz and he was able to immediately do the appropriate video driver update. Reboot. Launch SU. Open model. Hold breath. Select an object…Eureka!! IT WORKED!!!

Thank you so much for the suggestion!

Have a terrific holiday weekend!


#13

Please post the driver version that works.
(Inside SketchUp : Window > Preferences > OpenGL > Details)


#14

Not sure what’s going on now. I launched SU afresh after having to reboot my computer because it black screened me for some reason, outside of SU. The video driver now shows exactly what it was before: “Intel® HD Graphics 4000, GL Version: 4.0.0 - Build 10.18.10.4358”. SU is now misbehaving the same way again. Unfortunately, I wasn’t able to follow my son’s actions very closely and didn’t think to note the driver details at the time. I will attempt to do the same thing again. When and if I get it working, I will be sure to post the driver that worked…although now I don’t really know WHAT to think.


#15

I spent a couple hours this morning simply going through my computer and using the Dell website to identify missing driver updates and walking my way through it. Performed them all. Launched SU and it seems to work just fine now. Checked the graphics driver and it is still the same as I’ve identified earlier.

I guess the lesson I’m taking away is that it pays to keep your computer healthy with up-to-date drivers. I admit that I’ve been very lax about it.


#16

Not surprisingly, from everything I’ve read here, the problem has returned and all of my efforts to restore usable functionality have failed. I ended up going through every single post from the earlier topic recommended by catamountain in post 3 and whatever related posts and topics I could find on this site.

For reference, here are my specifics:
Dell Inspiron 3521 (bought with Windows 8 and performed the free upgrade to Windows 10 a couple of years ago)
Windows 10 64-bit 1607
Intel integrated HD 4000 graphics card
Sketchup Make 2017 (not Pro)

Thought I’d just summarize all of my efforts here in the hope that somebody can see something else I can try.

Tried removing and installing several updates (current state shown below), changed graphics driver to state below (the other graphics driver 4358 didn’t work either), downloaded and ran Sketchup 2017 Checkup several times (always with SUCCESS plastered all over the results), launched dual SU sessions, varied Intel Graphics 3D settings, installed the very latest Sketchup Make 2017, and probably a few other things I don’t recall.


I’m not expecting any magic bullets here. Just crossing my fingers and hoping that Microsoft will eventually come out with an update that repairs whatever the heck is wrong. Frankly, I’m resigning myself to that, or using this as an excuse to get another computer (one WITHOUT an Intel HD 4000 graphics card!). This computer is a few years old after all.


#17

Do a search for the Intel HD graphics control panel from the Windows Start menu. Another user with Intel HD 4000 just reported they were able to change a setting to “performance”. Restart SU.


#18

Thanks, but I saw the same post and had already tried that. Someone else had posted a similar approach with the graphics panel earlier. I tried several other permutations, launching SU before and after each adjustment. No luck.


#19

This topic was automatically closed after 91 days. New replies are no longer allowed.