Selection tool very slow to select


The forums indicate that this problem is due to a windows update rendering a graphics driver non-functional (card in my case is Intel 4000). If first happened about a month ago, so I updated my graphics drivers and this resolved the problem for a while. It has now come back. Not sure why - no recent updates to my system. It occurs simultaneously with “É” being produced when I type “?”, but this is easily resolved by pressing control+shift twice. I have looked for several of the reported updates (eg KB…) that may have precipitated this on my system and have not found them. The last windows related update on my PC was 18 Oct 2017, and sketch up was working fine subsequent to that (after I updated the drivers), which are current at present.

The previous thread related to this seems to have died a few months ago, and I have tried all things on the tread, but still have the problem.

Any further advice would be appreciated.



This seems to be a common problem. I just had a user come to me and say the Surface Pro she brought to do a presentation was painfully slow to use Sketchup on. I confirmed that selecting objects was unusable. Even in wireframe. I read the threads about looking for certain KBs too and to always have the latest driver. This Surface has the Fall Creators Update and the latest GPU drivers. There is nothing else I can think to do and Sketchup support seems to be afk. If anyone has any ideas PLEASE help!


John, thanks for your added voice. I had uninstalled KB4041676, so when I went to look at installing Fall Creators update, it was recommended that I make sure the system was up to date first, which it was not as I had just uninstalled the most recent update (of October 18, 2017). So I reinstalled the KB4041676, and for interest before proceeding to install the Fall Creators update, I tried my SketchUp make 17, which to my surprise worked fine WRT the selection tool. I guess I am wondering now whether it is still a good idea to install the Fall Creators update (and potentially upset the cart again - if it ain’t broke…)


I had a Windows Update just a couple of days ago. I’m not sure to which version, but Sketchup is now very slow to select things (and activating groups and components, etc.) It is still plenty quick for navigating the model and animating from scene to scene. For now, I will presume Microsoft to be the culprit, but any updates to Sketchup to fix this would also be appreciated.

Running Sketchup Pro 2017


When using same file in 2018 that works perfect in - Sketchup PRO 2017, setting up new sections in more complex models very slow and sketchup goes into thinking mode (no response etc). Seems like an eternity??? INTEL CORE i7 - 32 GB RAM, GTX1080. Played with three files so far, same issues. Does anyone else have a similar problem…Don’t think that Windows 10 is a culprit?


@nlenn, are you using a laptop?

In SU, go to Window > Preferences > OpenGL > Graphics card details. Are you using your NVidia card?


Of course…I think I’ve cracked it…There was an issue with Dibac solid sections, once switched off back to normal. So far so good…


My (temporary) solution for this problem is to uninstall Windows 10 updates one at a time until the problem is solved. So far I have identified the following updates as culprits in that when I uninstall them SketchUp works normally again: KB3150513, KB4038788 and KB4048954. I am using SketchUp Make 2017 M2.

This is an ongoing, and fairly major inconvenience for the SketchUp community and I’m more than a little surprised and disappointed that it hasn’t been addressed and resolved by now.


Select tool is lagging for me as well. The problem just started today and my production has since been halted while I search for solutions. I have checked and my graphics driver is up to date…so I will consider removing latest system updates although, from what I’ve read, this sounds like it is only a temporary fix and can be time consuming.

Problem is with SketchUp Pro 2018 (problem started with the 2017 version today…thought updating to 2018 would help, but no)

Device = Dell Latitude 5580 laptop
Display Adapters = Intel HD Graphics 630, NVIDIA GeForce 940MX
System = Windows 10 pro
Recent system updates = version 1709 on 11/15, KB4048951 on 11/16, KB4041994 on 11/16, KB890830 on 11/20

Any permanent solutions would be greatly appreciated!


Okay so I found something that seems to be a solution…at least for my set up.

I think this is what’s happening:
Because I have two display graphics adapters SketchUp was only opening using my Intel card and not automatically switching to the NVIDIA processor like it had previously always done (so maybe the Windows update negated the automatic switching?).

My solution was to right click on the new SketchUp 2018 icon and simply select which processor to open the program.

Hope this helps some of you too!


Reportedly, some of the Windows Updates have reset the chosen graphics hardware, and it seem it still may be happening…

Don’t forget, each version up SU is a separate program installation. So setting preferred graphics will have to be done for each version of SU on a laptop.


I had the same problem. This started a few weeks ago and was searching the web for a solution but could not find. I’ve un install and re install updates and so on for a while. I have just roll back to a previous version of my graphics driver and the problem solved imediatly. I dont know when my graphics driver updated due to auto update.
My system Laptop, HP Pavilion, Intel i3, wWindows 10, Intel HD Graphics 520, Graphics driver 2016/10/24.
I hope this can help some-one else.


That would have occurred with an automatic Windows update.


I dont think it was with a Windows update but more with an HP driver update that was done while I did not used SU for a few days.


Either way, you now know what to do the next time an update gets pushed automatically to your computer.


Roling back to my previous graphics driver also solved the double click and triple click selection method. All looks well now.


Check out


Is there a fix or Sketchup Make? I had the select tool working properly but after a restart of the computer it is now lagging again.


You don’t mention which version of Windows you’re using, but as a user of unsupported SU17 Make relying on an Intel graphics chipset, your options are limited to things that have already been posted throughout this forum about the slow selection tool issue (updating graphics driver, checking that some Windows update made a change to system and/or graphics driver, etc.) There will not be a one-size-fits-all answer because there are so many potential variables between all the different computer set-ups around the world.

A new potential fix that worked for some is changing compatibility mode (one of many tips in the main thread about this selection tool issue.)


I would like to try that. Are there instructions for running in compatibility mode? OK, I think I figured that out but it didn’t help.
I am running Windows 10 Home, version 1709, OS build 16299.64.
Intel Core i3-3227U CPU @ 190Ghz
Device ID ED613B81-F98B-4C40-918D-0F6A0943AFF8
8.00 GB RAM
64-bit OS x644 based processor.