Selection Tool slow/freezing


#1

I’m still having problems with the very slow selection tool problem. Everything seemed OK after the Windows update KB4106635, but with the new update KB4015217 the problem has returned. When uninstalled the issue is resolved and the selection tool works OK. However when installed the selection tool shows the freezing/delay problem but appears to be intermittent! That is, sometimes files will open and work OK and then another file will open and not work properly. The problem varies from day to day.
I cannot use SketchUp Make 2017as it stands, Microsoft support has no answers and this is driving me nuts.
I’m currently running Window 10 Home, (64 bit) v1607, OS build 14393.1066


Pointer slow to respond
#2

Some users have reported that reinstalling the Nvidia graphics driver has solved these issues. (Apparently the updates are messing with graphics settings, including setting applications to use the junky integrated GPU instead of the high performance Nvidia GPU.)


#3

Hi, thanks for the info. I’m a little unsure about handling graphics drivers. I don’t wish to do anything that might compromise anything else or cannot be reversed if something goes wrong. I currently have Intel® HD Graphics 2000 v 19.17.10.4459. Do I need to uninstall the old driver first?
I found this driver on the MS update catalogue and downloaded it. All I got was a cabinet file of 260 files. I’ve no idea what to do with this.
Would value any help


#4

I have the Intel 2000 as well. I manually updated the KB about a week ago and things appeared to work fine. Now it appears MS has installed some new updates and the mouse issue is back. Super annoying


#5

@scmfell, go to your computer manufacturer for driver updates. MS 3rd-party drivers may be outdated. For some people, they had better luck getting a good driver directly from Intel. It all depends on whether or not your manufacturer did some custom tweaks to the driver required by your particular machine.


#6

My computer was purchased through PCSpecialist. I’ve checked their website but they do not seemed to support drivers. I will get in touch with them directly to ask for their help
I have discovered a work around, purely by chance it does seemed to work but I’m not sure why! When SketchUp first opens it opens with the welcome page and then opens when the “Start Using SketchUp” is pressed. However, I have found that if the “Choose Template” button is pressed and the current selection is switched briefly to another template and then back again before opening, it fixes the selection tool issue.
I know this seems odd but I’ve tried a number of variations for opening existing files and each time this procedure is done the problem is resolved. Without doing this procedure the problem returns. If anyone has any ideas I would be pleased to hear them


#7

if a desktop system you may want download the latest driver available at the intel support webpages.


#8

My question still remains, I have Intel® HD Graphics 2000 v 19.17.10.4459. Intel do not not support this older graphics version. When I go to my device manager and update my drivers it says that I am up to date. Do I need to re-install the current driver and what is the best way to do this? Do I have to uninstall my driver first?
I did download this version from the MS catalogue but it appears as a cabinet file of 260 separate files!. I’ve no idea what to do with this.


#9

According to Intel, the latest driver for that card is 15.28.24.64.4229 from June 2015. You may need to accept that your graphics card is old and it’s time to move on.


#10

I have a display adapter that self-identifies as Intel® HD Graphics using driver version 9.17.10.4459 from 5/19/2016 also. It doesn’t claim to be the “2000” version. This is according to Intel, the latest driver version and it has been around for a while. I would worry about rolling the driver back to a previous version that is so old.

I am wondering if there is any active communication between the SketchUp engineers and Microsoft to work this issue out. I just shelled out another $120 for the year to use software that isn’t stable, so I am a little bitter about the issue. It took four days to get a response from the support folks at SketchUp.

I am currently going to try to roll back the last few windows security updates to see if I can get a working install. I have deadlines and I am starting to get twitchy.


#11

Those install package numbers can be somewhat deceiving and are different than the installed file version numbers.
(For example that package number you give is a 64-bit driver package with “.64” preceding the build number. The 32 bit packages do not have this “.64” in them.)

or “9.17.10.4459” ? The “19” seems a bit high for that old 2nd generation graphics.

Some users have found success in reinstalling the driver as all settings get reset to factory defaults.

You can first try to install over the top of the other install. If that does not work then uninstall the driver until WIndows lists your adaptor as something generic like “Standard VGA Adapter” then manually point the update driver to the downloaded install package. (If you don’t know how there should be help pages on Microsoft KnowledgeBase, or hire a local IT service.)


#12

Hi thanks for the info.

  1. My bad, you are correct the version should read 9.17.10.4459, (but also the date is 19/05/2016)
  2. Following your link, I found the version 15.28.24.64.4229 from June 2015 and decided to download and install this version from that website. I was informed that this was an earlier version to my current one but I went ahead and installed it.
  3. The installation appeared to OK but after re-start I checked the device manager and the original version was still in showing!!
  4. The problem with SketchUp still there
  5. Will contact PCSpecialist and see if there is a new graphics card I can get which is still compatible with my computer (now 6 years old)

#13

I just uninstalled the video adapter driver and did not delete the driver files. Upon reboot, the driver seems to have automatically reinstalled as expected. I had 5 minutes of glorious functional SketchUp Pro 2017 and then the display flashed black several times and then this is what I got (see image).

I guess I can try removing the last security update again, but this is starting to be a lot of time wasted. I may have to switch to working on my craptop to see if the problem exists there as well.


#14

nVidia GeForce GTX 960/1050Ti/1060 only.


#15

I just ran as admin in properties and works fine now


#16

FYI, Manually deleting the graphic driver files from the “%WINDIR%/System32” folder requires the machine be booted into Windows Safe Mode (as well as knowing which files to delete.) If you are not an experienced WIndows IT geek, then let someone with the experience do it for you.


#17

I finally bit the bullet and invested in a graphics card upgrade. After consultation I purchased the 2Gb nVidia GeForce GTX 1050. Installed today, and running OK. So far SketchUp is behaving itself. Keeping fingers crossed


#18

I am going to have to do the same thing. I am running Windows 10 and the Intel HD 2000 isn’t compatible with Windows 10. Frustrating.


#19

I know it’s very frustrating. Cost me £115 (with P&P), for the upgrade but I’m glad I did it. Since my previous graphics were integrated all I had to do was slot it in. I can now use the HDMI connection to my monitor which has also improved the display. The good news is that if and when I update my PC, I can always transfer the graphics card. This should then save a few pounds on an upgrade.


SketchUp 2017 freezing
#20

This topic was automatically closed after 91 days. New replies are no longer allowed.