Selection Tool process is slow, unbearably slow

I’m glad you got it and it worked.

Windows may try to push that update again or they might have a different update that supercedes this one. Keep this iin the back of your head, though, in case you run into a sudden change in performance of any program on your computer.

Probably, or some variant of… Windows Wonk.

1 Like

A search of the internet and specifically the microsoft website does not find a kb article with this number.

Try KB 4013418. Windows reinstalled it again for me this morning…

Time to turn off auto-updates?

1 Like

I had exactly the same problem this morning, following a windows update last night.
I uninstalled “Security Update for Microsoft Windows (KB4013429)”, which was actually second on my list of recent updates, and it worked a treat! As @donmcybertect said it did take quite a while for the uninstall and restart to complete - over 30 mins for me.
Thanks so much for everyone’s contributions here, especially @DaveR - you’ve saved me from pulling my hair out!

1 Like

Well, this morning I booted up my computer and was working on something when I got a “you must restart your computer”… Now or later? No mention of an update But, when I did the restart it updated and reinstalled
the same one. I’m just going to kill the auto updates.

1 Like

There is no such option on Windows 10 Home edition. You will get the update sooner or later, and your computer will reboot with the potential to lose work if you do not schedule the updates and reboots.


from InfoWorld (Woody Leonhard of

Thank you Dave, I had the same problem and the same update KB4013249 was the problem, thanks for making our life easier


1 Like

Hello -
I’m having the same problem - I can navigate through my model (which is relatively small) but can’t click on anything. I’ve updated the driver, uninstalled and re-installed 2017 with no luck. I checked the Windows update but don’t have any security updates (just a lot of updates for Microsoft Office).
Any other ideas as to why I can’t select anything?


Graphics card problem. Try updating the graphics drivers. Note that Intel HD graphics drivers have been notorious for less than adequate OpnGL support. Try updating anyway.

I updated the graphics card and still no luck.
I’m wondering if I need to revert to 2016; the one thing I did notice, which may or may not be relevant, is that this problem started after my ‘trial’ period for pro ran out and I started using the free version instead.
Thanks again.

Pro and Make handle graphics the same way so I think the end of the pro trial is unrelated.

Notebook or desktop computer?

So I’m not sure exactly what or why, but it’s working now. Yay!
Thanks for the quick replies and support.

1 Like

I’ve just downloaded SketchUp Make 2017 today, 3/33/17, and I find that the Selection tool is extremely tool. I’ve had earlier versions of SketchUp, and I don’t recall this problem previously. Is it my system, or is it SketchUp?

I don’t know what this means. If you mean it is slow, read this thread. there seem to be two common causes. One has to do with graphics drivers. Updating them seems to have helped some. For others a security update from Microsoft from late last week was the culprit. Uninstalling the update helped.

I too have just removed the Windows Update KB4013429, and SketchUp is performing normally. Thanks to all! It did take about 30 minutes.

The issue is now knowing when Microsoft tries to force the patch on me. Of course, I’m toggling off the auto update. But they can rename/renumber the patch, and I’ll then have to depend on youze guys to identify the culprit patch…or wait for Microsoft to fix their patch.

Thanks a million!

1 Like

I don’t know but I have to think that there are other programs that were negatively affected by that update. It wouldn’t surprise me if Microsoft releases an update for the update at some point.

Following my removal of the security update Windows reinstalled it the following night and the selection tool problem returned. I uninstalled it again, which solved the problem again. Windows then fought back and reinstalled the troublesome update…but this time sketchup is still running fine!
The update has the same code and I haven’t updated my graphics driver or (knowingly) made any other changes. So, it’s a bit of a mystery, but at least I can stop fighting my OS and get on with my work now!

For the record, I’m running 2016 Pro.