Newest Sketchup: Select tool freezes for 7 seconds

lag
2017
update

#1

Hi,
I’ve used SketchUp for several months but only recently I started to experience this strange behaviour:

  • After left-clicking with select tool anywhere in any model, the whole SketchUp window freezes for 7 seconds (quite precisely).
  • During the freeze no increase in CPU and disk usage can be seen.

I’m on Windows 10, SketchUp 17.2.2555, I’ve tried disabling all the extensions (even the built-in ones). This is my Checkup report:

Results:

Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and/or graphics card memory to fail.
Error: Graphics card information is missing.
Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!

The Checkup program found some errors (listed above). You may need to take some action in order to run SketchUp 2017.

See Help > Documentation for more information.

.

EDIT: Seems like I’m not the only one.


#2

I have a similar problem. When i look arround if i am in a specific angle it freezes and point the view below the object and pointing at nothing.


#3

If you searched a little more you would have found this: Selection Tool process is slow, unbearably slow


Model Disappears When I orbit
#4

Thanks, @DaveR!
I uninstalled the KB4013429 update and blocked it (tutorial here). It took approximately 3 hours but now everything works as expected!

Ugh, why doesn’t Microsoft roll the updates separately, not in one nasty 1 GB file which is essentially impossible to debug?


#5

I have exactly the same issue. The first time I just uninstalled Sketchup and re-installed it. And everything went ok! Sketchup was working without issue. After rebooting I got the same problem.

I can’t find the windows patch mentioned, probably because I have an Italian version.

Is it possible that trimble does not patch Sketchup considering the fact taht some secutirty patches are not under user control (windows just install them!)?


#6

I think it would be an exercise in futility for Trimble to attempt to create patches for every issue created by other software vendors, whether that is the operating system or graphics driver supplier. It doesn’t make a whole lot of sense for them to chase their tails every time the OS has a minor change. In the case of this recent Windows debacle, MS issued a repair within a week of the bad security patch they issued. IF Trimble had even attempted a way to deal with the problem caused by MS, they’d have to write the fix and then throughly test it before releasing. By the time they’d been able to get it out, MS would have changed the playing field again.


#7

Dear Dave, the problem is that the user cannot control patches. In my case I finally found the windows patch you mean: it was the “1607 per sistemi x64 (KB4013418)” but I cannot remove it. Windows doesn’t give me the option!

I tried to upgrade the Intel HD 4000 drivers; I tried to downgrade Sketchup (the 2016 Make has the same issue).

Well, in my case I use the “free” version of Sketchup, it’s my problem, but what about the Pro version?


#8

It doesn’t matter whether SketchUp Pro or Make. Expecting Trimble to create a fix or work-around for every little problem created by other software vendors is unrealistic. As you can see if you read the numerous threads on the topic of the errant Windows security patch, the fix from MS came faster than the SketchUp team could have modified their code and tested it to make sure it didn’t break other things. If they had done so, they’d have had to go through the whole process again after MS issued their fixed security patch. It would have been a colossal waste of time for a very small team.


#9

I understand but your software is unusable in this condition.

Anyway, is there an idea of what cause such issue (even if not fixed)?

At the moment I’m downloading the “Win10 Creators Update”, I hope will fix. I’ll let you know


#10

Evidently you don’t understand. And it’s not my software.

Did you look at the other threads on this topic here? There are links to articles and directions for installing the fixes from Microsoft.


#11

Sorry… is not yours :slight_smile:

I simply can not uninstall it! Windows 10 does not allow me to do it. The KB4013418 is not visible in remove windows (even if is listed as installed on 13/03/2017) and KB4013429 does not show “Unistall” when selected.


#12

Did you install the newer path MS released to rectify the problem they created? You might want to contact Microsoft since that’s their issue.

Out of curiosity, did you install SketchUp correctly using Run as administrator?


#13

I don’t know. In the recent two weeks I noticed my system a bit slower and this Sketchup issue, nothing else. Today I need Sketchup so I search on internet/forum the problem and discover this situation.

So I did nothing to patch windows, I saw 11 update after the 18/03/2017 (I said 13/03/2017 but is wrong) realted to KB4013418 and KB4013429, I don’t know if there is the fix. If you have some link please send. Thank you.


#14

#15

Thank you Dave for your link.

I have a good news: it seems that the “Win10 Creators Update” work. It tooks a while to install but now Sketchup it seems working fine.


#16

I’m back. After a few days the problem is back! Even with the latest “Win 10 Creators Update”.

Don’t know why.

Sad :frowning:


#17

Hi
I only see the update KB4013418 in my update history and cant uninstall it just like u. What is your next move, do we just wait for windows to have another update ?


#18

update your graphics drivers by getting the intel driver updat utility tool


#19

I am experiencing the same issue. Since the Creator’s update, the freeze is down to 3 seconds from around 7-10.

I thought my video driver was up to date, but I was wrong. Installing the latest Intel video and chipset drivers seems to have resolved my issue.


#20

Hi.
I encountered the same problem (select tool freezing) just a few days ago. I didn´t see any post later than March. I still tried the remedies recommended and uninstalled two latest Windows 10 updates in May (from the 27th). It worked! the recommended update (KB4013429) wasn`t available any morefor uninstalling, but these which were worked fine! I would like to thank all the forum members,who helped to solve the problem. But! It is very obviously the Windows problem and it would be very useful if some SketchUp team member would pass all these complaints to Microsoft staff (if it has not been done already). You see, we have paid both Microsoft and Trimble for these programs and somebody has to take responsibility for all those troubles and correct the mistakes made as ssoon as possible.
Regards,
Jabberwox