Sketch Up Pro 2017 Hanging Up


#1

I Use SketchUp Pro 2017. About 12 months ago I had a problem with it hanging up and the issue was resolved by updating the Intel HD graphics driver after which it worked fine.

However, the problem has returned with a vengeance. I have tried updating the driver to the latest version, but it still locks up for 10 seconds or so before the cursor can be moved again. Additionally, I cannot select anything on the drawing.

Is there anything I am missing? I presume that I can still download SketchUp Pro 2017 (I bought a license) and reinstall if this is what is needed.

Appreciate any help on this - I basically can not do any work and its piling up at this point.


#2

Most likely the Intel drivers were updated by an automatic Windows update from Microsoft. Try rolling the drivers back to the version that worked before.


#3

I’ve tried that - the ‘roll Back’ button is shaded out on the dialog box - i.e. I cannot select it. The last driver update was 11/12/2017


#4

I’ve just tried re-installing - that has not worked either unfortunately.


#5

I uninstalled SU17, downloaded and installed SU18 - same problem.

I installed SU17 onto my laptop (64 bit, 8 GB Ram) - same problem.

Right now nothing works on any of my machines.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.