Sketchup 2016 Pro hanging up on startup


#1

I recently installed Sketchup 2016 Pro on a new Windows 10 computer with GTX 980 graphics card. It works for a while after install, but then hangs up at start-up and won’t complete the loading process. I get the Sketchup workspace with all of my icons set up, but then it stops responding and shows a faded white screen. I’ve uninstalled and reinstalled twice, which seems to be the only way to get it to work again (temporarily). I’ve spent quite a bit of time using the LumenRT 2015 extension, and wonder if this is causing the hang-up over time. Other extensions installed include Skalp, CONDOC Tools 2.0, Artisan 1.2.4, Twilight Render, and BuildEdge Pro (though this is disabled). Please help, because reinstallation is a tedious process to get everything set up the way I work.


#2

Have you checked in the Nvidia website for an update to your graphics card driver? The drivers that have been shipped with a new computer often need updating.

That SketchUp works the first time after installing points and stalls on subsequent attempts to run it points directly to problems with the graphics driver. The first run of SketchUp doesn’t use OpenGL hardware acceleration, but it is usually turned on for the next runs. You can turn it off from Window menu>Preferences>OpenGL, but it is best used as a diagnostic step, as running SketchUp without hardware acceleration slows down zooming and orbiting for larger models.

Anssi


#3

Yes, I am using the very latest Nvidia driver. I can use Sketchup for a couple of days after reinstallation, so by this logic, it may not be the graphics driver. I have been using Sketchup in conjunction with LumenRT Viz 2015, but I uninstalled it and the problem did not go away. Any other suggestions short of uninstalling and reinstalling yet again?


#4

Although it sounds somewhat like a GC issue, if you have the latest drivers it ought to work OK…

Have you recently installed any Extensions/Plugins which might be causing a start up issue ?

Also…

Did you initially install Sketchup by selecting its installer exe file’s icon, right-click > context-menu > Run as administrator ?
If not, then consider this… go into Windows main toolbar left-side Win10 icon > right-click > context-menu > Control Panels > Programs and Features > then UNINSTALL SketchUp 2016 - any custom Plugins etc will be kept safe…
When it’s uninstalled, then reinstall it - by selecting SketchUp’s installer exe file’s icon, right-click > context-menu > Run as administrator…

Then launch SketchUp and see what happens ?


#5

Thank you for the advice! I will give it a try. I have been installing extensions/plugins recently as I set up this newly built computer. My guess it is one of those causing the issue. I will reinstall per your advice below and see what that does. More to come…
Thx!Eurogator


#6

@TIG, thanks for the help! It is now working. I’ll give it some time to see if it stays stable.
Thanks!


#7

Great !:grinning:
Any idea what the tipping-point was ?


#8

Right now I’m not sure. I don’t have LumenRT 2015 installed at the moment so I will see how long it takes for Sketchup to become unstable again. If it stays stable for the next few days then it appears that may be the culprit. The other extensions (that are installed) that I will be keeping an eye on are CONDOC Tools 2.0, Artisan, Twilight Render v2, and Skalp. These extensions never had any issue with Sketchup 2015 Pro. One last thing, I did a clean reinstall of the latest Nvidia driver (361.91). So I’ll now see how it goes!
Thanks!


#9

Bonne chance!
:smiley:


#10

I spoke too soon. I am now getting continual Bug Splats. I also get a Bug Splat message in Google Chrome that says there is an MSI audio file that is interfering, but I do not have an MSI-based computer, and that file is not present on my system. I’ve attached a snippet of what I get:

Thank you for your follow-up to help!


#11

Are you sending your bug splats in?

Have you tried using SU without any 3rd-party plugins in order to rule out plugin issues?

As a Pro user, did you file a support request?

You didn’t list any bit-ness in your profile. So if you installed SU16 64-bit, did you try the 32-bit version? That helps some people.

Out of curiosity, what mouse are you using?


#12

I’ve submitted multiple Bug Splats today, with additional supporting information as well. I’ve uninstalled the plug-in (LumenRT 2015) that I was using when the problems occurred. I do have 4 others still enabled (Skalp, Twilight Render, CONDOC Tools 2.0, Artisan 1.2.4). I did file a detailed Pro support request last night (no response yet). I am using the 64-bit version, since I installed the 64-bit version of Windows 10 on a new-build i7-6700K (Z170 Mobo) with GTX 980 (with a fresh install of the latest NVidia driver). I have not tried the 32-bit version, since I’m running a 64-bit OS. I’ve loaded Sketchup Pro 2015 and it runs with no problems. I am using a Logitech Anywhere MX Mouse with the unifying receiver and Setpoint 6.67.83 (driver 5.90.41) which I believe is the very latest since I just updated it a couple of days ago. One last thing, Bug Splat kept sending a message (see below) that references an MSI dll (NahimicMSIOSD.dll) that I do not have on my computer. For audio I have the ASUS Realtek set (for the Maximus VIII GENE Mobo). Hopefully, this answers your questions and perhaps can narrow down where to look next. Thank you for your thorough questioning to cover all the bases.
Thanks!


#13

Some people remedied issues on their 64-bit machine by installing SU 32-bit. Many renderers do their processing outside of SU so they still can take advantage of 64-bit processing.

No one yet mentioned testing your graphic driver by going to Window > Preferences > OpenGL and disabling hardware acceleration.

To be thorough, you should remove all plugins to see if SU behaves. If all goes well, install one-by-one.


#14

Very interesting…I just loaded SU 2016 Pro again, and noticed the bug splats happen when I try to adjust the camera view (panning and rotating the view). Without trying to adjust the view, I was able to disable the 3rd party extensions. I reloaded SU and got the same behavior. I am thinking this is not caused by the plugins. I already did have hardware acceleration disabled. Break, break… I just enabled hardware acceleration and Viola! it is now working again. Very, very odd. I want to avoid 32-bit processing as much as possible since I just built a shiny new 64-bit machine with Sketchup as a main application…defeats the purpose and I shouldn’t have to do that, especially since I pay an annual maintenance and support fee to Trimble. Anyway, any other thoughts with this latest info? Thanks!


#15

In fact, the only benefit 64-bitness gives over 32-bitness is the ability to use more memory. There is no performance benefit. The memory issue might be relevant to you in view of the plugins you use.

Anssi


#16

I intend to process large city scale models for urban and regional planning purposes so the ability to address large amounts of memory is essential. As of right now I am able use SU 2016. I’ll see what the official Trimble response is. It is curious that the hardware acceleration is working fine while disabling it causes a bug splat. I’d love to understand what is causing that.
Thank you for all your follow-up and help!


#17

Hi,

I am also running SU 2016 Pro and have been getting more and more consistent hanging on startup issues. It’s now at the point that it happens all the time and I simply can’t use the program which is clearly not workable! HELP!

I have;

  • checked all windows 10 updates are the most current version
  • checked all NVIDA GTX1060 (6GB graphics card) updates are the most current version
  • deleted the app data folder for SU and re-started. (no change).
  • uninstalled & reinstalled (no change)
  • uninstalled & reinstalled older version of SU 2016 (no change).

My laptop is pretty much brand new (November 2016) and is nice and powerful MSI GT72VR (quad core I7, 32gig ram) and is running windows 10.

All my other programs like Adobe Illustrator, photoshop etc are running fine. It’s just SU 2016 Pro that’s unstable.

Can anyone provide any advice on where to go from here?

  • Install windows 7? (supposed to be more stable I believe)
  • Install SU 2017?

Any help in diagnosing the issue most welcome.

Regards,

Joe


#18

did you direct the laptop to use the Nvidia card through the Nvidia control panel’s 3D settings, using the menu to customize settings for SU?

Is graphic driver updated?

Any plugins/extensions added to SU16?


#19

The most important 3D application setting is to force the system to use the Nvidia card for SketchUp. Automatic selection does not work, it prefers the processor-integrated Intel graphics.

Anssi


Printing problems
#20

Hi,

Thanks for the responses.

Yes the graphics card is up to date.

I have played around with the 3D settings (my menu looks a little different to yours - where you show a single line drop down selection for item 2 I have about 12 options. I’ve amended all of them to be application (rather than system) preferences, but it makes no difference. I would not expect that this would cause SU to hang on startup - it would be more likely to give better performance?

Yes there are some plugins:

  • Podium
  • Podium walker

I’ve also got a Podium Browser subscription.

I have tried deleting all of these and re-installing but the program still hangs on startup (it looks like it’s all going good but just hangs and then goes into “no response” mode and crashes.

Any other ideas?

Maybe I need to try a different (Windows 7) operating system rather than windows 10. Has anyone had any success with this, or does it cause more dramas than it’s worth, and I’m better sticking with Windows 10?

Not a happy camper!

Joe