Sketchup Crashing on Startup


#1

Good morning,

I am having a problem where Sketchup opens, you can select the template, then it gets to the next screen and just hangs. The Man and grids don;t show but the rest of the windows do. The cursor spins blue and just crashes out. No bug splats or nothing.

I have been all over the forums and even looked at the help section to try and contact Trimble. However it looks like you have to have a maintenance package to contact them. However I am trying to trial the pro version currently in view to purchasing if all goes well.

I have updated my GTX 1070 drivers from Nvidia, removed and updated the C++, even tried installing 2017 Make and the same problem occurs.

If I install Sketchup from scratch, first opening works…then once you shut it down and reopen it, it crashes.

Any ideas?

Thanks, James.


#2

This sounds typical of bad graphics drivers for the integrated Intel GPU. Make sure that the Nvidia card is selected to run SketchUp.Do this in the Nvidia control panel which you can access by right clicking on the desktop.


#3

Hi, thanks for the reply. I have tried this before. I have just been back in the settings and all is well. the GTX1070 is selected to run the program. Any other ideas? I have to uninstall sketchup and reinstall everytime I want to use it :frowning:


#4

Did you install SketchUp correctly? That is, under your normal sign-in to Windows, did you right click on the downloaded installer and select Run as administrator? Or did you just double click on the installer to make it run?


#5

If it helps, I am using an Asus Strix laptop.

Thanks, James.


#6

Everytime I install it, I right click and run as admin, it does flag up to install the C++ 8 out of 10 times it installs.


#7

I saw a screen recording from someone with the same symptoms. In the end he removed extensions and added them back in one by one. For him the problem turned out to be TTlib2. ThomThom already knows about that case, hopefully yours is the same issue.


#8

Hiya,

Thank you for the reply. As it’s a brand new install I don’t have any extensions. I did go into the plugins folder and delete all the standard ones like Trimble connect etc and it still didn’t start up. I even tried selective startup on windows today and it’s still a no go :frowning:


#9

If it works on the first opening, go to Window/Preferences/Opengl and Untick ‘Use Fast Feedback’. You could also reduce the Multisample Anti-aliasing. While you are there click the button for graphic card details and check that it is showing the Nvidia card.

Then see if that makes a difference.


#10

Good morning,

Thank you for all the replies! I have just tried turning off multi sampling and fast feedback to no avail. as soon as you close it and re-open is still hangs. The Nvidia card is showing ok too.

Regards, James.


#11

microsoft is advising don’t install their latest security patch… might be worth checking…


#12

I’ve not got that one installed :frowning:

It’s such a weird problem, I just don;t understand why it won’t work. I have previously had Sketcup Make working on there fine for about 6 months. The only extension i installed was indigo but all was working well. One day it did stop working about 6 months ago. I thought maybe with the new version it would work again but no luck :frowning:

I have been through and deleted everything I can find to try and give it a fresh install but still no luck.


#13

Is there any way of seeing a log of what it’s hanging on? What it’s failing to do?


#14

plugin AC for testing purposes sothat power saving doesn’t apply to the GPU.

do you have an external monitor connected?
do you have any remote desktop software installed?
do you use any virtualization software in connection with SketchUp?


#15

Yes, definitely following for sure. I also face this issue sometimes. And yes, I do have an external monitor connected but I don’t think it triggers Sketchup (checked from 192.168.1.20 IP address) in any way.

Nevertheless, please provide a permanent fix for this.


#16

Good morning,

I always use my laptop with the AC plugged in as the battery doesn’t last long due to the power of it. I do have an external monitor connected but this has never proven a problem in the past? I don;t run any remote desktop software or virtualization software.

I find it strange that it opens and works fine straight after install…but then any subsequent application launches hang as it’s loading up. All the menu’s appear but the workspace is blank.

Regards, James.


#17

When you say it hangs, what happens? Do you have to force stop it? Could it be as simple as a dialog is opening off screen and the screen isn’t where it thinks it is? This has been known to happen with the welcome screen making it virtually impossible get going.


#18

So what happen is, I double click the icon, the Sketchup welcome opens where you can pick your template. I usually pick Architectural Millimeters, however I have tried all options. Then the main Sketchup window opens, the menu appears at the top and on the right at the top the square with the diagonal line through appears, firstly its blue and white and then it changes to grey and white.

That’s it, the cursor is a blue rotating circle and I have tried leaving it for hours to no avail. If I click anywhere it shows ‘not responding’ at the top and then if I click again windows asks to close it.

It still seems odd that it opens the first time but not the second time, what changes?

Regards, James.


#19

Try closing the default tray (next time you get SU open) before shutting down.


#20

Which bit is the default tray? Is that the toolbar on the right which goes top to bottom?

Sorry, i’m really new to Sketchup, the little used it these last few days the more amazing it is!

Thanks, James.