Sketchup Crashing on Startup

#21

Just go to the window menu and hit hide tray.
Then close it and see if it opens.

#22

it has already proven in the past… do you use different screen resolutions on the internal display and the external monitor? If yes, try configuring the internal display to show the same resolution as the external monitor or just rip off the external monitor just for testing.

2 Likes
#23

Well what can I say…I install Sketchup and closed the default tray, tried restarting and it crashed. I then closed Sketchup, reopened…it crashed. I then unplugged my extra monitor (which is connected via displayport and has the same resolution) and tried Sketchup again and it worked!!!

I have since tried reconnecting my monitor and when Sketchup opens directly to my second monitor it crashes, but if i open it on my laptop screen and then move it across, it works fine!

What can be causing this? Is there a way around this or do I need to just move it every time I open and close it? I used a second screen as my laptop screen is small.

Thanks again for all our help!!!

James.

#24

On my new Win10 machine, I cannot trust SketchUp (any version) to run properly. All sorts of weird stuff happens with window placement and crashes.

I finally just live with SketchUp running on my internal display (which is a bit higher resolution than the old external display anyway.)

#25

is the external monitor connected via HDMI or DisplayPort?

if HDMI, can you switch to DisplyPort at least if notebook and monitor do support?

#26

and disable display scaling on high DPI settings first by:

  • right-click SketchUp
  • select “Properties”
  • open “Compatiblity”
  • configure setting “Override high DPI scaling behaviour.” to option “Scaling performed by: Application”

#27

You might want to uninstall the reinstall sketchup again
Hope it works
Cambridge.sketchup

#28

Hi all, just wanted to say that It’s connected by a displayport cable. I have now subscribed to Sketchup Pro as its working if I open and close it on my laptop display and just move it to my Larger display while working within it.

Thanks to all that helps, you have been great :slight_smile:

James.

1 Like