SketchUp Pro 2020 crashing without opening, producing bugsplats

Hi all,

Im having problems with opening sketch up at all. I run AutoCad but recently it was crashing every 15mins. We updated all sorts of drivers etc prior to discovering a stick of RAM had failed. Both 8G RAM sticks have now been replaced with 16G RAM sticks but now Sketch up is not opening.
It just produces a bugsplat every time.
I have downloaded Sketchup Check Up and it says everything is fine.
I have downloaded another set of intel drivers and made sure everything is up to date, but still not working. Anyone else having or had this issue with it not opening?

I don’t know if it helps, but you could try repairing your SketchUp installation. Find your installer file, right-click>Run as administrator, select Repair from the installer dialog.

I see in your profile that you have an Nvidia graphics card. Did you updated the drivers from Nvidia as well? Are you sure if SU is using Nvidia?

Yes, Since i posted I have downloaded the latest drivers and set SU to only use the nvidia card. I have also uninstalled and installed 2021 as an Administrator all with no affect. Still crashing

Yes, since I posted I have uninstalled 2020 and installed 2021 as an Administrator with no affect.
Its still crashing with bugsplats

1 Like

Does that mean you logged in to Windows under your normal user, right clicked on the installer and chose Run as administrator?

What model is your Nvidia graphics card? And do you know if it is set up to display SketchUp?

Are you sending in the Bug Splats with something that identifies them as coming from you? If so, @colin should be able to find them and tell you what is causing the crash.

I’m confused. The topic title says without bugsplats…

I read it as it is crashing without opening but it is creating Bug Splats. And in the first post:

Ah. I missed that while skimming to catch up. It’s important because video card issues often cause SketchUp to self-abort, which doesn’t create a bugsplat.

I do see the bugsplats, and they look video card related. I’ll ask others to take a look and see if there is something more specific going on.

In one crashing issue recently I had to set SketchUp to use the less powerful “Power Saving” GPU to stop the crashing. Setting the High Performance GPU would crash all the time.

Thanks everyone for your time, feel very old trying to sort this out and im only mid 40’s!!
Yes, I logged in under my normal user, right clicked the exe file and clicked run as administrator that way.
I have a Nvidia Ge Force GXT 1050 Ti graphics card. I have assigned this to sketchup but still no luck. Maybe I need to assign it across all apps??
Yes, Im sending in the bugsplats with my name and email entered.
Colin - Im not sure how to set the GPU ??
I have just run the checkup too and although the Nvidia card is assigned to SU its saying its not…

Are you saying you right clicked on the installer or the exe that actually runs SketchUp?

sorry the exe file

So you didn’t actually install SketchUp using Run as administrator? How about doing that now? Find the downloaded installer file, probably in your Downloads folder, and right click on it. Choose Run as administrator. And then when options are presented, choose the Repair option. After the installer completes, shut your computer all the way down. That is, power off completely. Then restart the computer and try running SketchUp.

Hi Dave, yes thats what I did. The downloaded installer file in my downloads folder IS an exe file. I right clicked on it and selected run as administrator and it is successfully installed. It just doesnt open.

Did you try repairing the installation as I suggested?

Well I had only just uninstalled 2020 and installed 2021 so didnt think there would be an issue but did as you suggested and unfortunately no luck.

I worked out how to change the windows assignment of GPU however it conflicts with Sketch ups running requirements. Sketch up requirements are fr the Nvidia card to be used but this is the High performance setting. I just changed it to the power saving setting which is the Intel card and it has finally opened but with this message??


It means at least you can run SU, but with less performance since using the “weaker” card.

An other idea.
Nvidia has two type of driver, the “Game Ready” and the “Studio”. I would say the Studio is more stable but you can try installing both (one after other) to see if one of it helps…
(Make sure I’ve linked the appropriate driver for your video card…)

The Nvidia software probably has a way to set itself to be used with SketchUp, but the Windows 10 way is to open the Graphics Settings control panel, and in the first options you see you would click Browse. Find your way to:

c:\Program Files\SketchUp\SketchUp 2021\SketchUp.exe

and add that to the list of apps. Click on Options, and then you can choose whether to use the power saving GPU or the high performance one. Here are some screenshots.