SketchUP Pro crashes when trying to Open?

Havent used this program in a while, but cant even open the program without getting the Bugsplat error message. Had SketchUP 2017 downloaded and wouldnt open any more withought getting the bugsplat error message, so i downloaded sketchup 2019 and now that is doing the same. Any help would be greatly appreciated.

Commonly crashes without Bug Splats on startup are caused by graphics driver issues. What is the graphics card in your computer? Unfortunately “i7” isn’t useful info for the graphics card.

Hi DaveR, Im not actually sure what the graphics card is. Sorry im not very tech savy. But thought the same thing, so ran an update through Intel to make sure my graphics card didnt have any updates it needed to do… and everything seemed ok.

Try this: In the search window in the taskbar, type ‘Device Manager’. In the Device Manager window, look down the left side and click on Display Adapters. What do you see there?

Also, when you installed SketchUp 2019, did you right click on the installer and choose Run as administrator or did you simply double click on the downloaded file to run it?

Intel® HD Graphics 620
Radeon ™ R7 M445

And i think i just double clicked on it. But ive tried since installing right clicking on the app and selecting Run as Adminstrator. Not sure what that did though.

Did you click on Repair after that?

Since it is common for Intel graphics drivers to be the cause of the sort of behavior you’re seeing, go to the Intel site and download the latest drivers for your Intel graphics card and install them. Reboot the computer and try opening SketchUp again. Does that help?

You might also update the drivers for the Radeon card while you’re at it. You need to be able to get SketchUp open and then go to Window>Preferences>OpenGL and see what graphics card it indicates it is using.

GOT IT!!! After i updated both graphics drivers and rebooted it finally opened. Once in OpenGL it says its using the Radeon graphics card.

2 Likes

Very good. Now go model something. :smiley:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.