I'm having problems opening Sketchup pro 2021

I’m having problems to open sketchup pro 2021. Just open ther program, a window opens with the error: Crash #351891. Can anyone help me?

Has it opened successfully in the past? Is this new behavior? If so, the first thing to look at is what has changed on your computer. A common one that can affect SketchUp on opening is graphics drivers. It’s not unusual for a Windows update to include broken graphics drivers for integrated GPU’s such as yours. Go to the graphics card supplier’s site to get and install their latest drivers.

Also make sure SU2021 is installed correctly. Find the downloaded installer, right click on it and choose run as administrator. Then if you get the option, choose Repair.

Next do a cold reboot of your computer. Power all the way off, leave it for 30 seconds or a minute. Then power on.

Any change in behavior?

It did not work, the same error still appears after repairing the installation

Did you update the graphics drivers? Are you getting Bug Splat reports and sending them in?

I did it and send the reports

With your e-mail address? Maybe @colin can look them up and give an idea of where things are failing.

You never answered my question about whether SU2021 ever opened correctly and if this is something new.

From installation until yesterday it worked perfectly for me.

So what changed on your computer right before SketchUp stopped working perfectly? It wasn’t SketchUp 2021. That hasn’t changed in months.

There must have been a change on your computer. A Windows update most likely.

If you did the repair as I advised, and that didn’t fix it, reinstalling probably won’t either. But you can try. Make sure you install correctly by right clicking on the installer and selecting Run as administrator.

I’d wait to see if Colin has an opportunity to look at your Bug Splat reports before doing anything too drastic.

Thanks for your help. I found the only change: I was trying out Enscape 3.1. I restored the system to a point before the installation of Enscape and SU2021 already opens

So Enscape is apparently the problem?

The cirrent version is 3.2. Maybe you should try that one instead.

Thanks DaveR, Maybe I’ll try it another time because I need to check that SU2021 is still working. Thanks again for all your help.

1 Like