SketchUp June 8 2021.1 update crashes (unable to start)

After updating my SU Pro 2021 to the June 8 2021.1 version, I am unable to startup my Sketchup Pro as it crashes everytime.
When starting SU Pro, nothing happens for a long period of time and at the end I get the bug splash reporting screen (which I have submitted).

Any help is appreciated as I am now unable to run SU for work purposes.

1 Like

Probably the single most important bit of info is missing from your profile.
The most common cause of something like this is a weak graphic card or a faulty graphic card driver.
You should start by going to the manufacturers site and download the latest driver for your graphic card. Don’t rely on windows to tell you it is up to date.

I will check however yesterday the previous version of SU Pro worked fine. Unless there is a major update in the graphic card requirements in this new SU 2021.1 version I am a bot sceptic that the issue is just that simple.
I also ran SketchUp 2021 Checkup and I did get all green ticks.

I uninstalled 2021.1 and reinstalled the previous version (2021.0.1) and I am now fully back up and running again with the previous version. For me the new update to version 2021.1 does not work well at the moment. I will retry updating again in a few days to see if anything has changed for me (or not).

Did you send in any of the bugsplats?

I found his BugSplat report. See internal chat thread.

Same problem. I think, issue may be connect with new feature that ‘improve hugh mesh’. My pc: win 10, i9 9900, RTX 2070 super.
Just update nVidia driver. But, skp 2021.1 crash.
Ciao

For EvdP, the crash looks like it was to do with the web cache folders. Can you try this test?:

Close SketchUp.

Copy and paste this path into File Explorer:

%AppData%\SketchUp\SketchUp 2021\

and delete any folder whose name starts with WebCache. There are likely to be two of them. Then try SketchUp and see if it doesn’t crash this time.

I’ve try too. But don’t work. SKP crash.

I have the same problem. Just updated Sketchup pro yesterday (on two computers) and now both are crashing like crazy. Crashing during file open & crashing any time i install an extension from the trimble warehouse. yikes

If you see a bugsplat window, can you send it in? Include your details so that I can then find the crash report.

Hi - attached is one such example
What details do you need?Thanks !

When you send those in there is a space for your name and your email. That’s what I would normally search for. You didn’t fill those in, but I can also find it from the crash number.

You have several sets of extensions from the same developers. Do you find you get a crash when installing a second or later extension from the same developer? Does the newly installed extension work when you reopen SketchUp?

i only noticed this behaviour (on both computers) after installing yesterday’s update - and i dont know if this is specific to any one developer , but i noticed that the extension would install - sketchup crashes - then when reopening sketchup the extension was there, installed and working as expected.
I tried deleting the webcache folder - i thought that was helping, but then the crashes started happening again.

Thanks. It is an issue that we know about. It’s the weekend now, but I will see if I can post an update on how that’s going early in the week. Sorry for the inconvenience.

1 Like

I imagine that some time soon there will be a post in the forum about a SketchUp update. Haven’t seen one appear yet, but the release notes page is updated. One of the fixed items is to do with crashing that can happen when installing certain extensions. Here’s the release notes:

https://help.sketchup.com/en/release-notes/sketchup-desktop-202111

The downloads page has been updated:

1 Like

OK thanks. I found that i can avoid the crashing that was occurring when switching files - by first starting a new drawing, and then only after that opening up a pre-existing file. that seems to prevent some crashes

Hi Colin - there is one other feature of the latest release that i have noticed.
LAYOUT no longer seems to be able to handle text bullets or numbering. Any text that i have created in Layout will no longer print correctly if it was numbered or bulleted.

I will try that. There was a LayOut PDF export issue fixed, hopefully that didn’t have this as a side effect.

I tried a test, and bullets and numbers seem to print ok. Do you have a small example file I can try?