SketchUp Make 2017 stopped working. Crashes on start-up


#1

Hi all,

I’ve been an avid user of SketchUp for many years, and have been using Make 2017 for the past few months with no problem (and 2016 for a long time before that). Suddenly (just today) SU will crash directly after pressing [Start using SketchUp]. Directly after pressing the button (or if I launch via a file) no window opens or anything - it simply shows the bug window that allows me to report the bug (which I have done).

I’ve been working on resolving this literally for hours, and have trawled through many official and unofficial threads on the topic.

Yesterday I installed several driver updates via the HP support assistant, which I suspect is the culprit. I’ve uninstalled these again, reinstalled SU, run CCleaner, re-installed drivers, rolled back graphics drivers to older versions, updated them to the latest version, made sure SU launches with correct graphics card, installed as administrator etc etc, and all to the same result - immediate crash on starting SU.

I found an old version of SU Make 2016 32-bit just to test, and this installed and ran fine (on my 64-bit system) but, of course, it won’t open any of my SKP files as these were saved in 2017 version and are not compatible.

There are no clues in the log file that accompanies the crash (at least that I can see). Shall I paste one here? It’s around 300 lines long and contains mostly a dump of the OpenGL properties.

I am at my wits end. I really don’t want to reinstall windows because everything else on my machine works fine, and I have my machine set up for other software that would be a real pain to have to reinstall and reconfigure (I’m a developer).

Any help appreciated. Where to from here?

Cheers,
Peter

Edit: Attached log file - SketchUpLog-2017-01-07-22_55_32.txt (26.3 KB)


#2

As you probably know, the install 32-bit version test is a red flag for a graphics driver issue. Reinstalling Windows sounds like overkill.

Are you able to update driver via the Nvidia site?

You did enable your laptop to use the Nvidia card from the Nvidia control panel’s 3D settings menu for SU? Try using integrated graphics?

Can check for plugin interference by temporarily renaming Plugins directory at C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins and try restarting SU17.

Another SUpper with your card (and identical computer spec profile) found a conflicting startup program called Nahimic which prevented SU17 from opening but allowed SU17 to open with integrated Intel graphics, thread. Even if you don’t have that program conflict, the same troubleshoot method of using clean boot can help to find other program/services conflict(s).
.


#3

They are plain text, so please just attach them. You may need to add a “.txt” on the end if the forum does not like the file extension. Or, you can always wrap up any log file(s) in a ZIP archive, the forum will accept these as attachments.

Suggest you edit the original post, and attach the logs there. (On Windows you can drag and drop files into the forum posting edit box, or use the “Upload” button on the posting edit toolbar next to the “Bulleted List” button.)


#4

Thanks to you both - I’ve attached the log, and am going through the suggestions above.
Notes:

Are you able to update driver via the Nvidia site?

Yes, that’s how I’ve been doing it :slight_smile: The latest version is only 3-4 weeks old

You did enable your laptop to use the Nvidia card from the Nvidia control panel’s 3D settings menu for SU? Try using integrated graphics?

Certainly the first, but I haven’t tried forcing integrated graphics yet. Will give it a go

Can check for plugin interference by temporarily renaming Plugins directory

There is currently no Plugins directory (new install)

Will try the clean boot method and the other tips.

UPDATE:

Forcing SU to use Integrated graphics still results in the crash.

Unfortunately a clean boot with no non-MS services and no startup programs does not help. Still immediately get a bug splat on pressing [Start using SketchUp].

One of the updates that was run was a BIOS update. I downgraded the BIOS again, but that still hasn’t had an affect.

Anything else I could try?

Thank you!


#6

Yes the log file looks ok, except for some of the system info is missing or blank.

How about getting Checkup and creating a full sulog file (which is actually a zip archive, with a larger log and a MS System Info .nfo file in it.)
http://help.sketchup.com/en/sucheck

You could look for any SketchUp specific Windows Error Reports.
See this other post by me in another thread:


Last resort, would be to roll everything back to a restore point before you did the HP updates.


#7

I did run checkup earlier and it indicated no problems. I’ve run it again and attached the dump as SketchUpLog.zip (103.5 KB)

Unfortunately there is no info (about SU or any other program) in the WER folder, just like andrew.d.blood replies in the thread linked above. I also ran “Event viewer”, but I can’t see any crash logs relating to SU in there, either. When I run SU and get the bug splat, no additional events appear in event viewer either to indicate the error.

EDIT: Just found out that if you navigate to the the WER folder rather than copy/paste the %LocalAppData%… string, then you get to the right place. here is an example error report. Can anyone see any indications in here of the possible cause? Report.wer.txt (18.7 KB). The correct path on Win10 is \ProgramData\Microsoft\Windows\WER\ReportArchive

And unfortunately (perhaps stupidly is a better word) I didn’t create a restore point before the updates.


#8

I responded to this in:


#9

Often updates will go ahead and set a restore point themselves, it just may not have a nifty name like you’d normally give them.

Looked at the WER report

EventType=BEX64
ExceptionCode: c0000409
Security check failure or stack buffer overrun

So, because this can be caused by security issues, most responses on the web, ask that users do complete (multiple) scans of their systems.

Especially if these buffer overflows are happening along with EventType=APPCRASH with ErrorCode: c0000005

Complete scan with your Anti-Virus

  • reboot and scan again

(Note, there are reports of some AVs [ie Comodo] needing fixs because they were causing BEX errors in other applications. So run an update on your AV/Security package.)

Complete scan with Anti-Malware (malwarebytes.com)

  • reboot and scan again (until nothing is found)

System File Checker

  • open an admin command shell (by right-clicking the “Command Prompt” icon and choosing “Run as administrator”
  • run the checker via command: C:\>sfc /scannow

One cause seems to be related to some old updates (KB3000850, possibly other numbers for various Windows versions and bitnesses.) These updates made changes to the Windows CFG (Control Flow Guard) feature, which is a an implementation of Control-flow integrity (CFI). CFI is a basic computer security technique that attempts to prevent malware from redirecting the flow of execution of a program.

Possibly related, is the Win 10 block untrusted fonts feature that works along with CFG.
Do you have this font blocking feature ON, OFF or in AUDIT ?
https://support.microsoft.com/en-us/kb/3053676

This page had instructions for setting a certain exe to be excluded from CFG.
https://social.msdn.microsoft.com/Forums/vstudio/en-US/d8f6e240-7b87-4882-bd0d-3dee364fd923/exception-codec0000409-exception-data0000000a?forum=clr
So the key would be for sketchup.exe instead of mmc.exe.

But before turning off any specific application security mitigation, I’d be sure to run as many security scans as I could.


#10

Looked at the Checkup Log

It successfully read your System information, and it all looks good as well:

OS Version:            10.0.14393 Build 14393
CPU Specs:             Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed RAM:         16384 MB
Adapter Type:          Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description:   Intel(R) HD Graphics 530
Adapter RAM:           1024 MB
Installed Drivers:     igdumdim64,igd10iumd64,igd10iumd64,igd12umd64,igdumdim32,igd10iumd32,igd10iumd32,igd12umd32
Driver Version:        21.20.16.4534
Resolution:            1920 x 1080 x 60 hertz
Bits Per Pixel:        32
Driver:                c:\windows\system32\driverstore\filerepository\ki118970.inf_amd64_d6ed74a719d2e629\igdkmd64.sys (21.20.16.4534, 10.52 MB (11,033,064 bytes), 7/01/2017 7:40 PM)
DPI scale factor:      1

Don’t know why the SketchUp log omitted it.


#11

Oh, and another thing I saw via searching, was some people getting these errors when unwanted toolbar applets were installed.

So check your installed software list (Contol Panel > Program and Features) as well as any Browser extension (especially 3rd party “helper” or “search” toolbars) … that have suddenly showed up, and you don’t know what they are for, or remember purposely installing them.


#12

The clean boot should have ruled out unneeded 3rd-party stuff. But it doesn’t hurt to look.


#13

Thanks for all the help so far. Running all the security scans now, and will check for toolbars etc too.
Interestingly, the checkup log seems to list the integrated graphics adapter and not the GeForce.


#14

See if when you right click on the Sketchup icon, there is an option to run high performance video adapter, or something like that.

Shep


#15

Yes, it really just runs msinfo32.exe, and then parses it’s log.
Looks like it grabs the first adapter listed in the .nfo file, but both are listed.


#16

Nothing detected with anti-virus, nor anti-malware, nor system file checker.
Disabled almost all helpers/toolbars/extensions in internet explorer (edge didn’t have any). SketchUp uses one of these browsers, right? (my default is Chrome).
Disabled untrusted fonts feature.
Excluded sketchup.exe from CFG.

Unfortunately still no effect :frowning:

Thanks for the tip about BEX64. Will continue to investigate this error and see if I can get to the bottom of it.


#17

Programs don’t care about your default browser preferences. SU17 now comes with Chrome for internet access, but still uses IE for webdialogs.

You could try reinstalling the required C++ runtime libraries. Maybe even the NET framework too. First what you have needs to be uninstalled through Add/Remove Programs. Found mention there was a bad version released mid-December, mentioned here. Either reinstall from MS or reinstall SU and the installer will install correct version from MS.

Do you have many versions of C++ installed? They can co-exist, but what do you have?


#18

Oh my sainted Aunt and her five generations of pampered poodles! That solved it!

After three days of basically destroying my system piece by piece with absolutely no luck, it was some sort of broken C++ redistributable that was the issue. As in the post mentioned by @catamountain above, removing the 14.xxx C++ packages through Add/Remove programs (I had two, though not exactly the one mentioned in the post) and then reinstalling SU did the trick.

Thank you to everyone who pitched in on this thread, especially @DanRathbun (and of course @catamountain). What a great community.


#19

Love that anecdote!

Glad it’s working, that was my next suggestion, by Joy beat me to it. I just suggested the same course of action to a gal in another thread.


#20

Mate I have the same problem. I am not good at programming etc. What exactly have you done to get it going again. I use SU Make 2017 and it crashes when I try to open it. Please help. Thanks in advance. I have removed all C++ and installed Visual C++ 2015 redistributable (x64) -14.0.24215


#21

Hey Niel, I’m not an expert but I think you need all the C++ redistributables, not just the 2015 version. In general, I believe you need to install x86 and x64 (if you have a 64bit machine, some programs might still use the 32bit versions). This isn’t specific to SketchUp (I have no idea which ones sketchup uses) but some programs use specific versions of the redistributables.

Here is a guide on another forum for installing all the versions

I hope that helps!