SketchUp Make 2017 Crashing at Startup

make
2017
crash
sketchup

#1

I’d never expect I’d have to make a topic like this myself, as usually, I’m the one who solves every issue with my computer but this is something new to me. Ok, so I have had SketchUp Make 2017 installed on our other computer and had no problems with it for a couple of weeks.

It started malfunctioning since yesterday. I’ve uninstalled and re-installed (yes - with administrator privileges) - no avail.

Funny thing is SketchUp CheckUp becomes unresponsive and closes mid-way through.

This notebook has a 1 GB NVIDIA GeForce 820M graphic card and runs on Windows 8.1 64-bit. I am slightly anxious because I have a deadline in a couple of days and my work is not finished.

Through this period the graphic card was updated 2 times. After the first update, SketchUp worked as always. I have a feeling this bug splat came about after the second update. Could that really be the case? Should I fill in my name and e-mail address so the Team Members can have a deeper look?

Thanks for any input.


#2

Okay, this is strange. I only reset the graphic card to take control of SketchUp and now it seems to be working. Should I leave it like this or follow the “if it ain’t broke don’t fix it” strategy?


#3

It seems like the 2nd graphics driver update changed the preferred graphics processor for SU back to the Intel integrated chipset? If that’s the setting you reset in the Nvidia control panel 3D setting menu, then you should be OK as long as you never need to rely on the OpenGL from your integrated Intel graphics on that machine.


#4

Thank you. Yes, I think that was the case. So far, it seems to be going smooth.


#5

Yes. For some obscure reason, leaving the graphics processor selection to automatic seems to result to the Nvidia or AMD graphics card sitting idle while Windows directs everything to use the Intel chip.

Anssi


#6

ALWAYS fill in the BugSplat! reports and send them. The bigs with the highest report numbers get higher priority. Also, if the cause is known, the Bugsplat website will display a information page.

So, we see that the cause is the Nvidia driver update is resetting your application settings. Is there a way to tell the Nvidia installer not to reset settings? (Perhaps check at the Nvidia website.)


Beyond, this, your images above show that the Intel HD graphics driver version is one known not to support SketchUp 2017. You should find a Intel driver of 10.18.01.4061 or higher.


#7

Thanks Dan. It’s been more than 24 hours since the fix. Til now I haven’t experienced anything unnatural.

You are right. This is strange because 2017 really does run quite smoothly on that notebook. I’ve just checked my own and I have a 9.17.10.2828 driver. SketchUp 2017 runs well on my machine too. As I understand “not supported” roughly means “be informed, you can face problems” not “the program won’t run at all”, correct?


#8

It really means that older driver versions (prior to 4061) had issues with creating OpenGL 3.x contexts. Usually SketchUp crashes during startup. (And it is not unique to SketchUp 2017, other company’s applications also had issues.)

So I am surprised if you did get by the startup routine, but Trimble said they have tried to better trap that error with M2.


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.