SketchUp Make doesn't start


#1

Hi everyone. I’ve decided to create this topic to report a problem and possibly find any light in this case.

I have a MSI GE72 2QD Laptop with Windows 10 Home (64bits) and a GTX960m. I’ve been using SketchUp since I bought this computer (Aug/2015) but, over this last week, the programs is presenting strange behavior. Right after I try to open the program, a new window will appear with SketchUp’s taskbar and trays, but the viewport won’t. After I try to click in any area of the window, SketchUp will stop responding, forcing me to shut it.

I can’t open any of my files, I’ve tried to reinstall it, reinstall the graphics card driver, I have even reinstalled the windows. Nothing seems to correct this issue. I’ve been using SketchUp Make 2015, I tried installing the 2016 version and the same problem occurs. I don’t get a bug splat screen or a code error, nothing. But, if I run windows in safe mode, I can use it normally. It’s driving me nuts.

Has anyone here experienced similar problems? Any ideas of what could be the cause of this strange behavior?

Thanks in advance.


#2

Additional information: I use a series of other softwares that are opengl based (Autocad, Revit, Rhino, and Blender) and all of them are working properly.


#3

Added any new plugins?

Once my Logitech Set Point driver/software became corrupted and seriously messed up how SU functioned - and only SU. Doing a repair reinstallation fixed things.


#4

No. It crashes right after reinstalling SU. Interesting that I use Logitech Set Point too, but I haven’t experienced anything abnormal with it. It’s like SU simply decided to not run in my computer anymore.


#5

Repair/update SetPoint. Part of your description resembled what I experienced with SU many years ago. SU froze.

To narrow down culprits I’ve compared logs of installed apps during safe mode, clean boot (less restrictive than safe mode and uses your graphic driver), and normal mode. HIjackThis was the app I used to generate the log file.


#6

Check your anti-viral software to see if SU is on its blocked/monitored list. I have Webroot and it thinks SU is evil. I need to set it to allow SU every times I update SU. SU many need to be running to check. The tab I check is called Control active Processes.


#7

Hi. Thanks for the reply. I checked SetPoint and everything is fine (already updated). I tried to use SketchUp with absolutely no third-party anti-virus running and it is still presenting the same problem.


#8

Running the latest version of IE, all up-to-date and cache and cookies cleared? SU uses many things from system browser - from javascript to webdialogs.

Ruled out plugins/extensions?


#9

Two suggestions:

  1. Open Control panel, select admin tools , data collection sets and check trace events and start ones. There are many other log files there you can check and maybe give you a clue;
  2. I Spent almost two weeks trying to fix may PC after it got flaky so , finally made sure I had all the MS updates installed except W10 . (Ever since MS played games with the DRM KB released under secuirity update I am very careful about what they do.) Any way after installing up dates I then reset IE ; I have W7 pro , 64 bits so at IE 11. After that ever thing started working and no more trouble to date. I have not checked W10 lately but MS was using user machines as a server to help the distribution of W10 and think you have a new browser so don’t know if you can reset like IE.
    Good Luck

#10

Logs of running background process can be long. To minimized the log length, open only SU in safe mode/ clean boot / normal mode then save log file of background processes.

I’ve been using ccleaner to clear all sort of temp files and even manage browser cookie collection through its option menu. Even though my browser is Chrome, there are many times ccleaner clears out more IE c-r-a-p than from Chrome in part because how Windows programs use tools from the system browser.


#11

Hi.

I ran out of patience and decided to format my (C:) drive and reinstall windows 10. SU seems to be working for this last couple of hours, but I’ll keep an eye in the suggestions that you both gave me and watch for IE settings. And if it happens again, I will boot in safe mode and save a log of background processes.

The most traumatizing part is that it happened without apparent reason, even returning after reinstalling the windows, making it hard to track since I didn’t do any major changes in my laptop.

Thank you both for the attention.


#12

Yeah, I remember my past PC traumas…

And save a log in each boot state to compare. Subtract the processes in the least restrictive boot state where SU works from the processes in the boot state where SU doesn’t run. Odds are one of those remaining processes is involved.

Trauma doesn’t end after you find the problem process. As something bad that screwed up that process could have done something somewhere that then affected SU. For example, I inadvertently installed a program beta that messed up a registry setting in IE (among other things.) Windows did not know which version of IE was installed. That lead to internet browsing issues and Photoshop would not load because it did not detect which version of IE was installed. By luck, the save logs from HijackThis included the IE version at the top of the log, so it stuck out. And my logs did not have a IE version number. Kudos to Ramesh, the MSMVP who helped me, and found the registry fix from someone using Quickbooks with the same IE issue (change a 0 to a 1.)

It took a month to track down that problem and fix.


#13

For Windows 10 the EDGE browser is default but E11 is also included for legacy application and you may have to make changes as part of the install but dot dot dot since I have not installed;
Even though you think you have not made any changes think auto updates are in play?
BTW failures may not be time correlated in that some thing may have happened days or even weeks before the issues shows up it . Depends on what the program is using and what is thought is the cause is some times is just the victim.
Hope not your case


#14

I might have figured the reason (and it is a really stupid one):

One thing that a I didn’t mention is that I use a dual screen monitors set up, and I found out that whenever the sketchup window was maximized to the second screen, it wouldn’t load properly.

So, I worked at my girlfriend’s apartment yesterday, using the laptop’s screen only, and the software magically opened and everything was okay. When I got home again and had the second monitor set up, the app returned to crash constantly. Interesting that, as I had both 2015 and 2016 versions, one of them was crashing (maximized to the second screen) and the other one wasn’t (maximized to the main screen).

Then I wondered if the problem would be related to that. After disconnecting the second screen, the same app that was crashing returned to open properly (on my main and only screen this time), and after reconnecting the second screen, it would crash again.

Has anyone ever experienced a problem like that? Any thoughts on how I could set the software to open on my second screen without crashing?


#15

SU has never officially supported multiple screens. But based on reports of those using multiple monitors dating back many years, SU should be set to open on main monitor.


#16

Hello MatheusAL good morning, i am interested to know what software you have tried, i am hunting for open source for my laptop to open revit files , revit is nice, but can be a bit slow on a high speed 11 inch laptop when i get about, lets know your thoughts on what you used , much appreciated regards Theo 64 0273136753 many thanks have a great weekend i am in AK NZ


#17

No such thing exists. The Revit format is proprietary to Autodesk.

Anssi


#18

Hello Anssi thanks , i think its time for a change there is now some really good open sourse cad software, i am sure it wont be long when autodesk will be sorry for holding back on what can open file types there are some cool software designers to help us all out, not being to open your revit files from one revit to another was a stupid move from autodesk and that will eventually hurt them for the inconvenience , not all companies want to keep buying another model up and it causes a hassle from one to another trying to swap files , i am sure it wont be long and they will loose out i have got to try on my 11 inch toshiba nb550d its darn fast using cad i got nano cad 5 seems better than autocad i have used for 40 years from 1 to 16 in all manner of jobs , its stunning open source , to test out , well programmed, for any one to use free 7 you pay for which is fair enough, i am sure it wont be long for some sort of revit version, that the modern days we all get to test out cheers from Theo in AK NZ have a great weekend


#19

thought i would reply as i just ran into a similar problem.

sometime ago i switched which dual monitor was my main screen and i have make pinned to the taskbar. after switching screens and clicking on makeup to open from the taskbar, it would get the blue line under it like it was open but would never actually open on the monitor. after switching back my main screen to the other monitor, everything worked fine.

if anyone is having a similar issue, i suggest playing with your dual monitors to rectify the problem.


#20

try opening sketchup via a sketchup save