Help - Sketchup won't start!


I recently purchased sketchup pro but am having a major problem as I can’t get SU to start. When I open the programme it starts and shows me to the startup page. I click on a template I want to use and then… nothing. The app appears open, but if I hover over the icon I just see a white box. If I click on the app in the task bar, I can see a white window expanding and contracting to the left of the screen but its just barely visible. Its completely unsuable.

I’ve updated my graphics driver, run the SU checkup and uninstalled and reinstalled the software completely (using run as administrator) but to no avail. I’m really stuck as I can’t do any work without it.

Layout works fine and will start up and allow me to open files but SU just opens a blank white window that is totally off screen.


Urgently need to resolve this so any help very much appreciated…



When you installed SketchUp and LayOut did you right click on the downloaded installer and choose Run as administrator? If not, or if you don’t remember, do that now. When you are presented with the options, select Repair. Then shut down and restart your computer. Does that help?

Downloaded and ran as administrator. Tried repair and restart but issue persisted. Then ran as administrator and reinstalled - still got the same issue…

After lots of trial and error I’ve sorted it. I had an old copy of 2017 which I have now deleted. Reinstalled as admin and it seems to have solved it.


Glad you got it sorted but it’s odd that removing SU2017 was required. I have SketchUp going back to 2015 on this computer and haven’t ever had any problems installing a newer version.


Have you changed your monitor setup lately?