SketchUp not opening after clicking start

First time posting here as I made an account specifically to ask this due to not being able to find an answer anywhere.

I just installed SketchUp onto my laptop to use for personal use as I enjoy creating things in it during my free time. However for some reason, I can click on the program icon and select the likes of a template etc. but as soon as I click ‘Start using SketchUp’ nothing loads and the program does not run.

I previously had SketchUp on an older PC and it ran completely fine with no problem however for some reason I now face this issue on my new PC.

Any help is appreciated, thank you!

Try running the SketchUp CheckUp application to make sure that the laptop is capable of running SketchUp.

-Marc

And if it won’t run the latest version (SU 2017) uninstall it, and try downloading an earlier version, which is less demanding on the graphics card drivers.

The official site has older versions here:
https://help.sketchup.com/en/article/60107

Cannot seem to find the CheckUp application. When I installed SketchUp Make (not Pro) it only installed SketchUp, LayOut and Style Builder.

But my laptop is brand new (actually bought it on Monday) and has higher spec than what is required.

You must always install SketchUp properly.
If you did not do it this way it can fail.

Find the installer exe file - probably in your Downloads folder - right-click > context-menu > "Run as administrator"
Installing it in any other way can cause all sorts of weird issues !
Just being an admin is NOT sufficient !

If you already have SketchUp installed you probably don’t need to uninstall/reinstall.
Instead close SketchUp and run the installer exactly as outlined above.
When prompted choose “Repair”…

Restart SketchUp - does it work any better ?

There’s a download link for CheckUp at the bottom of the article I linked.

Even if it’s a new machine, it’s possible that the video card drivers are outdated, or perhaps the video card settings are incorrect for the application, etc, etc.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.