SketchUp doesn't run (properly)

Good day!

I’ve installed skechtup about twoo weeks ago and used it once. It worked fine and I was exited to be able sketch my ideas. But when I tried to start it 1 hour ago, I chose a template and clicked ‘start using sketchup’. And the computer was busy, maybe trying to start the program… HDD 100% … after 10 minutes still nothing… I tried to close it and start again multiple times, tried to restart my computer, I’ve uninstalled and installed it again, but still the same problem. Does anyone know what’s going on?

Any chance you’ve had any new software installed recently? Perhaps something called

I see you’re using a laptop, NVidia card and Win 10. And I suppose your OS is 64-bit?

Test your graphics driver by going to the Window menu in SU > Preferences > OpenGL and disable hardware acceleration. Restart SU. Any difference?

If there’s a difference, as you’re using a laptop, go to the NVidia control panel. Go to the 3D setting and then to the menu which will let you choose to use the NVidia card for SU. By default, laptops will use the integrated graphics chip to save power. And for good measure, go to the NVidia website to download and then install the latest graphics driver for your card.

Sketchup is the only program i’ve installed recently.

Yes my OS is 64-bit.

I can not click on ‘preferences’ anywhere. I can only click on ‘add license’, ‘choose template’ and ‘start using sketchup’.

I’m searching for a way to test my driver

Go to Start using SketchUp. The Window menu I referred to is there. Disabling hardware acceleration is a way to test the driver’s OpenGL compliance.

Do a system search for as Dave suggests - it’s a ‘present’ via Win 10 update that’s causing issues with SU.

I can’t find anywhere, so most likely it’s not installed.

Where can I enter the window menu; is it in the left top corner? In the bar with ‘file’, ‘edit’, ‘view’, ‘camera’, ‘draw’, ‘tools’, ‘window?’, ‘plugins’, ‘help’? If so, then you must know that I bcan’t start the program like that, I can only start a simple … screen with the buttons I mentioned, and i can… unfold something called ‘learn’, also ‘license’ and ‘template’. Maybe I see this screen because it’s a trial for SU pro and the programme hasn’t actually started yet?

You are seeing the Welcome screen. The program hasn’t started. The button named Start using SketchUp doesn’t work?

Did you try updating your graphics driver from the NVidia website or make any adjustment in the NVidia control panel on whether you are using the graphics card or you MB integrated graphics when SU is running?

Another troubleshooting option is to uninstall the 64-bit version of SU and install the 32-bit version.

I´ve uninstalled SU and installed the 32 bit and it works! Hopefully it stil will when I start it again later. But I can sketch now, thanks a lot!


Good to hear, Sometimes the graphics driver OpenGL function calls play nicer with the 32-bit version of the program in Win 10.

But still check the NVidia control panel 3D settings to be sure you are set to use the NVidia card and its driver for SU. By default, laptops will use the integrated graphic chip to save power. And Update your NVidia card.

And get familiar with the OpenGL preferences options in SU to know what you are able to use.