SketchUp won't start - Checkup gives error (OpenGL library)

opengl
graphics
driver

#1

SketchUP 2017 was working on one of our computers and then just stopped working. I have updated the NVIDIA K2200 to the drivers that are available today. The WER report indicates that the problem is this NVIDIA driver: nvoglv64.DLL. I have removed all of the versions of Microsoft Visual C++ Runtime Library and downloaded the latest version from Microsoft. I have run a registry cleaner and cleaned out all problematic entries. After that I ran CheckUP and found the crash report indicating that nvoglv64.DLL is the problem. I have set the NVIDIA 3D to use the the K220 graphics card. ANy ideas?


#2

When installing the driver, did you r-click installer > Run as administrator?

Try older drivers?

Any SU Plugins? Thinking here, those load at startup and may sorta bump into other stuff at startup. Temporarily rename SU Plugins directory and try to reload SU.

Does SU load while in clean boot mode? Thinking here, can SU run with driver and unnecessary startup apps and services.


#3

I seem to remember having to uninstall the display adapter from Device Manager (until it said VGA Adapter) then booting into safe mode, and manually cleaning out ALL the "nv*" files from the "Windows/System32/" folder, before I could get the latest Nvidia driver to install correctly.
(After having this trouble, I installed the Nvidia Update utility.)


Just found this link:


  • Nvidia Update (for GeForce and ION GPUs)
    (Sorry Quadro users.)
    Automatically notifies you when a new driver for your computer is available, and directs to the download when you are ready to install it.

#4

I installed everything, including the video drivers, with ‘Run as Administrator’. I had renamed the Plugins folder before the last couple of install attempts. I will check that again. I will check to see if it runs in Safe Mode too.

Good gravy, I hope I don’t have to uninstall all of the video drivers as described by Dan. I suppose if it will work in Safe Mode, then that will be the first clue that I will need to do that.


#5

@kentsteen, when SketchUp fails to launch does it generate a BugSplat giving you the option to submit the crash information? If so, could you submit a BugSplat with your email address so we can identify it?

Thank you,
Thayer


#6

It did not give me a bugsplat. It would not finish startup. It would just stop trying to start and then generate a Windows Error Report.

I have it fixed. I am not sure how or what I did, but I will describe the process below:

I had removed every single version of Microsoft Visual C++ Runtime Library installed on the computer. AutoCAD threw a tantrum, so I had to reinstall a 2008 and 2010 version of those programs. After reading the previous responses, I removed SU CheckUP and 2017 SketchUP Pro from the machine and rebooted into Safe Mode. I ran SU CheckUP install (right-click - Admin) and it indicated that it needed to install another version of C++ Runtime. After that it installed, it started to run CheckUP. I got further into the process than at anytime previous. However, it still failed at the end of its program.

At this point I decided to see if I could install 2017 Make as a temporary stop gap measure until I could get our true IT people in here to figure it out. I rebooted into normal mode. Renamed the Sketchup 2017 folders in the Program Data and AppData/Roaming folder to something unrecognizable. Stopped the virus protection software. And ran the Setup for 2017 Make (at this point, please just assume I used right-click and ran all of these programs as an Administrator. I really don’t want to keep typing that). It installed another version of the C++ Library and installed completely. I held my breathe, crossed my fingers, knocked on wood three times and started it (R-C,RAA). It started. ???

Now that I knew that would work, I took a chance and uninstalled Make. Reboot. No virus protection software. Reinstalled Pro. Started Pro. Worked. Exited. Rebooted. Started Pro. Worked. Typed in license information. Still working. Fingers are still crossed. Makes it really hard to type. But it works.


#7

Glad to hear you were able to get it working. I’m sorry you had to jump through so many hoops though. Just to clarify for my own understanding, as I reread your post it looks like everything that you uninstalled and reinstalled was related to the MS Visual C++ Runtime or SketchUp itself and not the NVIDIA drivers. Is that correct?


#8

@kentsteen Which virus software are you using?


#9

Correct. C++ and SketchUP Make or Pro uninstall and reinstalled. The only other change was renaming the Program Data SketchUp 2017 folder.


#10

Our virus protection software is CyLance. Our IT professionals white listed SketchUp globally before I jumped through the hoops and it was not installing correctly. Now, it could be the reason that SketchUp stopped working out-of-the-blue, but it was not the reason for the installation errors. I had it shut-off the whole time I was working on the computer.


#11

Interesting. Thank you for this information.


#12

I had a similar problem, it went on and on until I was about to give up.
Until I removed all the C++ libraries (64 and 32) especially the latest ones from Microsoft.
I let Sketchup install its own library and VOILA! It all worked fine from there.
There is a lot of misleading info out there regarding poking into folders and updating the C++ libraries.

Then it wouldn’t take my legit license info, but that is a story for another day…