SketchUp 2017 Pro no start

intel
opengl
graphics
driver
hd4400

#1

I’ve installed 2017 Pro and when I double click the .exe (or shortcut to it) I get the Windows loading spinner for a few seconds and then nothing. Task Manager doesn’t show it running. Where to begin please?


#2

Hello. Did you install 2017 with Administrator privileges? This is a very common problem that gets asked here once or twice a week. Start here, then here and then here. Also, search the community posts as there are many similar issues.


#3

update the graphics driver, SU 2017 requires the OpenGL 3.0 support of the intel HD driver version 10.18.10.4061 (or higher).


#4

Thanks guys. I’ve done everything you suggest and I actually CAN report progress: Now, I get to the BugSplat and can report the error. LOL! Even SketchUp Checker fails about 3/4 though. What next?


#5

ensure to use the latest SU 2017 M(aintenance) 2 version (build 17.2.2555) which fixes some launching issues in connection with systems with a flaky OpenGL support. Just download and install (by “r-click > Run as Admin”) over your existing program installation, all settings will be kept.

More recent infos regarding the problem described always here.


#6

Thanks sketch. I repaired with the new version and it’s still crashing on startup in the exact same way.


#7

Hi Sketch,

Thanks for the link to 17.2.2555. I was having the same problem as cwk reported, but after installing the newer version I seem to have maybe solved my bug splat startup problem. Time will tell if it holds.

Chip


#8

@cwk, did you follow through the troubleshooting steps linked by sketch3d_de? Just asking as I don’t see where anyone clicked on the link which provides info and more links to update the things SU17 requires…


#9

Hi Sketch,

 Well, seems good things don't last.  After I loaded the M2 v17.2.2555, things worked fine for a bit.  Then yesterday it would not allow me to save models.  Then it would not open any models.  I did a "repair" operation, from the Download All center, but that didn't seem to help.  

In the past, a few days ago, I was able to have two models open also.  But then, it would open a particular model, but not a different one.

I've got a trouble call in with SketchUp Pro support and will probably get things straightened out on Monday, but it's too bad I loose three days in the process.  They've always been helpful in solving my problems,  they have talented folks working the problems.

 I don't want to do a complete uninstall/install until I speak with them, as I can loose huge amounts of work with a simple click of a button, which I've done in the past.  I'd rather not spend the time recreating things that are already in place.

 Any thoughts on further action?

Chip


#10

I did my research and called Dell, where I was able to get two drivers updated, 1 for an Intel HD Graphics 4600; and 1 for an AMD FirePro M6100 Fire GL V.

After doing this, it seems that SketchUp is back to acting as it should. Maybe this solved the problem.

Chip