Bug report during startup


#1

I have windows 7 professional. Nvidia Geforce GTS 250 video card. I’ve tried to install the latest version of sketchup without success. Sketchup generates a bug splat everytime I try to start it. Ive sent in the crash report several times. Downloaded and reinstalled several times.Video card driver is up to date. Sketchup will work if I boot up windows into safe mode but will also generate a Cant create dump file error.


#2

There’s at least an issue with your driver, which didn’t load in safe mode.

Try disabling hardware acceleration in normal mode. R-click on Desktop > Properties (context menu) > Settings (Tab) > Advanced (button) > Troubleshooting (tab). Slide the hardware acceleration slider to none. Click Apply. Try opening SU.

If SU opens, go to Window > Preferences > OpenGL. First try disabling Fast Feedback. Close SU. Re-enable hardware acceleration at the system level. Restart SU. If it opens, you can live without fast feedback. If SU doesn’t load, go back and disable hardware acceleration again at the system level, and try loading SU. Disable hardware acceleration inside SU through Window > Preferences > OpenGL. Close SU. Re-enable hardware acceleration at the system level. Restart SU. Helps?

If you now can open SU in normal mode, try installing older drivers. One of those may work on your computer.

When do you get the dump file error - anything to do with saving images, Vray? Googling the error brought up one solution of emptying the TEMP file.


#3

Hardware acceleration is greyed out in windows. Sketchup 8 works fine. I would use it but now my drawings from sketchup make are incompatible. I rolled back the display drivers, no luck. Also, now sketchup make doesnt work in safe mode.


#4

Did you add any extensions to SU14? SU14 uses Ruby 2.0, an upgrade from Ruby 1.8. Some plugins can cause the startup crash. I should have mentioned that too.


#5

Ive never added any extensions. All Ive ever done is download the installation program for sketchup and tried to install it. This program used to work fine. This is the only program On my system Im having trouble with.


#6

No hardware acceleration in normal mode? Low-end card? OpenGL has about 300 function calls. If the driver leaves out function calls that SU requires, there are problems with the program. Each new version of SU tends to rely more on OpenGL to increase program performance.

Desktop?

Check the NVidia control panel options, r-click on the desktop to access. Under 3D settings antialiasing and anisotropic filtering should both be set on application controlled. You also can try adjusting other settings.

Can you reinstall the driver that let you open SU in safe mode to try adjusting OpenGL settings inside SU?

@tt_su, could you check the bug reports? Gut feeling is the driver/card can’t deliver post-SU8. Think about upgrading.

Can you share the file so some here can saved it down to SU8?


#7

Is it listed somewhere when SU comes out with a new more demanding program what the minimum system requirements are? That way I would know before I upgraded SU whether or not I needed to buy a new video card. Then I wouldnt upgrade, keep my video card and have normal access to all my drawings.


#8

Per my Nvidia control panel, Antialiasing mode is application controlled as is anisotropic filtering. I have zero knowledge of all these video card settings and am certain me playing with them isnt the answer. I will say the bulk of these setting are application controlled. Again this is the only program Im having trouble with. Ive downloaded Freecad, AutoQ3d, 3Dcrafter 9, all my graphic intensive video games…they all work.


#9

It might just be that SketchUp is the only one of your applications that uses OpenGL. What kind of computer do you have? Many computers also have an Intel video chip in addition to the video card (embedded in your motherboard or main processor). In that case you might also make sure that 3D applications in general and SketchUp in particular is set to use the Nvidia card instead of the “Select automatically” or equivalent setting
Here is a screenshot from my desktop computer - your’s might look a bit different depending on OS and driver version.

Anssi


#10

[System requirements][1]. Another thing to check is that .NET framework is the right version. As you get the trial version of Pro with the SU Make installer, that may be an issue as SU8 and SU14 have different requirements. That’s a MS update.

Something is going on with your computer - hardware acceleration grayed out in normal mode, not being able to run SU in safe mode (which should load as it uses the default MS driver if there is a driver issue.)
[1]: http://help.sketchup.com/en/article/36208


#11

I have sketchup 14.0.49 installed on an older hard drive running windows xp. I booted into it instead of my current hard drive. I was able to open my drawings with that configuration. Same graphics card.


#12

At least you’re functional - got your file. Mystery remains. Something happened.

On your old XP drive, is normal mode hardware acceleration still grayed out at the system level?

An MS update for your Win7 set-up could have changed something that affected SU. OR something else changed/installed.