Sketchup crashes on starting


#1

Sketchup gets as far as the startup screen to choose the template. When you click to open sketchup it crashes and you get "Loadlibary failed with error 998: Invalid access to memory location. I have reinstalled sketchup several times to no avail. I have updated the graphic card driver.
Windows 7 Professional
ATI Radeon HD4650 gaphic card with OpenGL Version 6.14.10.11672.

The only two ways I can open it is either using the XP virtual machine or turning off the graphics card in the device manager, starting sketchup and then enabling the card again.

Can anyone offer a proper solution?

Thanks


#2

@webmaster

Geo had some.great insight on another forum:

https://productforums.google.com/forum/m/#!topic/sketchup/zAlf45hLGmU

Let me know if this helps. If not, I’m sure we can find a different solution.

~Drew


#3

if only disabling the SU hardware acceleration (= OpenGL) fixes the issue (= slow display output speed w/ big models) you might want consider buying an alternative video card as e.g. the reliable GeForce GTX 750 Ti in form of the quite MSI Twin Frozr model.


#4

Hi Drew,

Thanks for your help. I’ve been through that site and I can’t get any of them to work. I tired going into the graphics card Catalyst control centre and creating a profile for sketchup but it had no effect. I read of a registry edit for the 2013 version to turn off hardware acceleration but the registry entries are different for 2014.

The root of the problem does seem to be between Sketchup and the graphics card but I’ve tried lots of other 3d software including Blender and 3Dcaft, which work fine,so there should be no problem with the graphics card per se.

Regards Mark


#5

Did you add any plugins? SU14 uses Ruby 2.0 now.

AMD card drivers are optimized for gaming programs. So some of the OpenGL function calls required by SU may be left out of the driver - which has definitely been the case this past year, with more posted reports of issues with AMD cards. Try an older driver. For a few years, the drivers seemed to be working fine.

If your other programs don’t require the same OpenGL functions as SU, the comparison is a bit pointless.


#6

I never got the opportunity to install any plugins, it crashes before I get that far and non of the programs I use are gaming. I’ll see if I can find an older driver though but it seems a retrograde step. If more and more cards are having this problem Sketchup needs a patch if it is not going to become sidelined which would be a great pity.


#7

SU doesn’t control what video card manufacturers include in their drivers. OpenGL is a suite of about 300 function calls. Quite a few programs which require OpenGL don’t require all of those function calls so card manufacturers may leave out the less used function calls. AMD has a long history of weaker OpenGL support than NVIDIA cards.

SU developers have always provided a way for people with deficient graphic drivers to use SU - run SU without hardware acceleration. Go back and disable hardware acceleration at the system level again. Open SU and go to Window > Preferences > OpenGL and disable hardware acceleration there. Quit SU, restore hardware acceleration at the system level and try opening SU again.


#8

But I can’t start sketchup, it crashes as soon as I click on now start using sketchup after choosing my template. I need a way to turn off hardware acceleration without starting the program. If I disable the graphics card in the device manager the program will start but the option to turn off hardware acceleration is greyed out. One solution would probably be to do it through the registry entries but I can’t work out the appropriate one.


#9

Try clean boot or safe mode. Instructional links in this section https://sites.google.com/site/sketchupsage/problems/pc-install#TOC-System-Troubleshooting. If the problem is indeed just your graphics driver, safe mode uses the default MS driver and SU should open.

Also Google your error. I haven’t encountered your error around the SU forum, but it has appeared to other people.

If you have a laptop, be sure to choose the AMD driver for SU in Catalyst. Laptops rely on the integrated graphic accelerator’s driver to reduce power consumption unless the user overrides that setting.

I once had an AMD card that allowed me to use hardware acceleration if fast feedback was disabled through Window > Preferences > OpenGL. But I was able to temporarily disable hardware acceleration at the system level to adjust that setting back then.


#10

I have Googled the problem and clearly Sketchup is developing quite a reputation for this sort of instability so I’ve uninstalled it and will now look for a more stable piece of software!


#11

There is nothing UNRELIABLE about my graphics card, it works with every other piece of hardware!!!


#12

You’re using a laptop, right? To conserve battery useage, the integrated graphics chip on the MO is used unless you override that default setting to direct the computer to use the graphics card. The greyed out hardware acceleration option you saw indicates that hardware acceleration was not available to you for SU (the AMD card was not being used.)

One of the more sensible suggestions from MS was to right-click on the shortcut to run SU as administrator.

Sketch3d_de is a SU reseller who often deals with professionals with demanding software performance requirements on a budget. Once upon a time, SU only had the Pro version and catered to professional with computers that usually exceeded the hardware/system requirements - and that was back when files were commonly only 10 MB and a monster file was 40 MB. To improve SU performance, the developers rely more heavily on the graphics driver OpenGL functions as that specialize graphics RAM can be up to 3000x faster than other system resources. The graphics driver is now even involved in saving files. Some people now are somehow working with files as large as 600 MB. There’s an interesting balancing game dealing with the pro crowd and the free crowd. Yet millions of people use SU quite successfully.


SketchUp 2016 crashes on startup
#13

You mean software? It is a chance that Sketchup is the only software you use that needs OpenGL support. OpenGL is a graphics environment mainly used by higher-end 3D modeling applications (some 3D games use a subset). Other 3D games use DirectX, but for modeling it is slower.

I have used SketchUp since version 3 with several kinds of hardware, and with the right graphics driver it has always been very stable. I don’t use many plugins, though.

Anssi


#14

the maturity of the OpenGL support of the Radeon Catalyst driver has been proven many times in the past to be optimized for speed in games instead of accuracy with 3D modelers!!! This may of course change with new driver versions or drivers for different models… but the GeForce driver was in general more reliable in connection with OGL-based applications.

To eliminate a maybe garbled driver installation you can:

• download the latest Catalyst driver for your model
• unistall the Catalyst driver installed (preferably w/ admin rights)
• restart Windows (!)
• install the recent driver version downloaded above (preferably w/ admin rights)
• run SketchUp

if this doesn’t help, you may want try our free support tool for disabling the SU hardware acceleration from outside SU (Windows only).


Sketch Up Pro 2016 Crashes on startup!
#15

You have no way to know what the manufacture installed in your graphics card. As noted the performance is based on the functions included. I had a similar problem some time ago with open office after using it and my graphics card for a number of years. They did a minor up updateand I started getting blue screens!
All you are doing is making an assertion with out any basis except a feeling and will not even try some suggestion that could help you.
FYI here is a viewer that will audit your graphics card and tell what you really have http://www.realtech-vr.com/glview/


#16

try using the appropriate anti-virus with googlle SketchUp.
may be useful