Crashes & lock-ups


#1

I’m about to purchase a 3-D printer and immerse myself in that area of interest to see where it leads.

In preparation I have looked at countless numbers of videos of CAD software and finally decided that Sketchup would be the app I would learn to use.

Unhappily I can only keep it going for very very short periods of time before it locks up. Changing a tool or moving an object is usually what does it.

Hunting around for a solution I have seen many other reports of Sketchup crashing or locking up, and have yet to see a definitive solution.

64 bit Windows 8.1 desktop computer with plenty of storage and ram. Never had a problem running anything else. Have even completely uninstall using the very thorough Revo UnInstaller Pro and reinstalled from a reboot. No difference.

Does anybody have any likely suggestions before I wipe Sketchup and look for another alternative?

TIA


#2

Unless you have installed plugins that make SketchUp crash, the most likely problem is with your graphics card. You could try installing the latest driver for your card from AMD, and, if that doesn’t help, you can try, in SketchUp, unchecking the “Use Hardware Acceleration” box that can be found in the Window menu>Preferences>OpenGL dialog.

Lately, also, people with AMD graphics cards have been reporting similar problems here, and some of them were able to use SketchUp when they installed the 32-bit version instead of the 64-bit one. The 32-bit version will run on a 64-bit operating system, with only the memory footprint limited to about 4 GB. You are unlikely to run into that if you only make object models for 3D printing.

Another, unlikely, possibility is that some hardware problem is causing the crashing. Despite its simplicity, SketchUp is a very demanding application that stresses your system much more than simple word processing or web browsing would do.

Anssi


#3

It appears the AMD/ATI Radeon R7 cards may have issues with OpenGL.

These other users who have R7 cards also ran into issues:


#4

For those who say AMD cards only fail using SketchUp …

Adobe Forum: OpenGL Failure in Lightroom CC

Microsoft Answers: OpenGL Problem After Upgrading to Windows 8 (Solved)

Minecraft Fourm: How to fix OPENGL Problems in ATI Drivers

Facepunch: Has ATI/AMD fixed Catalyst’s OpenGL problem yet?
… which refers to a topic on the AMD Community that cannot be found.


#5

SketchUp would for most people be the only application requiring OpenGL At work I have Archicad and some IFC viewers (typically they are available for both PC and Mac). Autodesk has switched to DirectX but I am not necessarily happy about that, zooming in Revit feels clunkier than in SU or Archicad, and it still has the same model size limitations.

Anssi


#6

Thanks for the replies.

The video card is an AMD Raytheon R7
Total Memory: 3888MB
Display Mode: 1920 x 1080 (32-bit)(60Hz)
Windows 8.1 64-bit

I upgraded the driver as recommended by AMD’s driver analysis application.

No difference. Sketchup locks up almost immediately.

Complete uninstall of Sketchup, reinstall (no plug-ins added) with the new driver in place, still no difference.

The AMD site offers Windows 8.1 32-bit drivers for the “R7 200” series but not for the “R7 300” series. How do I tell which series mine is? I can’t see anything on the DirectX Diagnostic Tool/Display tab that indicates which series.


#7

Go back and read what Anssi and Dan first wrote - try installing the 32-bit version of SU.

Also in SU, go to Window > Preferences > OpenGL and disable Use hardware acceleration if installing the 32-bit version of SU doesn’t help.

SU does not use DirectX.


#8

Oops, my bad. I took that to mean install the 32 bit AMD drivers.

I’ll uninstall Sketchup again now and see if I can find the 32-bit version of it.

BTW, 64-bit Sketchup froze as soon as I clicked on the Window menu item, so not possible to change the setting of hardware acceleration.


#9

It’s not hard to find if you go here.


#10

There are at least 2 tools to switch off hardware acceleration outside of SU.


#11

OK Cataountain, following the instructions at the links you provided:

Running the file from set_skp2015_gfx_minimum.zip washed out my screen and caused Restart to cycle forever, forcing me to do a hard reset. Everything SEEMED back to normal after the reboot.

Then (after the restart) running the file from get_skp2015_gfx_settings.zip produced a text file which only contained the following:

ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.

So then I ran the ‘OpenGL Config4’ support tool, which shows disabled for Sketchup 2015.
http://forums.sketchup.com/clicks/track?url=http%3A%2F%2Fwww.posh.de%2Fcms%2Findex.php%3Foption%3Dcom_docman%26task%3Dcat_view%26gid%3D131%26Itemid%3D236&post_id=45241&topic_id=14833

Uninstall, reboot, reinstall Sketchup 2015 32-bit, and attempt to run it. After clicking on “Choose Template”, the “Welcome to Sketchup” dialog disappears and then – nothing. Sketchup fails to run.


[Win] Setting Preferences > OpenGL switches off via batch script
#12

A manual method of temporarily disabling hardware acceleration system-wide shown in the image at https://sites.google.com/site/sketchupsage/problems/pc-install#TOC-The-process. That example was in XP. There’s usually several ways to get to the same window to temporarily disable hardware acceleration.


#13

I answered in the other post, … linked to.


#14

It is a Radeon R7.

Control Panel > Device Manager > Display adapters (expand the category)

Double-click your adapter.

You’ll can copy the description from the “Details” panel, “Device Description” field. (Click it once to select it, right-click it and choose “Copy” from the popup context-menu. Then Paste it in a forum post.)

The “Driver” panel will list driver details, date, version, etc.

Make sure to go to the “Resources” panel, and check the “Conflicts” box at the bottom of the panel for any conflicts.

In the Microsoft forums, Microsoft engineers were telling people to install Windows 7 drivers into Windows 8.x… because the latter did not work.

At one of the graphics game forums (minecraft) people swear that the newest Catalyst driver sets do not work with OpenGL, and say that going back to v10.7 Beta does work with OpenGL.

Lastly, you need to uninstall any previous AMD/ATI driver set (Catalyst) and reboot the computer until it is running the “out-of-the-box” Microsoft generic Windows graphics driver, before installing a newer graphics driver. (This is the same protocol for Nvidia, or Intel graphics [if not running the Intel Driver Updater Utility.].)


#15

Well, I’m finally getting somewhere! I’ll document what I’ve done in case it helps someone else.

Use Revo UnInstaller to remove all traces of existing Sketchup installation.

Reboot PC.

Initiate a fresh install of Sketchup 32-bit (on this 64-bit desktop PC) using “Run As Administrator”. I don’t know how important that is, but I was not previously installing via “Run As Administrator”; I don’t recall seeing that instruction anywhere relating to Sketchup. Anyway…

Installation runs to completion – no errors reported or apparent.

Run Sketchup, click Window menu item, Sketchup freezes (indicated by the Windows 8.1 rotating blue circle).

Exit Sketchup.

Run regedit and verify that there exists: HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015

Run get_skp2015_gfx_settings.cmd. Result:

ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.
ERROR: The system was unable to find the specified registry key or value.

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\GLConfig_Display
FIRST_TIME REG_DWORD 0x0

Now run set_skp2015_gfx_minimum.cmd

Again, run get_skp2015_gfx_settings.cmd. Result:

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\Preferences
GfxUseAccelerationOffScreen REG_DWORD 0x0

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\Preferences
GfxUseAccelerationOnScreen REG_DWORD 0x0

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\Preferences
UseFastFeedback15 REG_DWORD 0x0

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\Textures
MaxGLSize REG_DWORD 0xffffffff

HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2015\GLConfig_Display
FIRST_TIME REG_DWORD 0x0

Run Sketchup 32-bit again.

For the first time I am able to access the menu tree:
“Window --> Preferences --> OpenGL” without the application freezing.

All three checkboxes on the System Preferences dialog (hardware acceleration; maximum texture size; fast feedback) are UNCHECKED.

I’m out of time for this now but tomorrow I’ll get into a Sketchup tutorial and see if the functionality persists through using it for a while. I’ll also try re-enabling those checkboxes one by one to see what can be learned.

Thank you for your suggestions and for sticking with me.

BTW, “washed out my screen” was a descriptive term, not technical. Desktop icons, applications Windows, everything on the screen was “whited out”, as if viewing through frosted glass. That caused me to force a Restart, which never completed, thus forcing me to initiate a hard reset. Fortunately there was no hangover after the restart.


#16

It is on the Installation Instructions page:
Installing SketchUp: http://help.sketchup.com/en/article/56085

… because it is standard operating procedure with Windows Vista & higher. (Without administrative rights an installer often cannot make changes to the registry, or write files in %ProgramData% or %ProgramFiles% paths, depending upon security settings and/or UAC.)

This indicates the installer does not initialize these attributes, it is the first running of SketchUp by a user that initializes them, to the maximum. This is why so many low end graphics cards are failing to start SketchUp.

SketchUp could do what these little scripts do and the function could be fired with a command line parameter, like:
sketchup.exe /minGfx
(hint hint for the SketchUp Dev Team.)

All set to minimum (ie, features OFF.)

That is what is supposed to happen.