Crash but not splat

I’m a relatively new user and enjoyed working with Sketchup Make 2015. I recently moved to a newer laptop and upgraded to 2016 (not a good idea to do both at once, I know). Since then, Sketchup shuts down within minutes with no notice or error. Tried uninstall/reinstall to no avail. Please advise.

A typical cause for this sort of behavior is tied to the graphics card. You might try turning off Hardware Acceleration in Preferences>OpenGL and see if the behavior changes.

Also check for driver updates for the graphics drivers.

Upgrading the card seemed to work. Thanks for your help and quick response.

1 Like

Well,I guess I was a little hasty in my reply. I completed both of your suggestions. Although the program stays on longer than before (4-5 mins vs 1-2 mins) it still closes without warning or saving. Any other things I can try?

Try turning off autosave in SketchUp’s preferences and see if it runs longer. Some graphics card issues cause crashes during autosave, which by default has a 5 minute interval.

I timed it at 8 minutes before shutdown. I never had this problem on my previous laptop (Windows 7 running Sketchup 2015).

It could still be a graphics card issue. If you search the forum you’ll find quite a few threads in which users are having difficulty because of Intel graphics.

Thanks DaveR and 'sl…'It seems the problem is being discussed with no solutions at this time. I found a post at Intel from Dec. basically saying that Intel doesn’t work with Sketchup and they know it. It seems they aren’t working to fix it. Hate to have to buy a new computer and won’t be going Pro at this time. I’ll keep watching this board to see i someone figures it out.

If it’s any consolation, I don’t think this is a SketchUp Pro vs. Make issue. I don’t think going to SketchUp Pro will change anything.

Sorry, but don’t hold your breath! Intel are the only ones who can fix this.

I think it is this thread and the reply by Esteban:
https://communities.intel.com/message/358625#358625

I’m not exactly sure what he is saying. Just some basic political PR “we strive to do our best” kinda junk, and “we work with developers when we can.” (Run on sentences. It is obvious that English is not the first language of the Intel forum jockeys. Very poor support. A lot of dissatisfied customers. But I see the same in the AMD and Nvidia forums. “The greasy wheel never squeaks, it seems.”)

Then he just throws the issue back at the OP, by posting a screen shot from SketchUp Requirements page, saying basically, SketchUp itself says you shouldn’t be running it using Intel graphics.


And, BTW, the OP in that thread was just complaining about clipping when zooming in close.

Several months ago, I bought a new laptop with the Intel HD 5500 video adapter integrated with an nVidia Geforce 840M. I installed my licensed version of SU Pro (the 64-bit version) and it resulted in my work simply disappearing after the file had been open and worked on for about 5 minutes or so.

In trying to diagnose the issue, I fiddled with settings in the OS and in the software to no avail. Ultimately, I removed the 64-bit version of SU and replaced it with the 32-bit version. This has solved the problem for me in using SketchUp on this specific laptop. I continue to use the 64-bit version with no problems on my other system whlch has an nVidia graphics card and not the Intel adapter.

You may want to try uninstalling your 64-bit version of SketchUp and installing the 32-bit v in its place. Admittedly this is not the most desirable solution because it reduces the available amount of usable memory in SketchUp, but if it allows you to use SU without it crashing, it is more economical than buying another computer. Having used the 32-bit v for about 5 months now with no major concerns, this may be a reasonable alternative approach in this case.

If you decide to take that route, let us know if it works for you.

Dan,

I remembered that my previous laptop ran Make 2015 fine. It also has an on-board Intel HD card. The difference is that it’s Windows 7. My new laptop is Windows 8.1.

In trying to make Sketchup work on the new laptop, I uninstalled 2016 and was trying to find a download for 2015 or a 32 bit version (based on J.V. Lee’s advice). I came across a website for “Softonic” that says that Make 2015 is not compatible with 8.1.

The fact that Sketchup doesn’t work (shuts down) on my new laptop points to the Windows version, not the video card. Would you agree?

Frank

Absolutely NOT. The issue is with certain version releases of your video card driver.

There is a link around here somewhere for a external utility to change the SketchUp registry settings for OpenGL.

I, for one, do not care what this website says, about anything, especially about SketchUp. They are not licensed to distribute SketchUp products, nor serve SketchUp product installers. (The admins here have removed links to their downloads, in the past.)

This website is one of those “mirror” sites that serves up other company’s product installers, without permission. They basically use other people’s products to generate traffic, so they can make ad banner revenue. I have no respect for them, nor any website like them.

2 Likes

All the official various downloads available for 2014, 2015 and 2016 are here:

But was it running the 32-bit edition ?
There should be no difference between Make 2015 and Make 2016, if the bitness is the same.

As mentioned too many times to count, try the 32-bit edition(s) if your graphics choke on the 64-bit edition(s). (For some unknown reason, both the Intel and AMD 64-bit drivers have problems with OpenGL.)

Dan,

I agree with your comment about Softonics and similar sites. I only mentioned it because they specifically said Sketchup was not compatible with Windows 8.1.

My old laptop ran Sketchup 64 bit just fine. I have been unable to install 32 bit on the new laptop due to remnants of 2016 64 bit remaining after uninstall. Not sure what to do now.

Frank

Did you right-click the installer and “Run as administrator” ?

(It matters not whether installing, repairing or uninstalling.)

Dan

Yes. Same problem.

Frank

Okay, check your user Temp directory, and delete the “sketchup_install” sub-directory if it exists.

You can find it’s path from a command prompt, by using the “set” command. (It will list all environment variables.) The “TEMP” and “TMP” variables contain the full path to your user temporary directory. (Note that the user “AppData” folders are hidden by default (in the folder tree) on Windows, since Vista (I think.) But you can paste in the full path into the breadcrumb bar of the Windows file explorer, and get to hidden sub-folders.

Then try running the Make 2016 installer again, by right-clicking and “Run as administrator.”

I previously operated SU on a Win 8.1 setup with no problem, so I do not agree that it is incompatible with that OS. Consider the source of your information…the Softonic site is not reliable and the veracity of info derived from that location is questionable, as @DanRathbun pointed out.