Sketchup crashes every few minutes


#1

this seems somewhat random and I can’t nail it down to a specific action. While I am working Sketchup just crashes and gives a bug-splat message. I went to autobackup every minute to keep from losing much. Sometimes it goes into a long wait - I have had to go have lunch while I am waiting it took so long. During that time files r being created and deletes as I watch my windows explorer window. Sometimes it splats in the process. Sometimes it appears to do it in the middle of a move, delete, insert, etc. - even just moving around.
It does it on large and small models.

how can I cure this?? SU2015 Make on W7 x64 - i7 with 16GB ram and EVGA 560 graphics .
hw acceleration is on.


SketchUp 2015 (64-bit) and Intel HD Graphics 5500
#2

Hi-

I just looked up your crash reports, and you must have the patience of a saint to have waited this long to contact us! I’m glad you got in touch.

The crashes are consistently in the same place, and may be related to a ruby plugin - can you tell me what plugins you’re running? I can’t determine the exact cause of your crashes, but I’ll call them to the attention of some other folks on the team who may be able to give more information.

I do have one suggestion, which is to download the newest version of SketchUp - you appear to be running 15.0, and we have done two maintenance releases since then (the latest version is now 15.2).

Also, have all of these crashes happened with a particular file that you’re working on?

Thanks,
Marc

Crash reports: 51540, 51369, and more


#3

This looks to be related to some extensions, but we’re not able to tell which one.

Can you PM any of us the content of your Plugins folder?

Then it would also help if you had a chance to remove your extensions one by one to see when the problem goes away. Then we can focus on that one and see if we can reproduce it.


#5

Based on the crash report this does not look like a registry issue and we would not recommend doing any modification to it. In general I’d not encourage users to meddle with the registry as it’s too easy to make mistakes that can make the whole system unusable. Even registry cleaners is something I urge people to stay away from because they can be overzealous in their “cleanup”.


#6

Thx - I lost contact with this request.
I have updated - I will see where that goes.

Then I will work on the extensions.
I just loaded one so that isn’t it.
I have STL import, SuSolid, Cleanup, and Extrusion tools. I think it was
doing it b4 Extrusion tools.
So that leave 2.
It usually does it when I am using the MOVE tool, but also at other
times, and sometimes it does it when I tell it to save the file. It
saves it, then crashes.

I 2nd the registry cleaner issue. I repair computers and have had
clients mess up their system - I have messed mine up also. Don’t use
them…


#7

well, the update is producing another issue. When I open any skp file it tells me the file is already open by another user. It is not. I am the only user. I must say no and open it again. Then it opens. This occurs with any file I open even if I had it open, closed it, and try to reopen.

The update also did not cure the crashing.

I disabled all the extensions that I added from the beginning till after the crashing occurred.
No help. I have now disabled every extension shown. No conclusion yet.
The issue with already open is still present - I never got that error with the original install.

update - it is still crashing - no extensions enabled, I hope it isn’t hardware accel b/c it looks terrible without it.


#8

I bump my request about the BugSplat data: Sketchup crashes every few minutes
I might be able to find some clues to what is happening if I can look at the BugSplat crash data.


#9

Have a look at this thread.


#10

I have 16GB of memory. This never happened until I updated Sketchup. It also does not happen with other programs even when I have 5 or 6 programs open at the same time. So I don’t think this is the issue. It does it whenever I open sketchup by clicking a file. If I open sketchup and then open a file it is OK. It does it anytime, however I did notice it did not do it a couple of times today then started again.
It will do it if I have no programs open and it is the first time I have opened Su in hours.


#12

So basically you didn’t read the thread.


#13

so basically it says
"To see the issue, you need to have the Preview pane open"
since I don’t EVER use the preview or thumbnails can I assume that this does not apply to what I am experiencing???

The locked issue is becoming more infrequent. Maybe it is like fine wine and gets better with age.
The crashing is still there.

UPDATE: It appears that the lock issue is mostly - maybe only - occurring after a crash now.
Hard to keep my mind on it, it is so aggravating. The crash seems to be occurring mostly when I am moving things around.


#14

Regarding the crashing, have you tried disabling hardware acceleration through Window > Preferences > OpenGL? If the crashing isn’t extension related then it needs be seen if it’s a graphics driver deficiency disguising itself as an extension issue.

Locking can also be a permission issue with an overly protective OS. People opening a file from an email or thumb drive can get the same read-only message. In those cases, the OS sees the file as foreign and possibly dangerous so you only get a read-only. Doing a Save As in SU with another name and to a location on your HD makes the OS happy.


#15

I don’t understand…
I had only one issue with SK 15.0 - it keeps crashing - usually but not always when I am moving things and sometimes on exit after it saves the file. I immediately reopen the autosave file and continue. Sometimes I get a warning b/c it starts acting erratically.

When I upgraded to 15.3 -331, I started getting the lock error when I went to reopen the file. If I wait long enough I USUALLY don’t get the lock error - but sometimes I do for a file I have not opened for hours. NO other system changes occurred.

The only other program that has trouble with hw accel is Firefox and it is a known bug. I have NEVER seen the lock issue with ANY program except when I actually have the program open and don’t realize it - not the case here.

So it isn’t my system or driver. I have a GTX 560 Ti, an I7 -3770K not overclocked, 16GB ram, 700W PSU, and with ALL driver up to date.
.
I disabled hw accel but the screen looks terrible. If it takes disabling hw accel to solve this - I’m on to another program b/c it really looks bad without it.

Maybe it is time to load a different program. Any suggestions?

I don’t know if it is related but when I move things and use the arrow keys to TRY to direct it where I want it is very erratic. Sometimes it works as expected, other times it moves any where it wants to in any direction but the arrow being pressed, sometimes jumping totally out of view requiring a ctrl Z to get it back.


#16

Disabling hardware acceleration is a troubleshooting step - not a cure. OpenGL is composed of a set of function calls. Driver developers may leave out a few critical function calls required by SU. Each version of SU uses the driver differently, so you may have a different working experience with different versions of SU on the same machine.

If you disable hardware acceleration and the symptoms subsides and/or goes away, it’s a good indication there is a driver-related issue. A GTX 560 should be adequate for a lot of modeling, but it’s isn’t a great card. I have a 500 series card in my current machine and there are OpenGL issues, although the program doesn’t crash while moving.


#17

I got rid of the locking issue – I gave up on 3.331 and rolled back to 2.685 – no more lock issue. It still crashes though.
I set hw accel off and moved everything in my model and it did not crash. The last time I tried that with hw accel on it crashed. It doesn’t prove it yet but I think it was a pretty good indication.

Now what?


#18

Do you download your drivers directly from NVIDIA?

Still submitting the crash reports with the older driver?

Look at your NVIDIA control panel. You should be able to access it by r-clicking on your desktop. Go to 3D Settings > Manage 3D settings. What is anisotropic filtering and Antialising mode set to? Are you relying on the settings to be globally set or do you set special settings for individual programs?


#19

Do you use the default Windows mouse driver? One time my Logitech mouse driver became corrupted and caused SU to behave quite badly. Though your problem doesn’t sound like it’s related to a naughty mouse driver.


#20

I do get them directly from nvidia - I noticed I was one behind so I updated yesterday. I had 1 crash today when using the push tool with hw accel off. Lock issue gone on 2.685.

I actually never touched the 3D settings in nVidia Cp. But here r the defaulted settings:

I’m using a Logitech mouse with Logitech drivers. I don’t see any issues with any other programs. But I will reinstall the latest.


#21

I guess y’all must be out of ideas.
I have new graphic driver - it was only one behind.
I have new/proper mouse driver - logitech instead of M$
I have tried no hw accel - same crashing though maybe not as frequently
I tried 3.331.0 and had the same crashing PLUS a file locking issue.
I rolled back version 3.331.0 to 2.685 and the locking issue stopped, so I can assume there is a bug in the 3.331.0.

I still have the crashes in 2.685 - what it does is to go into a save mode USUALLY during a move operation. MOST of the time it will crash but not always. If it does not crash it takes a very long time - 30 to 60 sec to come back ready. It creates the temp #.SKP files, sometimes a number of them, and the autosave file, then crashes.
I open the autosave file and continue. The biggest issue is that I loose all the history so I cannot undo things.

I will assume this is an SK issue and a bug in the basic version 15.
Is there a fix forthcoming???


#22

At the start of this thread Marc, who had had a glance at your Bugsplat reports, said that to him it looked like the crash was related to plugins. You had a few of them installed. Are they all new, 2015-specific versions? Have you tried disabling all plugins, and, if crashing stops, bringing them back one at a time to see id it resumes?

Anssi