Sketchup crashes every few minutes

I disabled them all and it made no difference.
forgot about that in my summary.

Marc also suggested updating SU. It may be time to try that again now that the lock issue was attributed to the graphics driver version.

Are you modeling with Shadows on? Any special line style or other preferences? Can you share a file that causes problems?

I still see traces of Ruby API in the crash reports. Can you temporarily remove extensions from your Plugins folder? Disabling from Preferences > Extensions might not mean that no extension hasn’t loaded something.

You seem to have more than one thing causing problems - bug splats indicating plugins and the ‘locking’ symptoms coming from particular graphics driver(s). Multiple triggers/variables is harder to diagnose from based on a few sentences in a help forum. Updating the drivers I suggested was not done in vane. It was intended to limit some know triggers and nudge your computer to a clean baseline.

Something that’s a bit odd is the pairing of a 500 series NVIDIA graphics card with an I7 processor. The I7 deserves better. Your existing power supply would support an upgrade. Though I’m not saying this would address your crashing problem.

I do not believe that the locking issue was a result of the graphics
driver. I can’t swear to it b/c I can no longer remember the sequence,
but I am almost positive I updated the graphics driver b4 I rolled back
the SU version as it was ur suggestion. I rolled back b/c I did not get
it in 15.2.??. I normally keep up to date on drivers and the nvidia I
had was only one rev old. I got that 500 bd b4 I upgraded to an i7 and I
don’t do gaming so it seems to be sufficient. Anything better is a
little pricey.
The crashes appear to occur after a move and *during *an autosave. I
have had it crash after another operation, maybe a push or a resize. But
I use move a lot more.
I have set the autosave to a very short time b/c of the crash but maybe
that is making it worse. Many times nothing happens after I do a move.
Sometimes it will do the autosave and come back ready but it seems to
take an awful long time to write the file and it is writing & rewriting
the numbered files - I assume some temp version of autosave.

I recommended rolling back the driver version, not SU version. The SU maintenance releases addressed some bugs, so it’s a good idea to keep current on that. Graphics drivers can vary in what all OpenGL function calls are included with each version, sometimes an older driver will work better if the latest driver is missing function call(s) a program like SU require.

Are all your plugins removed from the Plugins directory? Your splats still indicate plugins are involved. One fella with an AMD card had issues with the Depth Cue line style - but that was with AMD driver.

A MSI twin frozr (two fans but reportedly quieter than other brands) 750 or 760 with 2 GB RAM would be a better pairing with a lower clock I7 without costing too much. The dedicated RAM on the graphics card can be up to 3000x more efficient than system RAM to do the processing it has to do. I have a 500 series card on my old machine - it’s a wiener. New machine will have a 760 with liquid-cooled I7. Look up posts by sketch3d_de for good hardware component pairings to optimize SU performance.

Be aware the some plugins that install via .exe can be in places other than the default plugin folder.
Various Render plugins do this and can cause splats if you have the wrong version.

if i understand correct the file locking problem is a regression issue of M3 for fixing the Windows preview crash bug of M2 and earlier.

for disabling plugins do a “Window > Ruby Console”:


restart SU and do a:

is_disabled = Sketchup.plugins_disabled?

for checking that plugins are disabled.


Going down a side path…
In your NVIDIA control panel, under…
“3D Settings”
Ensure that the “Let 3d application decide” in the selected option.
That way any manually made adjustments to the settings you have for SketchUp [on the NVIDIA] side will be overridden by SketchUp itself.
This might help ??

On 3/9/2015 11:04 AM, TIG wrote:

OK, the issue was a plugin!!!

But now how do I install one at a time to determine which one.
Every time I try to install 1, all the rest get installed.

I have STP import/export == the ONE I am trying to install
Cleanup3 and SuSolid also get installed. They r not in my list @
extension warehouse

[quote=“bill_ruggirello, post:33, topic:6668, full:true”]I have STL import/export == the ONE I am trying to install
Cleanup3 and SuSolid also get installed. They r not in my list @ extension warehouse[/quote]

probably because they are installed by the SCF plugin store plugin.

You sure about that plugin being the problem?

Your problem sounds very familiar. I have all the plugins you mentioned and don’t have any trouble with them.

What I DO have trouble with is autosave, ironically. My guess is you started having crashes, so after a lot of lost time you went in and increased your autosave frequency so you wouldn’t loose so much work, it then crashed more often but you probably didn’t put it together because the crashes were random. If the autosave kicks in while you are doing something, particularly while editing groups or components, bugsplat.

As soon as I turned off autosave I cut my crash frequency down significantly (not entirely, this is still a ridiculously buggy software, if this thing actually killed a bug every time one of us got a bugsplat, all the bats would starve to death).

Give it a try. And Trimble, fix the stupid autosave, I’m here looking for the solution to yet another crash that wouldn’t have lost me so much time (and $$$) if I could use it.

Good luck.

Finally, an answer I can deal with. It actually makes sense.
And it has to be true because it sounds like it comes from a REAL user.
I was thinking that, since every time it crashed it made a backup - lucky me!!
And u r exactly right about the reason I increased the backup frequency.
So the solution is to turn off autobackup, save often, and hope Trimble fixes the REAL PROBLEM.

thx again.

If you have a file that fails consistently on Autosave, then submit it to support. @dewitt_justin, I promise you, if you do that, we’ll fix it, 100% of the time. The problem is that 99% of the time, it happens on your system and not other computers in your office or ours. And the problem most likely is not Autosave, it’s how the file got something in it that is corrupt and will fail. And in our statistics, most of the time that’s plugins. What we HAVE done to address this is to vet extensions through the Extension Store, and let developers know when their are issues in their software that could cause issues with other software, possibly stomping on each other.

So what have we learned here? 1. If you have an issue and can reproduce it, submit the file to support. We’ve hired many more support people than we had at Google. 2. You’ve got LOTS of good suggestions on plugins and graphics cards from a lot of talented people, so store this link somewhere, and refer to it if you get into trouble again.

I don’t understand your reply…
@dewitt_justin nailed my issue. All the previous info/suggestions may/may not be worth something but they all had nothing to do with my problem. Submitting a file has nothing to do with it - all of them create the problem.

Are u saying that I should just deal directly with justin b/c he has the answers???

Obviously, he went thru EXACTLY the same scenario that I did telling me specifically what I did to make the problem even worse with increasing the autosave frequency - so my autosave is off, I manually save and I have no crashing issues.

thx for trying.

Your and Justin’s Autosave ‘problem’ is a symptom of something else. Odd’s are the culprit is plugin related. So the problem you experience will be unique to your system. The problem will persist as long as the underlying cause - 3rd-party plugins added to SketchUp - remains.


See @catamountain 's reply.

For the past 2 months, people have been trying to help you. If you choose to ignore suggestions for the root cause of your problem and instead change something to address a symptom, that’s your choice. Good luck.

thx guys for ur effort. Now when is Trimble going to fix the issue with autosave that is causing the crashes?

Obviously, it is an interaction between plugins and autosave. I have ALL the plugins I had before and a few more and do not have the same type of crash or frequency with autosave off. Yes it still crashes periodically with totally different symptoms that I cannot pin down.

FYI, I didn’t ignore suggestions, but NONE of them helped 1% except turning off ALL plugins or turning off AUTOSAVE.

u do the math.

Plugins are created by 3rd-party developers. Those developers are responsible for their plugins - not the SketchUp developers. Use them at your own risk.

The plugins obtain from the Extension Warehouse are vetted by the SketchUp team. That plugin source will be the closest you get to quality control by the SU team before plugins are released to the public. But as everyone knows, good SU plugins are available from many sources.

Find the plugin that causes the problem at your end and report the problem to that plugin developer. It’s a bit of a catch 22 here because you would rather disable a symptom than find the cause. -That’s your choice. Good Luck. Likewise, the SU Ruby environment and OpenGL usage changes between versions too. Plugin developers often need to update their work to accommodate the changes: but they are not required to do that neither.

We isolated the problem. It’s your job to systematically go through your plugin collection to locate the problem plugin. If you rather disable the symptom instead, that’s fine with me too.

1 Like