Many crashes with Sketchup Pro 2022

2022-04-19T03:00:00Z

I’m having a problem with Sketchup not being able to work on a file for more than 10 minutes and it closes unexpectedly and the splat bug box doesn’t always appear or auto save.
I don’t know what else to do, because I’ve already configured the graphics card, I’ve updated all the drivers, I even uninstalled and reinstalled again “run as administrator”

I already did the Checkup to see if something is not compatible

[Results:
Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.
Congratulations, your computer has met all the minimum requirements to run SketchUp 2022.]

And this is happening for a variety of reasons,
usually it’s during the autosave the screen freezes and it simply closes and I lose all my work because it doesn’t always autosave or simply when I go to save the same thing happens, or when I orbit it freezes the screen and closes, with paste in place it freezes and close, push pull or move.

I thought it was the file because it was too big but it’s happening with other files too.

Windows 10 Pro
CPU Intel Core i7-7700HQ
GPU - Intel HD Graphics 630 and NVIDIA GeForce GTX 1050 Ti
32GB Ram

Any extensions running?
Which ones?

I don’t have any one

And periphery? 3D mouse, monitors etc.

No monitor, but I have a mouse and a keyboard

That’s real old school modeling, then😃
I would guess you are on a laptop.
What does [menu] Window > Preferences > OpenGL > Graphic Card details say?
Is it using the Nvidia card?

I just started fresh with this notebook, and and i haven’t installed the plugins yet hahaha
And Yes it is Nvidia

Btw thanks for answering
nvidia

Next thing, what is the save location? Onedrive?

Are you saving your models “to the cloud” or is the folder you are saving to synced with “the cloud”?
Does this happen with all files or only one? How large is it (size on disk/edges and faces)?

I save the files I’m working on to the desktop. I usually save to the cloud but I never use it directly from there.
But I’m having problem with different files and different sizes.

The complete file is 534 MB (560,848,896 bytes) but I separated a file without vegetation and decoration and this one is 110 MB (116,387,840 bytes)

And both are without faces and edges, I do group and component of everything.

Faces and edges go nowhere when you put them inside groups and components. SketchUp still has to process them. You see their count if you check the “Show nested components” box in the Window menu>Model Info>Statistics dialog. Your file is enormous.

1 Like

The biggest is with Edges 88780393 Faces 39619444 and the another one Edges 12341712 Faces 7066097

But yes this is the biggest file I worked with

The average size I always work with is 200-400mb, but I never had this problem with earlier versions of sketchup

And the problem is that it is closing suddenly even with small files of 58mb

What i have noticed is this



So

Massive file - not in itself an issue, but I’m 100% certain there is some optimisation you can do to help that.

However if the file is 524meg, then autosave is having to create a large file every 10 minutes which will take some time (not responding is usually when sketchup is "saving)

if you are saving to a a cloud folder, then the cloud service may actually lock out the file - if the file gets locked AS SketchUp tries to save, or worse, mid way through the save, then this may cause things to crash or worse, become corrupted.
This often happens with antivirus software too, which will lock a file as it is being scanned.

  1. Try optimising the model : purge out spare components, repair split edges
  2. Try saving to a folder that is not syncing with a cloud service: if you need to save to the cloud you could always use your free trimble connect storage.
2 Likes