Crash on launch

First few things to note:

Yes my graphics driver is up to date
Yes my Graphics card works with OpenGL
Yes i reinstalled Sketchup many times, including a few drivers.
Yes i tried disabling Windows Defender to start the program
Yes my windows is up to date.

Now: I tried to start sketchup.exe many ways and it seems to crash immediatly. The crash log basically shows no error and just suddenly stops so no help there. Does anyone know what might cause this?

I pasted the log here below and nothing is missing, it just suddenly stops.

======== Starting GL ========
WGLUtils::IsExtensionFinderWindowClassRegistered: Class is not registered.
WGLUtils::EnumerateAttachedDisplayDevices: \\.\DISPLAY1 : Intel(R) HD Graphics 4600 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \\.\DISPLAY2 : Intel(R) HD Graphics 4600 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \\.\DISPLAY3 : Intel(R) HD Graphics 4600 : PT 1
WGLUtils::UtilsState::ctor: Max GPU perf is 1
GlInformation: Starting graphics capabilities tests.
WGLUtils::GetBestPixelFormat: Selected pixel format:
  Id: 5 DBL RGBA:8-8-8-8 Depth:24 Stencil:8 MSAA:0 FF:0
WGLUtils::CreateGLContext: Creating HGLRC with wglCreateContextAttribsARB.
GlInformation: GL renderer information:
  GL_VENDOR: Intel
GL_RENDERER: Intel(R) HD Graphics 4600
 GL_VERSION: 4.2.0 - Build
GlInformation: Compiling UberShader

Any help would be very welcome, i need sketchup for my studies

(quick note: i recently reset this pc to factory settings to fix some issues. I had sketchup 2015 before the reset installed without any problems)

You may have installed and reinstalled SketchUp. Did you install it correctly by right clicking on the installer EXE file and choosing Run as administrator?

Your graphics card might support OpenGL. Does it support OpenGL3.0 or higher?

It supports OpenGL4.2 which it now has installed and yes sadly i tried installing as administator.

Logged in as adminstrator or Run as administrator from the Context menu?

Logged in as administrator and selected it with right click > ‘Run as Administrator’

Log in as you normally would and then try Run as administrator.

Your error message implicates the GPU and its drivers. Intel GPUs are well known for their lack of adequate OpenGL support. Maybe you’ll have to roll back to an earlier driver version to find one that works.

Tried both, sadly got me nowhere.

Maybe it’s time for a new graphics card.

Sadly this is a laptop as seen by the 840m graphics card so this is not changable.
Is there no other way to keep this running?

If your graphics card is not up to the task of running OpenGL properly, you could perhaps go back to SketchUp 2016 and turn off Hardware Acceleration to make the CPU do the rendering work.

Thank you, luckily 2016 also had no problems opening the file i needed to continue. Seems like something inbetween 2017 and 2016 broke the program for my laptop.

I didn’t have to disable hardware acceleration though.

SU2017 is more demanding of the GPU. Since yours is evidently a porch dog, stick with SU2016.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.