Sketchup won't run on PC


#1

I’ve been successfully using SketchUp on a Mac. When I install SketchUp on my Win7 64-bit PC, it fails to run and I get this SketchUp Error Report. Any suggestions how to get around this problem?


#2

It’s hard to tell with so little information but as I understand it, SketchUp won’t run on ‘a’ graphics cards as your profile indicates you have.

Seriously, what graphics card is in your computer? Typically, when SketchUp crashes on startup, the problem winds up being related to the graphics card and/or its drivers.


#3


#4

Radeon cards are well known to be lacking in OpenGL support. Not too long ago, an automatic driver update for Radeon cards also loaded a program called Plays.tv. That program caused all sorts of problems. (search the forum for references to it) Look to see if you have it installed and uninstall it. See what happens.

How about updating your profile, too?


#5

if uninstalling ‘Plays.tv’ doens’t help you may want try the 32-bit version of SU which is known to be more compatible with the flaky OpenGL support of the AMD Radeon/Crimson driver.


#6

Unless I am mistaken, only Pro versions are available at your link. I am not “Pro” yet.


#7


#8

What is the prefered graphics card for SU?


#9

nVidia Geforce cards have been noted for working well.


#10

The driver date is shown as 11/16/2012, an update should be done regardless of this problem…


#11

Updating the driver is a good suggestion. I have been to the AMD web page and updated two different ways. The version remains the same so, I conclude, that I must have the most current driver for my board.


#12

Geforce GTX 960/1060 for desktop systems.

if nothing (recent driver, SU x32) helps and you don’t wanna swap your graphics card yet, you can get SU to run (slow) by disabling the hardware based OpenGL graphics output acceleration by disabling “Windows > Preferences > OpenGL > Use Hardware Acceleration”.

If launching still fails, you can use our free support tool ‘OpenGL Config’ f. Windows (no adware/spyware/installation), download to e.g. Windows desktop and launch.


#13

disabling the hardware based OpenGL graphics output acceleration by disabling “Windows > Preferences > OpenGL > Use Hardware Acceleration”.

My installation of Sketchup fails before I can see any of the pull down menus. So, disabling acceleration is not possible.

I was hopeful SK would work when I inherited my supervisor’s ATI FirePro 3D Graphics V3700 card this week. Regrettably, it fails too. The last driver update for it was 8/17/2009.


#14

That support tool seems does not let me apply the fix to my computer.


#15

SketchUp 2017 does use a new OpenGL graphics pipeline and is therefore not supported anymore.