Sketchup takes ages to start

I’m not sure is going on with sketchup (and layout) on my machine. When I start sketchup it takes about 5 minutes for everything to display and be able to use it.

I uninstalled it and reinstalled and it’s still doing it. The only thing I did before all this started was a deleted folders of previous versions along with other miscellaneous folders to free up space. I didn’t touch anything that had to do with 2020.

Did you install SketchUp correctly by right clicking on the downloaded installer and choosing Run as administrator?

Do you have a bunch of extensions loading?

Yes I did.

I don’t have that many extensions being loaded but I’ll disable all of them and see if that makes a difference.

Does it start with a model already open (or are you launching by double-clicking a .skp file)? If so, there may be a problem with that particular file.

It’s just double clicking the SU icon. My default is a empty scene.

I’ve disabled all extensions apart from native SU and Vray. Still hangs up before starting. :angry:

Is your profile correct that you are using an Nvidia gtx745 GPU? Are you certain that SketchUp is using it? Have you tried updating the graphics drivers?

FWIW, the gtx745 benchmarks fairly low and SketchUp really requires a suitable graphics card.

I’ve been using this card since I got the box from HP a few years ago. Max, VRay, Corona Sketchup never had any issues. This has only been happening for the past couple of weeks. Granted I need a better card anyway so maybe I’ll order one but the card shouldn’t influence the start up of the programme?

SU works okay once it’s going it’s just waiting for it to start up.

Maybe I’ll uninstall and reinstall again.

I uninstalled and did a clean install. This time I made sure to right click/run as administrator. I thought I did that before but who knows.

All seems to be well again now. All I have to do is go reinstall vray and all my extensions.