SketchUp takes a while to start up


Lately, my SketchUp Pro 2023 is taking longer to start up. I tried resetting and reinstalling the app, but it was still the same. Any idea how to fix this? I have an i7 13th gen, 3080 ti GPU, and 64 RAM. The app is installed on an M.2 drive. I have no issues with operating the app, even with 600MB+ files.

Thank you for your time.

Do you have a lot of extensions? They are often the reason why SketchUp take more time to start up…

1 Like

@rtches is correct. The more extensions you have running the longer it will take to load and be ready for your input.

Extensions are loaded after you open an existing document are start a new one. If it’s taking a long time to get to the welcome screen, you may have a lot of recent files that are taking time to render the thumbnail.

How long does it take until you see the welcome screen?

I just uninstalled six extensions and kept only one, and it still took a minute and a half to start.

This happens when I also start a new file…

Where do you store your models? The thumbnail rendering mentioned by @colin might take very long if they are stored in the cloud. Just a thought.

If you get to the welcome screen quickly, and it’s only slow when opening an old file or starting a new one, your components and other collections can affect how long it takes.

Do you have any collections, and if so where are they stored?

This also happens when I try to start the application and start a new file. I just checked my components folder, and I have no files there. Can it be Cache files from AppData?

I am still looking for a solution…

What operating system? Your answer of ‘64’ in your profile is not an answer. Please complete your forum profile.

Which one?

[quote=“DaveR, post:11, topic:242785”]

[/quote] I am running a 64-bit operating system on Windows 11 Pro version 22H2 - 13th Gen i7-13700K 3.40 GHz

SU Podium, a rendering extension. Sorry, it is my first time using SketchUp Forums.

Put that in your forum profile.

Try removing or disabling Podium. It’s probably the one causing the delay.

Rendering extensions are the ones that take more time to load, I use sketchucation extension manager to disable the rendering extensions and other extensions that I don’t need for an specific project and when I need to use them just activate it from there, it’s better than the native extension manager imo because you have a list of the active and inactive plug-ins, that makes it easier to locate the extensions, with the native manager you must scroll and search the plugin you want to activate, if you have few plug-ins it’s not an issue but when you have a lot and you’re tired you can miss it and you’ll be trying to find it for a while.