Sketchup VERY slow to start up! 2 minutes

For some reason recently my Sketchup (2022) takes nearly 2 minutes to open a pretty blank default template. I never used to have this problem. I have already tried disabling all of my extensions, repairing Sketchup and opening it from its file location rather than the shortcut.

Does anyone know why this could be?
Also, if I was to uninstall Sketchup 2022 and reinstall the same version, will all of my settings stay the same, templates, extensions still be there? I am hesitant to do this incase it wipes everything.
It’s making my workload super frustrating and inefficient.

Any help will be much appreciated. :slight_smile:

Share the .skp file with us so we can see what “pretty blank” means.

If you uninstall and reinstall SketchUp you won’t lose extensions or things like keyboard shortcuts.

Your profile isn’t clear regarding operating system. Is it Windows? If so, which Windows version?

1 Like

Could it be that your template contains huge components that are not shown but have been saved with the file.

Try using Model Info → Statistics to see if you have a lot of edges, faces and components.

1 Like

Problem Template.skp (872.8 KB)

Now that I think more about the template - Could it possibly be my Components Library trying to load each time I open it in Tray 1?

Thank you for your help.

A template should not be 873 Kb. So on top of waiting for all of your extensions to load you’re also waiting for SketchUp to deal with a bunch of unused stuff.
Screenshot - 6_28_2023 , 3_56_53 PM

See if this one opens more quickly.
Problem Template purged.skp (124.5 KB)

1 Like

Unfortunately this didn’t fix the problem. It still takes 2 minutes to open that file, even with extensions disabled.

I’m thinking this may be an issue with recently adding my component library to sketchup (which is 2.7GB) and for some reason it’s trying to load this all on opening perhaps?

That could indeed be the problem. Where did you add that component library? Try moving the folder out of that location or make Sketchup look elsewhere for components.

You should set SketchUp to look at only In Model components when it starts.

Your template still didn’t need that extra baggage, though.

I usually click “open or create a local collection” and select the folder from there.


This should have nothing to do with the trays.

So move the component collection from where it is or rename it so SketchUp can’t see it for loading and then see what opening SketchUp does.

1 Like

Have you got the component library stored on a slow device like cloud storage or a network share?

1 Like

I renamed the library, and now its opening at approx. 30 seconds which is a lot better than 1.5 minutes! Thank you for you help - I am about to reply to question below.

Yes. It is stored on a shared Google drive - however I have made the library “Available offline”

However this will all be changing next week - and maybe it is the issue. I will see what system we will change to and see if that helps. Thankyou.

Still, if you’re connected to the internet it would be looking at the cloud to load from. No wonder it’s slow.

That’s not a great option. Hopefully you aren’t saving your project SketchUp files directly to your Google Drive and working on them from there.

Put your coponents in a folder on your hard drive instead of a Google Drive folder. Personally I have found it best to put the component collections in the default location on my main internal drive.


This must be the issue. Thankfully we are getting new systems next week for all of the drive to be reconstructed with design team having our own storage. Multiple people need to access the same library - but I will copy the library over into my hardrive to use until the changes next week. Very much appreciate your help! Thank you

HI Guys, I had the same problem & after much tinkering I found my problem was my Anti Virus software, I disabled & boy it goes like a rocket, with it enabled is soooooo slow, hope this helps.

1 Like

Is that with SU2021 as indicated in your forum profile or are you using a newer version? Have you tried whitelisting SketchUp with your AV software?

It is with SU2021, I did a clean install of anti-virus it was all working fine until about a few months back, I did have programmes including SU on the exception list, but it did not make any difference, I am still tinkering, but if it saves people time trying to locate the potential issue of slow down…I will let you know if it remains the case.

Well, since SketchUp 2021 hasn’t changed in several years, it’s obviously something else. Seems like you ought to be able to have the AV software running without it causing SketchUp to slow down. At least you have an angle to work, though.