Sudden Problem - Sketchup slow in once template opens


#1

Hi, Been a 10+ year user of Sketchup. Work with very complex models and am a regular user of components and have utilized techniques to model efficiently. But all of the sudden sketchup is running really slow. Tried reinstalling Sketchup, but the problem still persists. What is odd is, even if I don’t open a complex model and just open a new template the orbit tool is really slow. Moving around in any way with any tool is really slow.

All other programs have been closed. Ran a diagnostic of my laptop but found no problems.


#2

Hello. This happened to me too when I tried adding a high resolution custom gradient background via the Watermark feature. Try changing your style to something else and see if you get smoother orbiting. If yes, then this is can be because of your style settings.


#3

Does it happen with all templates or just your custom template?


#4

Hi Guys,

Thanks for the reply. I haven’t replied in a few hours because I had to leave for work. I will answer some of the questions later today. Thanks!


#5

Hi Again. Suspected it was my NVIDIA driver. Updated it and now everything seems to be fine.