SketchUp suddenly very slow, even with new template


#1

Hi all,

When I opened my drawing in Sketchup this afternoon I noticed it was very laggy and slow. Orbiting and zooming wasn’t smooth anymore and the fan in my laptop started to blow a lot harder… My laptop is a week old (brandspankingnew) and I haven’t had any problems until now… I closed SketchUp and opened a new blank template but even then orbiting and zooming became very slow again…

I saw a similar topic two days ago where the topic starter claimed that his graphic card update solved the problem. I also checked for updates for my Nvidia driver but it was already up to date…

Very strange… I hope you guys can help me :slight_smile:


#2

There is another post today in which the writer found that windows 10 had updated the graphics driver with results similar to yours. Rolling back the driver fixed his.


#3

any updates to this issue? same thing just happened to me :frowning:


#4

Same thing here, opened Sketchup this morning and almost was not able to move around at all… I did not get a notification that Windows 10 peformed any update…


#5

As slbaumgartner said, rolling back on NVidia driver fixes the problem.


#6

I’ve installed the previous software and indeed the problem was gone.
Very strange though, I hope they fix this bug soon.


#7

Hi All,

I also have a similar experience. SketchUp worked fine with the same model but is now is extremely slow to orbit. I opened a new blank template- same result. Currently right in the middle of a project and trying to get some extra work in on the weekend; very frustrating. Please help with a fix. I will try to switch from my Nvidia graphics card to the intel card as an another post suggested. Any solutions for be very appreciated.


#8

@justdowd7, did you try rolling back the driver as mentioned above? Go to Start > search for Device Manager > open display adapters > r-click on Nvidia card > Properties > Driver > select the roll back driver option.


#9

For those who may not be aware, Microsoft drivers are well known for causing problems like this. In general they do the job just fine, but they can cause problems with more specialized software programs. If you’re computer is a commercially available model (vs. a custom build or modified system), then it might be worth checking to see if it’s using a Microsoft provided driver or an NVIDIA provided driver. Info is listed on the Driver tab.

For example:

If for some reason you find you have a Microsoft provided driver, then I’d recommend downloading and installing the NVIDIA drivers from NVIDIA.

Same goes for any other device that might be causing system instability… if it’s using a Microsoft driver, then try the manufacturer’s driver. This approach doesn’t guarantee a fix, but it’s a decent place to start with troubleshooting.


#10

I just rolled back the driver update (NVIDEA 860) and sketchup seems to be working properly again. The odd thing is the driver update was on 12/29/2016, and I have used sketchup frequently in the last month without any problems until today…? The driver is currently rolled back to Aug. 2016 update.


#11

Rolling back the driver has resolved this issue for me but I’m now back to having thick lines. Still, at least it works now and isn’t so laggy. Same as justdowd7, I’ve been using this without any issues until today.
Thanks for the advice @ catamountain…