Intel Graphics Driver Update makes SketchUp Slow

I’ve noticed that a recent driver update is causing problems for various clients of mine. One of the most noticeable problems related to SketchUp is that it takes a long time to select objects (up to 2 seconds or more). I’ve rolled back the graphics drivers for several customers and they think I’m a magician (one hired an onsite computer tech with no luck).

So to help everyone I’m posting the steps below for Windows 10.

  1. Start device manager (type ‘Device Manager’ from the start menu)
    image

  2. Expand the Display adapters folder, right click your display adapter and select properties.
    image

  3. Select the Drivers tab and press the Roll Back Driver button.
    image

  4. Your screen will freeze up for about 10 seconds while the driver is being rolled back.

I’ve had this problem for a couple of weeks now. When I followed this guide the ‘Roll Back Driver’ option is greyed out as it is in your screenshots, so I’m not able to fix it this way… Do you have any advice of what else might work?
Thanks

I understand that SketchUp version 2018 offers a fix. The instruction how to apply the fix is in the Release Notes.

Could you post a snip of the relevant portion? A quick scan of the release notes shows that this info is not easily spotted.

Also @maddierai is listed as a Make user. SketchUp 2018 is only available in the Pro version.

It is the first item of the Miscellaneous section:

Miscellaneous
Added a preference to workaround an issue in which selection could be very slow on some Win 10 systems. To set this preference open Command Prompt and enter:
C:“Program Files”“SketchUp”“SketchUp 2018”\jsonpatcheditorPreferences WorkaroundDrawXorRectUseGLFlushNotFlushDraw b true
Note: If you installed SketchUp in a non-default location you will have to update the location above.

1 Like

I just had one of my computers do that after a windows update. Uninstalling the update took care of the issue. If that doesn’t take care of it the next thing would be to try a system restore.

As you can see this computer has had updates turned off for quite a while. After a while you get tired of all the issues that can show up after updating.

I encountered this problem which I think is related one of the Win10 updates around yearend on a SurfaceBook Pro which has a GeForce GPU + Intel 520. In Nvidia control panel (in Win10 control panel) I found Sketchup set to default to the Intel Integrated Graphics. When I switched it to High Performance Nvidia processor, SU the slowness disappeared.

Recent Win10 updates broke other things on my machines including MAPI calls to Outlook.

I just reinstall over the driver with the same driver. as administrator.

1 Like

Could you post the steps for those that may not know how to do that?

step 1 go to intels driver website and find the relevant down load for your hardware and software environment.
step 2 down load it and follow the instructions. Usually I down load files to my “downloads” folder. I right click on the exe. file and select run as administrator. I then follow the screen prompts and hope its fixed when it restarts :slight_smile:

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.