Solution: Sketchup select tool is very slow on Win 10 with Intel HD graphics cards

performance

#1

OK, update as of 23 Dec 2017. Drama!

  1. After using Compatibility mode, Sketchup 2017 Make worked fine…for a while.

  2. Then it went back to the same problem, Select Tool was slow, 7 second delay or so.

  3. Then, about a week ago, Sketchup started working right! I think it was one of the following updates:

  1. Then it stopped working after I installed the major Windows Feature update on 12/22/2017.

  2. I checked the updates, and there was one on 12/22/2017, I believe it was KB4058043. I uninstalled it…and back to working right!

What a roller coaster!

[original post] Run Sketchup in Compatibility Mode. I used Win 8. And it worked when all else had failed. Also found that running the Compatibility Troubleshooter, along with then running the program As Adminstrator, stabilized Sketchup to work right.

image


#2

What version of SketchUp?


#3

2017 Make


#4

I also have occasional issues with the intel graphics HD4000 and a slow selection tool. I used to try and uninstall updates which would temporarily “fix” the problem. I ended up installing a driver install utility from intel and the latest driver which also…temporarily…fix the lagging selection tool. However subsequent windows 10 updates seems to also cause problems so I found that reinstalling the current driver for intel HD4000 repairs it again. I have stopped trying to disable the Win10 updates and I keep the driver and installation utility in my download folder so that when my SU make 2017 starts being laggy again…I run the install tool and reinstall the driver and it works.
Long story short…reinstall your graphics driver.


#5

Could you provide the website or link to the HD4000 graphics driver? Thanks.


#6

I suggest saving it to use again later :slight_smile:
btw the current driver is 10.18.10.4653
However the listed driver down load is noted as 15.33.45.4653
Not sure but I think the notation difference is because the driver packet includes things besides the driver.


#7

Tom I hope you realize your computer might require a different download than mine and the site has several options for you to choose.


#8

My easy solution for the slow select sketchup problem after 2 months of grief is as follows. Type - device manager - in the search box by the start button. Then select “device manager in the control panel”. Then select “display adapters” so the arrow turns down. Right click on your graphics system (card). Choose update driver. Select browse my computer for driver software. Then choose the driver you wish from the list. I choose the one that I knew worked before the problem and it worked!!! Just a few steps as here would have saved 2 months of frustrations. I did not know where to find an older driver and it was there likely all the time.


#9

My own experience is getting weirder all the time. Lenovo P500 core i7Win 10, Intel HD 4000. It was working right for a while after I did the above. Then it just stopped working, about a month ago. Tried everything. Un-updated a Microsoft KB. Not sure if that was what did it, but it worked…for about a week and a half. Then stopped working. Tried everything. Then one time it starts working when I did the Compatibility Troubleshooter. And its still working. For how long…I don’t know.


#10

SU v2018:


#11

SOLUTION FOR 2018 SLOW SELECT TOOL

Hey SketchUp Friends! This topic has gotten quite long, so I’m going to post a recent message in hopes that it will pop to the top and save a bunch of reading.

If you are experiencing a “slow select tool”, meaning when you select an item it seems to take 5 or 10 seconds to respond then you are feeling the effects of a relatively recent Windows update.

There is a patch (batch file) that solves this issue a majority of the time. Using the link below, you’ll find that script. Please note that this is set at the User Account level so it will need to be set for every user on a given computer. Please download the files here: https://goo.gl/rAo1S8

The zip file contains a Windows batch file.

Download the file
Shut down SketchUp
Unzip the file and open the unzipped folder.
Right-click on the WindowsSlowSelectionWorkaround.bat script to “Run as Administrator.”
(If you see a pop-up from Windows Defender, click the “more” link and select “Run Anyway”)
Open SketchUp again and see if selecting is more responsive now.
Hope that helps!
-steve


#12

I wanted to say that I was having this issue also with Sketchup Make 2017 on Windows 10, 16GB Ram, Intel UHD Graphics 620 integraged gfx card. I updated the graphics card driver and it worked perfectly. I noticed that when I tried updating the driver through Intel it either wasn’t the correct driver or didn’t work, but when I tried an older version from Dell’s site (using my laptop asset tag to identify the correct driver) it worked perfectly.


#13

Excellent! Glad to hear it!

Video card drivers can be weird. Back in the days, we would just get them from the card manufacturer’s site then Microsoft added the ability to automatically download new drivers, which was cool for a while but never kept up to date. Now, not only do you need to know the make of model of the card, but there’s also a chance that you’ll need to get the “branded” version of the driver from the computer manufacturer’s website. I think Dell has done that for some systems… HP… Lenovo. I prefer the manufacturer not touch my drivers and just let me get them from Nvidia or AMD.


#14

it’s not simply branding but adjustements required for an appropriate power management and cooling performance adjusted to the capabilities and conditions of the system, typically of notebooks.


#15

I understand how important this piece is in modern times. The new Apple Macbook Pro is a good example of the delicate balance between using the hardware to its fullest and not causing a laptop fire.