(Solved-ish)Going Incredibly Slow

sketchup

#1

Hey guys,

I downloaded SketchUp today to start working on a few home projects, and eventually upgrade to pro to use at work for small drawings on job sites. I’ve used the program before, and it’s always worked very well on other PC’s that I’ve used.

I stared having problems with overall performance immediately after downloading. So I’m hoping someone may have an answer for me, or just be able to tell me that my system just can’t handle SketchUp. Here’s my specs:

  • Intel i5 2.3GHz
  • GeForce 940m With 2GB of Ram (This is a Laptop)
  • 16GB DDR4
  • Windows 10 64-bit
  • 600GB free on my HDD
  • 128GB SSD that is use as bootloader

I ran the SketchUp Check and got no errors.

The application starts fine, but the performance is incredibly choppy. It will take a few seconds to snap to a point, then I can draw a line but it will continuously disappear and reappear until I stop moving the cursor. This also takes a long time, (Around 5 seconds for one line to render, if not longer) My driver software is up to date.

If anyone has any insight into a way to troubleshoot this, it would be greatly appreciated.


#2

11m later and I fixed the issue (sort of)

I found a setting under preferences called “fast feedback” and it instantly fixed my problem.

I am still having the selection problem that everyone else seems to be having, but that’s much less of a concern.


#3

By default, laptops use the integrated Intel graphics chip to save power. Did you go to the Nvidia control panel’s 3D Settings, open the tab to customize the Nvidia card by program and choose the Nvidia card to be used for SU?


#4

As a general rule 2017 needs to have your graphics drivers updated (especially the for the Intel GPU.)

Did you enable or disable fast feedback ?

Did you first try to uninstall the Windows update that e1 else has been having issues with ?


#5

I have already updated my drivers, and set my graphics card to be used over the integrated graphics. I disabled a setting called “Use fast feedback” (Window> Preferences>OpenGL)

It worked instantly. Still having trouble with the select tool running slowly, but not a problem enough to bother me


#6

This is the result of a Windows Update. See:


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.