Sketchup very slow


#1

Hey dear sketchup users, My computer have intel xeon over 4 ghz 6 core, 16 gb ram and nvidia 1070 ti gpu and my sketchup models still lagging. I imported a bigger model like car and i cant even move, i cant open group- it takes about 30 seconds. It is just unuseable. I tryed switch off hardware aceleration and all theese but nothing working. I used to work in more complicated models than this car and it was not that big problem for that pc so i dont undersntad.

Thank you.


#2

Make sure SketchUp uses the Nvidia.
To check: Window->Preferences->OpenGL->Graphic Card details

To set: Rightclick on the desktop and choose the Nvidia control panel
Goto 3D settings and add SketchUp 2018 to the programs that need the ‘Strong Graphics Card’

Apply changes


#3

Since it was mentioned that hardware acceleration was switched off, I don’t think SU’s current version (2018) is being used (nothing under the user’s profile), this feature disappeared when the new internal rendering engine was implemented (I think it was in SU 2017?).

Apart from that, what @MikeWayzovski said should help a little. Unfortunately SU is sensitive to how well / poorly a model has been structured and it is particularly susceptible to higher polygon count modeling.


#4

I am sorry but it has been about a year now since virtually everyone on the planet who uses SU 2017 has been experiencing huge issues with compatibility with Microsoft 10. Even though i am told this is a problem that Microsoft created. At this point SU needs to figure out how to fix the issue in order to make their software viable for commercial use. Our firm (with several offices across the country) is having serious issues with lost productivity. Constant gradual slowing of model performance the longer you a model open, as well as slow processing when you attempt to select an object. Doesn’t matter what settings you pick, or the size of the model (large or small) same results. Sketchup PLEASE FIX THIS…


#5

There were changes made as part of the SketchUp 2018 release to help mitigate the issue created by Microsoft and their neverending updates that break the graphics drivers. If you haven’t upgraded to SketchUp 2018, you’ve been missing out on the fixes that were made to help folks like you who have been getting the short end of Microsoft’s “upgrades”. It’s safe to say there won’t be any changes made to SketchUp 2017 at this point.