Sketchup Running Horribly on my Computer

Hi,

So Sketchup runs very poorly on my system and is barely unuseable.

Specs are:

Intel i7700k OC to 4.8GHZ (This is stable, been running it for 2 years no problems.)
32gb DDR4 3200mhz Corsair Vengence
Aorus Extreme GTX1080ti
Samsung Evo M.2 PCiE 1TB
1440p G-sync Monitor

In preferences, it is registering my GPU. I have tried changing the material to the most basic I could find and it’s still performing badly. The AA is also set to 0 and shadows are off.

I came to the conclusion that it must be the model I am working on. however, and this is the kicker. As a test I opened up the same model on my laptop which has the following specs:

Intel i7 6600u, 16Gb Ram, 256gb SSD, and no discrete graphics.

And it runs fine, with only a few frame drops.

My graphics drivers are all up to date, and I have running benchmarks has shown that PC is performing as it should.

Does anyone have any advice ? This is really frustrating as I can’t find any resources online that shed any light on this.

Thanks!

Is the model file on the local drive ? Ie, don’t open directly from virtual drives / cloud storage.

Check to be sure Windows Update has not replaced your driver with what it thinks is a better driver. (There was a major update recently. I noticed on my machine the menu font settings were reset.)

Did you install SketchUp correctly by right-clicking the installer and choosing “Run as administrator” ?
(If not do so and choose the “Repair” option.)

Also, what does Model Info -> Statistics say about the amount of content in the model?

Thanks for the responses,

The file is on the C: (1TB M.2) and Sketchup is installed on the D: (2TB HDD)

My drivers are all good, I will try reinstalling Sketchup, and seeing if my version is out of date.

As I said, I opened the exact same model on my laptop which is basically just for web browsing and it runs fine. The model is fine.

I’ll have a look when I get home in half an hour, the model does run absolutely peachy on my work laptop, which is basically just for emails and web browsing.

Can you be more specific by what you mean as “poorly” and “barely usable” ?

Constant stuttering, frame drops, frame rate drops to 10 when zoomed out.

It essentially runs about 3 times less consistently than my laptop, which doesn’t make any sense when considering the difference in specs between them respectively.

Desktop AVG FPS 28 MIN FPS 4

Laptop AVG FPS 45 Min FPS 10

This is on the same project, my laptop is set with shadows on and AA on x4 Desktop is set to shadows off and AA to x0

My laptop was plugged into a 4k monitor when testing this, whereas my desktop monitor is only 1440p.

FPS? Is this when running an animation ?

I’m running afterburner to read the statistics when just in the editor. correction I’m gettting a pretty much constant 6 fps when zoomed out, as opposed to 30 on my laptop.

This does not make sense to me. A frame rate only makes sense for video animation or play back.

Could this be caused by Afterburner ? (Thinking out loud.)


A few more questions …

Is SketchUp running on the #1 monitor ?
(I and others have seen issues when trying to run SketchUp on an external monitor which is not the #1 Windows display.)

Do the two displays use differing display scales ?

Is SketchUp on a display that is set to higher than 150% display scaling ?

Thanks for taking the time to help, it’s apprieciated.

So every 3D program where the pc has to draw 3D shapes in realtime will have a frame rate.

It’s how fast the program is running, the same as a video game. Afterburner allows you to see the frame rate of any 3D accelerated application. Turning it on or off makes no difference to performance.

It’s currently running on my primary monitor, my secondary monitor is the same and they both have scaling set to 100%.

I’m going to try reinstalling it.

Are you overclocking the GPU with Afterburner ?

Nope.

Reinstalling it had no affect.

My cpu utilisation sits at 20% and gpu at 4%

Do you have another account to test?

I have seen issues when installed on a D:drive, too

Do you use any plugins? Are they same on both computers? Is the Outliner tray open?

I just reinstalled it on the C: no difference unfortunately

there is a builtin methods for testing FPS in ‘Ruby Console’…

Test.time_display
# my 'slow' nvidia iMac with a simple cube returns
72 frames displayed in 1.4182 seconds
Average frame = 0.0194 seconds
51.4752 frames/second
# shadows on
72 frames displayed in 1.4521 seconds
Average frame = 0.0199 seconds
50.2730 frames/second

john

3 Likes

Ah with profiles on in styles the camera animation f/r is cut in half.

if I enable all the edge styles and a section plane [for good measure] i still get 50.2049 fps…

john