Sketchup not displaying properly on new Dell

I just unpacked my new Dell Inspiron 17 3000 series laptop and one of the first things I did was to download Sketchup 2019 - 64bit version. It is unusable!!. Anyone have any idea what’s going on? This is the only issue with graphics I’ve seen so far. Social media, streaming, websites all display properly. I’m running 8GB ram with Windows 10 64 bit. version

sketchupmess|690x388](upload://tNjR9BU6ElUKqbW6mHMbpWhGOg0.png)

I emailed Sketchup but the etch support is shutdown for the holidays. Any help is appreciated.

Thanks

Cameron

What do you mean? What do you see when you open SketchUp?

Did you install it correctly? That is, did you right click on the installer and select Run as administrator?

Is the GPU listed in your profile the one in this computer? If so, in SketchUp, go to Window>Preferences>OpenGL and untick Use Fast Feedback. Does that help?

FWIW, you should update the graphics drivers with the current versions from the manufacturer. The ones that came with it are almost certainly old.

Hi Dave,

the GPU listed in my profile is the one installed. I checked all drivers and they are current. Hopefully the pic I uploaded is visible

That’s unfortunate. You should read the various comments on the benchmark sites. Integrated graphics are not recommended for SketchUp, especially low end GPUs like the HD620.

How did you check? Did you just let Windows tell you? If so, go to the Intel site and check.

What your screen shot shows is clearly a GPU problem.

Did turning off Fast Feedback change anything?

Fast Feedback was already turned off. I went to the Intel site and tried to update the driver there but the install failed. I think because there must b e a custom driver being used. I may have to look at returning the laptop. According to Setchup this laptop is compatible but if it cant run on it, I dont want it

That might be a good idea if you are able to. Get a dedicated Nvidia card.

From the System Requirements page.

1 Like

Dave,

for fun, I checked Fast Feed back and that solved the problem! Thanks

Microsoft bundles their own version of the Intel graphics drivers with Windows and those drivers are well known to be broken in terms of their support for OpenGL. Even if you could get it to work, very likely the next Windows update would break it again.

If you can return it, take the advice Box gave. Get a computer with a decent Nvidia GTX series card.

Temporary fix, I expect.

It should be ok. With 2019.3 the installer turns off fast feedback if you’re using an Intel GPU, because most Surface Pro laptops would have the issue where the scene was blank. But, some computers have more capable Intel GPUs, and turning off use fast feedback leads to various artifacts.