Not displaying properly


#1

Hello,

Can someone help me with getting Sketchup to work properly on my laptop? I have added a picture how it now looks when I start Sketchup and I don’t know where to begin to solve it.

Thanks in advance.

Frans


#2

We’ve seen this before. It’s related to your graphics card and it’s drivers. Update the graphics drivers.


#3

Thanks Dave for your reply. As far as I came it is my (build in) graphicscard and it is not possible to upgrade. So then No Sketchup on my laptop? Besides the webbased version.


#4

Did you make sure that SketchUp is using the Radeon graphics adapter? If so and there’s no upgrade for it, you could go back to SketchUp 2016 and turn off Hardware Acceleration in Preferences>OpenGL. SketchUp 2016 is available here.


#5

It is the only graphics card, so that must be used I guess.
I’ve had this before: it is a windows 7 laptop, did the upgrade to windows 10 and this was the problem. When I reversed back to windows 7 the laptop was horribly slow. Now a SSD drive is added which helps a lot and I installed Windows 10 again… Maybe also go back to W7.

I will try Sketchup 2016 first, thanks


#6

Okay, re-installed 2016, turned off hardware acceleration in Sketchup and it seems to be working properly. The only thing when I select by click & drag it moves slow and is difficult to get it accurate.