Sketchup running Slow HELP


#1

Hey guys i have a gaming laptop with this system
Win10
Nvidia Geforce GTX 1050
i7-7700HQ CPU @2.8GHZ
16GM Of ram. the laptop is brand new.

when i first use the sketchup everything was ok. but when i added lots of materials to my model it became very slow. i tried to woek on monochrome mood. it halped a little but still i cant work like this… is there any help or suggetion?
Thanks , Matan.


#2

Start with this:

Also update the drivers for your graphics card and make sure that the Nvidia card is the one set as the default for SketchUp.

It may be that your materials are just too much for your graphics card and slowing things down, too.


#3

yeah i guess its the materials. im a student right now and this laptop cost me around 1200$. i thought this one will make the job for this program. anyways i wll try this article. thanks alot anyways :slight_smile:

edit: my card is updated but i dont know how to check if the right card is setup for the sketchup. how do i do that ?


#4

Try r-clicking on the SU desktop icon. With Win10, there should be an option to pick which graphics card you are using through the context menu.


#5

It does seem to be a pretty good system you have there. Model complexity is always a factor of performance, but as it’s a laptop make sure it’s plugged in, if not it may be in power save mode restricting the performance. You could adjust these settings of course in system settings.

I thought I’d mention it as I’ve seen it before.


#6

i will try that !

well the gpu card choose did better now. its running kinda good but still laggy for some.
i will keep with the update.


#7

hey thanks, it fixed the prob. i think i workd the whole time with the intel GPU :joy:


#8

Great, we cannot stress this GPU choice for laptops enough, but do try to keep your graphics driver updated as you were advised too. Although you have a nice graphics card, occasionally you have to update your GPU driver in order for your graphics hardware (which includes monitors) to play nice with other Windows updates in addition to optimizing how SU functions.


#9

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.