Sketchup and Windows 10 - Again

Hi there,
I installed SketchUp 2017 (the free version) on my computer last year. These are the computer specs.
Acer Aspire all-in-one Z1-612
Intel Celeron j3060 (2 cores) running at 1.6 GHz
8 GB ram
Windows 10 home version 1903
Built in Intel HD graphics, I suppose it uses whatever memory it can find, I don’t know!
Like a lot of people on this forum and the Microsoft forum, my SketchUp started to run very slowly a while ago. Whereas when I first installed it, it ran fine. I now dare not go near the toolbar menu to add/delete items. The computer will be unresponsive for one minute. I tried installing SU 2014, it worked OK-ish, but too slow and jerky. I then installed SU 2016. It runs perfectly. I have left 2017 installed in case I need to save any drawings as 2016. According to what I have read on this forum, my computer is not the best to have SU installed. But what this has shown me is that whatever computer you have with whatever state of the art graphics and CPU and lashings of ram, we all share one thing in common, Windows 10. Apparently Microsoft has been aware of the problem since 2017 (the date, not SketchUp) I wonder if we will ever get a fix?

I wouldn’t count on it

SketchUp 2017 and later require a suitable graphics card while 2016 and earlier have the option to make the CPU to pick up the slack for inadequate graphics cards like your integrated Intel HD GPU. Integrated graphics are not recommended at all for SketchUp due to their weakness in proper OpenGL support. Of course it doesn’t help that Windows pushes updated graphics drivers that frequently break things. Best thing to do at least with your existing computer is find a graphics driver that works directly from Intel. Download it and save it somewhere so you can find it again. Then whenever Microsoft pushes an update, roll back the GPU drivers to that saved file.

Better would be to get a computer with a suitable graphics card. I’ve been using SketchUp on Windows since version 3. I’ve always had Nvidia graphics cards and have never seen the slow down reported by Intel GPU users.

1 Like

I have let Windows upgrade my graphics driver, I hadn’t thought of trying Intel directly. I will try this evening.
I was tempted to buy a new computer, it just seemed an expensive move considering it is only SU that struggles. Oh and by the way, when I first installed SU 2017 last year my computer (see above for specs) only had 4GB of ram. I thought that upgrading to 8GB would help. It didn’t!

RAM is useful for some things but the bottleneck is your graphics adapter.

1 Like

What happens when you activate the Eraser tool (E) and start hoovering over entities while holding the leftmouse button down?

If you hit the space bar before you unleash the leftmouse button, you have a selction left.

DaveR. I let Intel look for updates to my system and it recommended an update to my graphics driver. It downloaded the driver and offered to install it for me. I said yes please and it got to about almost installed when it displayed a message that the driver was incompatible with my system. I know when I’m beat, if Microsoft, Trimble and Intel can’t fix this fault then I will stick with the usable not not very wonderful SU 2016.
I will leave SU 2017 on my system in case one of the above figures out how to make it work. I used to use SU 2013 on my old XP computer. I wish I still had the computer and SU 2013.
Thanks for the replies all.
LRW65 (but feeling MUCH older!)

I also had Fusion 360 installed on my computer and it ran perfectly. I just haven’t got the time to learn how to use it. SketchUp is so easy to use.

Sorry to make you feel much older. Unfortunately there’s nothing Trimble can do to fix your inadequate graphics card. SketchUp 2016 at least allows you to use the CPU for rendering instead. Fusion360 doesn’t have the same graphics requirement that SketchUp has.

It might be that restarting your computer and trying again to install the Intel graphics drivers will work. Or it may be that your graphics card is passed it’s use by date and they no longer actually support it. I guess we haven’t learned exactly what model the graphics adapter is yet.

Per …

… it’s the low end Celeron integrated HD Graphics 400 which uses shared system RAM.


On an incredibly low end processor without adequate support. Even every smartphone today is more well equipped by many factors of magnitude.


I have witnessed NO slow down in 3D performance from my Windows 10 (Pro) PC (home PC). I am completely up to date on Windows 10 as well. My PC is not new but an older 4th gen core i5 (quad), 12 gb ram, 512 SATA SSD and Nvidia GTX 650 ti.
Sir, you need a newer and better PC for SU. Stay away from all-in-one units as well. These offer limited ability to upgrade hardware.


I’d say no better than a Chomebook specs.

I have searched for an updated graphics driver with no luck. I started SU 2017 and loaded a sketch that has 200 component instances, 30 groups, 253 component definitions and 24 layers. It is 11 meg in size. I then reduced the profiles setting to 1 and deselected edges. The sketch will rotate very smoothly and fairly fast, I can pan,zoom,delete and push/pull with no reduction in speed. The only thing that has ever caused severe slowness is when I click on View, Toolbars, The toolbar box will open and the cursor changes to an hourglass for 32 seconds before the cursor returns to an arrow. If I then close the toolbar box it disappears and the cursor becomes an hourglass for 36 seconds before the arrow returns. I dare not try and change the toolbar layout, it would take half an hour or more. So far I haven’t found any other problems in SU 2017, there might be some waiting for me, I just haven’t found them yet.
I repeat for those who can’t believe SU2017 runs on a computer of this specification. It does!
LRW65 (Soon to be LRW66):birthday:

LOL happy early birthday! Just turned 48 last week :wink:

Using a fast style for your modeling (work) scene and only using presentation style(s) for output scenes is one facet of a good SketchUp workflow …

To add to what DaveR said about the video drivers, I would stop Windows from using any Microsoft driver updates.

Here’s a link with step-by-step to force windows NOT to update hardware drivers-

It’s always best to use the hardware manufacturers drivers and updates.

I would rather use 2017 than 2016, but 2016 is very stable and fast. I will use 16 until either a fix is found to enable 17 to run as well as it did several months ago, or I will buy a new computer. But £1000 for a computer to run SketchUp that I only use for fun? I think I will keep using 16!
At the moment Intel can’t or won’t update my video driver, even though its own diagnostics app recommends an update and after trying for several minutes can’t finish the job. The computer manufacturer, Acer, has no new drivers for me to download. The driver they have is older than the installed driver. I tried rolling back the previous driver with no change and had to reset the newest (ish) driver. At the moment Windows is the only programme that offers me any sort of driver update.
To have a chance of running SU 2017, or newer, I would have to buy a new computer. My other computer is a 10 year old laptop running XP, and my other other computer is an Atari ST!

It may be possible a fresh install of windoze will help, note I said MAY help.

Thanks, but that’s too much like hard work. And Windows will only find a new way of screwing up anyway!

Hi, i got the same problem on my laptop and desktop computer and it’s a graphic driver problem.
Each Time Windows do an update that will update the graphic driver automatically and SU doesnt work anymore (slow very very very slow).
I have to remove the graphic driver and install the good one.
I found the tip on a thread that explain this issue (sorry i havent the URL)