SketchUp Make 2017 on Windows 10 comes to grinding halt

I am a hobby user and since having landed on SU Make 2017 I have notice a complete breakdown in functionality. After just a couple of minutes of use the software comes to a near grinding halt.
Whether it was windows 10 that messed with SU or the other way around it leaves me without my favorite drawing program.
Is Trimble kind enough to put out a 2020 version of SU Make?
I have tried the pro version and ALL the problems that I have in Sketchup 2017 are fixed!
I would be happy to pay for it but I cannot afford the $299 for one time let alone yearly.
Sketchup is simply Fantastic Software but is it only the pro users that are going to be able to afford it?

Are there any other options?

Joseph

1 Like

Assuming you have a capable graphics card (your forum profile doesn’t say what you have), have you verified that SketchUp is using it? Windows 10 is notorious for resetting to the Intel Integrated Graphics and for installing broken drivers, either of which will seriously mess up SketchUp performance.

Trimble has made pretty clear that they don’t intend to update Make, that the web-based version is the only Free variety they plan going forward.

2 Likes

Thanks for the reply. I have tried 2017 on both a high end Alienware gaming machine and a newer one as well. They both have graphics cards that I believe SU is using.They show up in the preferences/ open GL tab. I’ve never had to change anything there but here’s what they are set to : 4X and Use fast feedback is checked. No open GL warnings and my card is shown in the Graphics Card Details.

The main problem that the large or small, the file start out working great. Rotations and zoom are fast. Eveything works great… but then a lagging sets in. I notice it on selecting and rotating, Undo and Redo, and Saving and loading get reeeealy slow. Processor use isn’t showing unusual activity. It also happens on a tablet that used to work just fine too and it has Intel on chip graphics.

I’ll take any tips.

Thanks.

Joe

Do you have any extension installed?

1 Like

Have you installed SketchUp correctly by right clicking on the downloaded installer and selecting Run as administrator?

2 Likes

I had but have uninstalled all of them and deleted the directory. I have one, DXF import/ export, in 2020 trial.

I did NOT do that. Never have. I’m guessing I should? Any logical reason?

Yes, you should. Not installing it using Run as administrator prevents the program from installing all of the needed stuff. We’ve seen all sorts of odd behavior due to incorrect installation.

Close SketchUp, find the downloaded installer, right click on it and choose Run as administrator. When presented with the options, choose Repair. Make sure you are logged into Windows as your normal user.

2 Likes

I will try and get back to you …hopefully with a lot of smiles !!! : )

No smiles. I reinstalled (I had uninstalled). There was a few plugins in the plugin folder so I deleted it and did a Repair as you described above using “Run as Administrator”.

Start up was normal but I can tell something is not working right off the bat. When I go to View/Toolbars there is a 10 second delay before the spinning wheel stops and I can actually do anything in that window.
Once I load a file the delay is 20 seconds or more. The objects in the files are wayy sluggish to highlight when I click on them and extra slow to open. Rotations are hurkey jerkey. Overall useless.
Bummer. As SU 2020 loaded quickly while 2017 was running and ran the same model flawlessly.
Sketchup 2017 is Broken :cry: :cry: :cry: :cry: :cry:
Thanks for your help and let me know if you think of anything else.

Try changing these.
Also Have you updated the driver for the graphic card? Or rolled back to earlier ones? The specific graphic card driver can make a huge difference. On one machine of mine I had to wait a year for the driver updates to work and had to keep an old one for it to work.
2017 isn’t broken, it isn’t performing well on your specific system, so there is something on your system causing the problem.
Please fill in your profile correctly as it helps us answer your questions.

1 Like

As Box directed, make sure you update the graphics drivers. The graphics card is the primary potential bottle neck and correct drivers are important.

It really would help us to help you if you complete your profile.

Maybe you should look at using SketchUp Free instead. You can be pretty confident there’s not going to be another SketchUp Make version released. There are things you can do with your system, though, that might help.

Getting system info. Thank you for persisting.

OS Name Microsoft Windows 10 Home
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name LAPTOP-L69IGFJD
System Manufacturer LENOVO
System Model 81Q6
System Type x64-based PC
System SKU LENOVO_MT_81Q6_BU_idea_FM_Legion Y545
Processor Intel® Core™ i7-9750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date LENOVO BHCN35WW, 11/23/2019
SMBIOS Version 3.0
Embedded Controller Version 1.35
BIOS Mode UEFI
BaseBoard Manufacturer LENOVO
BaseBoard Product LNVNB161216
BaseBoard Version SDK0R32862 WIN
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = “10.0.18362.387”
User Name LAPTOP-L69IGFJD\josep
Time Zone Pacific Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 8.77 GB
Total Virtual Memory 18.3 GB
Available Virtual Memory 6.36 GB
Page File Space 2.38 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Driver is most current that I know of. System is about 2 months old.
SU 2020 is not as picky about drivers?

Did you try turn off fast feedback or reducing the AA?

From what I read this laptop has a low end graphic card that may not run Sketchup properly.
Sketchup does not recommend integrated intel graphics.
Which is why we keep asking you to fill in your profile info.
Graphic Card=CPU doesn’t tell us anything useful.
But Intel UHD Graphics 630 does.
If you bought this to use sketchup I would take it back and buy one with a dedicated graphics card, specifically Nvidia.

1 Like

Yes it is. It is a known issue. There was a hotfix published but only for SU 2018 Pro.
SU 2019 and later have the fix built in, as well as other performance enhancements.

It would be nice if there were a wider range of product licenses available …

1 Like

Check in the control panel -> hardware list the types of graphic cards.
Maybe you have 2 graphic cards and sketchup using slow integrated graphics.
You can also check with a right click on the sketchup icon if the entry “run with graphic processor” is listed in the popup menu and then select the entry “High performance Nvida” or similar entry instead “integrated graphics”.

I use make 2017 without Problems after changing the used graphic card.

Cheers
Torsten

1 Like

But why would it work great for a few minutes then bog down suddenly? An 2020 works great. Perfectly.

I’m going to get my GP info. And Post it. I thought it was included in system report.

Ahh! So it IS broken?
Any workarounds?

NVIDIA GeForce GTX 1660 Ti

image