SketchUp Make slow on Windows 10


#1

I have updated to Windows 10 (from Windows 7), and SketchUp has become really slow. When I try and move a model the elevations loose their textures temporally, this use to happen a bit with Windows 7 but only on really big models. The model I’m on at the moment started life in Windows 7 and it was fine, I’ve hardly added to it since the upgrade and it’s not a big model. I’ve contacted Microsoft and they say that there’s nothing wrong with Windows and that its something to do with SketchUp. Can anyone help?


Is SketchUp Windows 10 Ready
Speed up SketchUp?
#2

SketchUp 2015 was released in 2014. It cannot possibly support Windows 10, without some updates.

You might have referred to SketchUp Hardware and Software Requirements before you upgraded.

Also see this bulletin by the SketchUp Team:

You might try running SketchUp in Compatibility Mode for Windows 7 or 8.
Right click the SketchUp shortcut, and choose Properties, switch to the Compatibility tab, and select a mode to run in, then click Apply or OK. (No guarantees.)


#3

This thread was started a few days ago if you read along you may draw some info out of it. Or maybe even shoot a PM to @alabamabob2003 who started it and share what you are experiencing compared to his issue. There is some input from a few knowledgeable folks, as for me my smartest move was to avoid the upgrade. I am not a computer geek but something in my gut said stay away as they gave a whole year for the free upgrade. I will see the yea’s vs. the nay’s list after 9 months then decide. Hope it works out for you…Peace…


#4

Hi Dan,

Thank you for your reply. my hardware is compatible because it worked fine on Windows 7. Its a shame that SketchUp could miss out if it won’t be compatible with Windows.
I have tried running it in compatibility mode (for Windows 8) but it doesn’t have much effect, thank you though :smile:


#5

Hi mrwmrutski,

Thanks for passing on the thread :smile:


#6

That’s a short conclusion. Whether something works completely can only be determined by infinite testing. Since Windows 10 has its own drivers, it may still be possible that drivers are not yet well optimized as the Windows 7 ones.


#7

I installed Win10 on my home computer last week end. What I noticed was that right after the upgrade Windows was using it’s basic driver. I had to fetch another update to get the appropriate nVidia drivers. One the drivers was running everything was back to normal again.

Did you check if there are updated drivers for your graphics card - for Win10?


#8

Hi, sorry I didn’t see your post! what are nVida drivers?


#9

[quote=“nathanaeldgw, post:8, topic:14295”]
what are nVida drivers?
[/quote] If you have an Nvidia graphics-card then it has ‘drivers’ which set up how it works.
Whenever an OS is upgraded or a new version is released the drivers are updated…
So you need to go to the vendor’s website and check if your card has a newer driver.
Most GC suppliers have updates for their cards’ drivers to catch up with Win10’s vagaries.
Installed the latest driver and see if that helps with SketchUp.
Also check the GC’s control-panel to see if it’s set up to let the 3d program to choose its own settings - the best option…


#10

Why not go back to Windows 7. If you can , but of course MS has set things up so you cannot do that easily depending on the SkU version .
Trimble has been up front with what version they support so I guess you should chastise the person in the mirror for the situation you are presently in.
BTW MS almost always hides things in their releases buried usually under security updates they do not explain in their release notes.
I’ll bet you do not know they use you computer to help distribute 10 update world wide?
BTW those of you who want to remove the Windows update nag screen , delete KB3035583.


#11

Hi, thanks for the info :slight_smile: I have just checked for updates to the drivers, but they are already up to date. Is there anything else that I could try?


#12

Nathan;
This will require some effort on you part to understand what you see , but may give a clue into what is going on. I am still at W7 so hope MS has kept this capability;
During the problem time;

  1. open task manager.
  2. At bottom of its screen select resource monitor
  3. That will open up several split screens allowing to view a number of resources your machine is using.
    Suggest you read the help files to clues on how to trouble shoot issues;
    Please update your profile. That would help us under stand your system better.

#13

Here is a screen print of my "split screens

"


#14

I find that display is not much help in trouble shooting. It does not help me , but good news it appears you got there via the resource monitor correct?
Go the righthand screen and you can suppress that display and then you will have the actual PIDs and much more usable info.
One key item to watch for is a red highlight in the image colum. That will be a flag some process is wating for another to complete before it continues to process . PLS update your profile


#15

which video card (make & model) and driver version do you use?

search and run “dxdiag” and post a screenshot of the display tab.


#16

Is an Intel® G33/G31 Express Chipset Family
I have checked the Intel website and there are no updates for me.


#17

no OpenGL hardware acceleration with the native legacy drivers of Windows 10:

Graphics drivers that come with Microsoft Windows or that are downloaded from Windows Update typically do not support OpenGL.

you therefore may want either go back to Windows 7:


or (if a desktop) plug-in a dedicated video card as e.g. the fine GeForce GTX 750Ti or better (which depends on available space and wattage of power supply unit).


#18

Hi, I’m running Windows 10, since I upgraded (from Windows 7) SketchUp (Make 2015) has been stupidly slow, is there any way that I can speed it up and make it usable? Thanks :smile:


#19

Have you tried to find a solution in the forum? There are a lot of topics about Win10 already…


#20

Yes I have, but nothing seams to help