SketchUp Make 2017 on Windows 10 comes to grinding halt

SU 2017:

SU 2020

Both running together. 2017 lagging while 2020 running perfectly

? What is AA?

Acronym for “multisample anti-aliasing”

Oh. Duh. the 4x4.

Is your model large? Is Autosave turned on? Where are you saving? Not to a cloud storage service?

1 Like

I’ve tried large and small models. Files save locally. Backed up to cloud but there’s no lag there until things really go to heck…usually after a few minutes of working on a model.
The quick way for me to see the misbehavior is to open the Toolbar preferences…lags immediately when program opens. At 1st “Make component” works great then it takes FOREVER to make simple components. Everything just bogs.

So, Crazy thing. I did all the following:

Installed as administrator but that didn’t fix the problem.

Updated my driver…again since I got it 3 months ago.

In the shortcut properties I changed:
.
Turned off compatibility mode (windows 8) . I had tried compatibility mode previously and that hasn’t worked.
Unchecked a box that adjusted the DPI settings. (something compatibility mode tried to adjust? )

Anyway, I don’t know what changed things (some will say the new video driver ). I wish I knew so that I could help the next guy. But I’m very happy right now : )))))

Thank you for all your input. I appreciate your time. Can I change my original post to “Win 10 Broke SU 2017” ?

Let me guess.

Driver just came out. My software, at least, just informed me. Maybe others were having problems like mine. So, I don’t really know. But I’m happy someone advised me to check. Thank you guys.

Now I just have to work on my older computer…Same thing since Win10.

Always check from the actual website of your graphic card for updates. Never rely on windows.
Often drivers are released but not pushed even by the graphic card software.

Good advice. My Lenovo app must not have been getting the newest either. So I would guess that it was the Win10 update that changed sum’thin. And, I hope it stays this way cuz if it isn’t the driver for some reason then I’ll just go nuts.

Hi,
what is your detailed configuration when you mentioned that the .skp files are saved locally but backed up to the cloud?
Do you use OneDrive or Google drive directly on those folders ? This could be an issue.

The way l understand this issue is pretty simple. What’s happening, as l recall, is that SketchUp is using your CPU instead of your Graphic Card to process the graphics. I had this issue a few versions back. I recall right clicking on the graphics card icon to set the card to be the graphics processor, not the CPU. It was a simple click.
.

Evidently your recollection is in need of updating.

From the release notes for SU2017:

Graphics Pipeline

With SketchUp 2017, we have completely reworked our graphics pipeline - i.e., the way we display SketchUp models. This was a massive change that will allow us to innovate far beyond what we have been able to do in the past.

This new graphics pipeline has stricter hardware and software requirements than in previous versions of SketchUp. To run SketchUp, you will need:

  • A 64-bit operating system.
  • A graphics card that supports OpenGL 3.0 or above.
  • A graphics card that supports Hardware Acceleration. We will no longer support software rendering! [This means no CPU rendering available in SketchUp 2017 and later.]
  • A graphics card that passes a series of tests that are run by SketchUp 2017 to assure that your card is capable of rendering SketchUp models. These tests include checks like compilation of SketchUp’s GLSL shaders and support for OpenGL framebuffer objects.

If your machine does not meet these requirements, you will see an error dialog when launching SketchUp, LayOut, Style Builder, and Viewer that lets you know which requirement you did not meet and which will prevent you from running SketchUp until you fix the error. If you see this error dialog, try upgrading your graphics card driver - upgrading your driver is a good first troubleshooting step and often solves the error.

Thanks for the update. Apparently I haven’t had to deal with this issue in quite some time. That’s good!